LinHES Forums

R6 SBE install breaks MBE
Page 1 of 1

Author:  lusid [ Tue Nov 10, 2009 11:28 pm ]
Post subject:  R6 SBE install breaks MBE

I've had my R6 MBE running for a couple of months now, along with a frontend only install, with an HDHR and a central NFS share for recordings. Today I finally got around to installing an R6 SBE, and the results were pretty ugly.

During install I picked SBE as the system type, assigned a unique hostname, and the installer found my MBE and the NFS share. Everything seemed fine. It launched myth setup after first boot, I looked through the screens and aside from it wanting to reconfigure my HDHR tuners on the SBE everything seemed fine. I could play my existing recording, but had no livetv. I didn't have time to work through it so I shut it down.

Then I went back to my frontend only install, started it up, and it had lost all of its settings. I moved to the master backend, it too had lost all of its settings. I reconfigured the front end settings, got back into the FE install only to discover livetv no longer worked there either.

I went into myth setup, and had no tuners. I had to reconfigure the HDHR on the MBE. I thought I had done something wrong, so I repeated the excercise on another machine. Built a SBE, and had the same issues again. So I double checked the system type on the SBE, and it was set to MASTER backend. I check the system type on the front end, which now thought it was STANDALONE.

Am I missing some important step setting up an SBE? How do you configure an SBE without killing the MBE?


Author:  jams [ Thu Nov 12, 2009 10:13 pm ]
Post subject: 

This shouldn't have happened, adding an SBE hasn't been tested in a while but it all worked last time I looked.
I will take a look at this, but just to clarify this is your setup.
1) ONE MBE without FE
2) FE only
3) SBE without FE

Author:  Too Many Secrets [ Fri Nov 13, 2009 6:18 pm ]
Post subject: 

I've seen this as well. Just figured I borked it on my own.

MBE/FE and SBE/FE (with NFS). It came when I lost a HDD and had to reinstall SBE. database got skewed and ip addresses ended up backwards. I had to power off the SBE to get into the MBE from LinHES config. It wanted to go to the wrong BE. Very frustrating at 1am, but I am still not convinced it wasn't sumthin' I dun...

Author:  lusid [ Fri Nov 13, 2009 10:02 pm ]
Post subject: 

My setup was:

One MBE with FE, and One FE.

Then I tried to add an SBE.

By the end my system was fully roached. I ended up killing the SBE, backing up the recording related tables, restoring the MBE from a 2 week old snapshot, flushed the old tables, reimported the current tables, and ran a commflag rebuild.

I still have issues with playing back some of my recordings over UPNP because the hostname of the recording owner in the recording tables is inconsistent, but I think I can patch that up in SQL.

I think I'll hold off for a .22 release and a free weekend before I attempt this again.

Author:  dfdario [ Wed Jun 09, 2010 5:17 am ]
Post subject: 

Since I am having the same problem, did you sove it?
I fresh installed 6.03 MBE/FE and all working properly. When I try to add an SBE/FE I experience the same issue as above.
It also happened me with 6.02.
Any suggestion?

Author:  dfdario [ Thu Jun 10, 2010 12:00 am ]
Post subject: 

>>>> Moved to LinHES installation >>>>

Page 1 of 1 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group