View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 8 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sun Sep 30, 2007 12:09 pm 
Offline
Joined: Sun Feb 19, 2006 7:52 am
Posts: 5
Location: Round Rock, TX
Just spent the last 24 hours installing/reinstalling R5F27 to get schedulesdirect working. Using pvr-350, tv-out works out of the box. Despite setting preset channel to 3 and external channel change command to /etc/irblaster/change_channel.sh, myth does not set the tuner to 3 or use change_channel.sh. When watching tv, all I get is gray noise. By using ivtv-tune to set the tuner to 3, I get the broadcast. And using change_channel.sh, I can tune the satellite box.

This hardware was working on a previous version of knoppmyth (not sure which, from maybe Feb 2006). Luckily I'm installing on a new hard drive so I can just pop the old one back in, but tv listings aren't working thanks to zap2it.

Also not getting sound out from looping pvr-350 rca jacks back into sound card, but haven't really configured that yet.

Any help resolving these issues would be greatly appreciated.

Thanks,
John Helms


Top
 Profile  
 
 Post subject:
PostPosted: Sun Sep 30, 2007 1:35 pm 
Offline
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
Have you been through the R5F27 Hints and the Troubleshooting pages on the wiki? Both cover a number of know issues with PVR cards and the ivtv drivers.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Sep 30, 2007 2:46 pm 
Offline
Joined: Sun Feb 19, 2006 7:52 am
Posts: 5
Location: Round Rock, TX
I had been through the troubleshooting guide and adjusted the buffers on the pvr-350 due to errors in dmesg. I had not seen the R5F27-specific hints, but none of them seems to apply to this situation. The channel frequency table is us-cable as recommended in one of the guides when using an external tuner. The capture card is type MPEG-2 encoder (pvr-x50, pvr-500), default input is tuner1, video device is /dev/video0. There does seem to be a bug in the input priority field of the input connections section as you can't enter a value or tab past that field.

Once I have manually tuned channel 3 using ivtv-tune, the video is great. But I can't change channels through the remote. It looks like it's about to change channel (video pauses), but nothing happens. The irblaster does not blink and the card tuner doesn't change either. So it stays on whatever channel the satellite box is on. I can change the channel using /etc/irblaster/change_channel.sh just fine. If I knew what script/executable mythtv is calling to change channels, I could probably soft link it to change_channel.sh and put ivtv-tune -c 3 in rc.local and be done.

I see several scripts/binaries in /usr/local/bin:
root@helmsdvr1:/var/log# cd /usr/local/bin
root@helmsdvr1:/usr/local/bin# ls -l | grep -i channel
-rwxr-xr-x 1 root root 691 Dec 9 2006 change-channel-lirc.pl
-rwxr-xr-x 1 root root 374 Dec 9 2006 change-channel-lirc.sh
-rwxr-xr-x 1 root root 5456 Dec 9 2006 changechannel.py
-rwxr-xr-x 1 root root 24296 Dec 9 2006 channel
root@helmsdvr1:/usr/local/bin#

I tried changing the channel and then ls -lutr to see if one of these was being used, but apparently not.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Sep 30, 2007 7:43 pm 
Offline
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
What does:
Code:
ls -al /etc/irblaster/change_channel.sh

show on your box? I don't even have that directory. What are the contents of the file?


Top
 Profile  
 
 Post subject:
PostPosted: Sun Sep 30, 2007 9:01 pm 
Offline
Joined: Sun Feb 19, 2006 7:52 am
Posts: 5
Location: Round Rock, TX
Sorry, had to put old drive back in to get it up and running for the wife. But I copied the /etc/irblaster dir to a flash drive before shutting down. Here is a listing from winxp cmd:

Directory of E:\helmsdvr2\etc\irblaster

09/29/2007 08:18 PM <DIR> .
09/29/2007 08:18 PM <DIR> ..
09/29/2007 08:19 PM 248 channel_change.sh
09/29/2007 08:19 PM 151 hardware.conf
09/29/2007 08:19 PM 2,756 irblasterd.conf
3 File(s) 3,155 bytes
2 Dir(s) 644,726,784 bytes free

I think this was created when the auto-install asked if I had an IR blaster. BTW, I'm doing a fresh auto-install on that separate drive and NOT doing any type of recovery from backup. Thought it would be easier/safer than trying to fix all of the incompatibilities.

One thing that popped into my head is that the lowest channel populated from schedulesdirect is 7. Don't know if this would prevent tuning to ch 3 (output ch from dish 301).


Top
 Profile  
 
 Post subject:
PostPosted: Sun Sep 30, 2007 9:03 pm 
Offline
Joined: Sun Feb 19, 2006 7:52 am
Posts: 5
Location: Round Rock, TX
Sorry, also forgot to post change_channel.sh contents:

E:\helmsdvr2\etc\irblaster>more channel_change.sh
#!/bin/bash

# Automatically Generated by /usr/local/bin/irblaster.sh

echo Changing to $1

REMOTE_NAME=301

for digit in $(echo $1 | sed -e 's/./& /g'); do
/usr/bin/irsend --device=/dev/irblasterd SEND_ONCE $REMOTE_NAME $digit
sleep 0.7
done


E:\helmsdvr2\etc\irblaster>


Top
 Profile  
 
 Post subject:
PostPosted: Sun Sep 30, 2007 10:15 pm 
Offline
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
jhelms wrote:
Sorry, had to put old drive back in to get it up and running for the wife. But I copied the /etc/irblaster dir to a flash drive before shutting down. Here is a listing from winxp cmd:

Not terribly useful. I was hoping to be able to verify the file ownerships and permissions. :?


Top
 Profile  
 
 Post subject:
PostPosted: Mon Oct 01, 2007 5:31 am 
Offline
Joined: Sun Feb 19, 2006 7:52 am
Posts: 5
Location: Round Rock, TX
It did occur to me that being in /etc, it might not be accessible to non-root users. But I ran change_channel.sh as my personal account (jhelms) and it worked fine. Didn't try it with mythtv account, but assumed it would work. I might be able to experiment some more tonight (Monday 10/1). If you think of anything else to look at/try, I'll give it a shot.

Thanks,
John Helms


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: Google [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu