LinHES Forums

lirc mouse daemon
Page 1 of 1

Author:  footeo [ Sat Jan 17, 2009 9:36 pm ]
Post subject:  lirc mouse daemon

Has anyone got the mouse daemon to work with lirc? Specifically I would like to control the mouse with my ATI Remote Wonder II. I found a lircmd.conf file on another forum but it isn't clear to me how the button names relate to anything or if they are supposed to match up with the settings in /etc/lircd.conf. Any help or guidance would be appreciated.

Author:  sinspot1 [ Sun Jan 25, 2009 5:59 pm ]
Post subject: 

I have also been tring to figure that out and have not had any luck. So I could use my remote with Miro.

Author:  footeo [ Sun Jan 25, 2009 10:14 pm ]
Post subject: 

I have actually got it to work now and I will post what I have. My settings may be slightly unique as I used irrecord to generate my own lircd.conf file for my remote to get the diagonals of the mouse button to work. I haven't actually tried it with Miro but, I will give it a try in the morning and try to post a how to if it works alright.

Author:  elgordo123 [ Wed Jan 28, 2009 3:20 pm ]
Post subject: 

Would love to see these instructions too. I tried to get that to work a long time ago too. No Dice.

Author:  footeo [ Wed Jan 28, 2009 10:11 pm ]
Post subject: 

Ok, these are the basic steps you need to take.
First edit xorg.conf add the InputDevice "LIRC-Mouse" to the ServerLayout section:
Section "ServerLayout"
        Identifier     "XFree86 Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
# PS/2 Mouse not detected
        InputDevice    "Serial Mouse" "CorePointer"
        InputDevice    "USB Mouse" "CorePointer"
        InputDevice    "LIRC-Mouse"

Then add the following Input device section:
Section "InputDevice"
        Identifier "LIRC-Mouse"
        Driver "mouse"
        Option "Device" "/dev/lircm"
        Option "Protocol" "IntelliMouse"
        Option "SendCoreEvents"
        Option "Buttons" "2"
        Option "ZAxisMapping" "4 5"

Then you need to edit /etc/lirc/hardware.conf and uncomment the START_LIRCMD=true to make the daemon start when lirc is started:
#Don't start lircmd even if there seems to be a good config file

Next you will need a lircd.conf file that has the directions of your mouse set. If you don't have a mouse arrow control on your remote you can set up a toggle button that will enable/disable your number keys to operate as the mouse. I ran irrecord to generate my own specific lircd.conf since my original did not have the diagonals. You will need to kill lircmd as well as lirc before you run irrecord. You may have success just running irrecord without any arguments but I needed to specify the correct device using irrecord -d /dev/lirc0 temp_lircd.conf. After following the onscreen prompts you will generate a file temp_lircd.conf in the current directory. Then backup your existing lircd.conf mv /etc/lircd.conf /etc/lircd.conf.bak and then move the created file: mv temp_lircd.conf /etc/lircd.conf . My lircd.conf is as follows:
# Please make this file available to others
# by sending it to <>
# this config file was automatically generated
# using lirc-0.8.3-CVS-pvr150-2(default) on Mon Oct 20 20:03:40 2008
# contributed by
# brand:                       test.conf
# model no. of remote control:
# devices being controlled by this remote:

begin remote

  name  test.conf
  bits           24
  eps            30
  aeps          100

  one             0     0
  zero            0     0
  gap          203979
  toggle_bit_mask 0x0

      begin codes
          A                        0x000278
          B                        0x000279
          POWER                    0x00020C
          DVD                      0x000238
          TV                       0x000239
          QUESTION                 0x0002BE
          MAXIMIZE                 0x0002D5
          HAND                     0x0002D0
          ATI                      0x00028E
          MOUSE_LEFT_BTN           0x0002A9
          MOUSE_RIGHT_BTN          0x0002AA
          MOUSE_UP                 0x0001FF
          MOUSE_LEFT_UP            0x0021FF
          MOUSE_RIGHT_UP           0x0011FF
          MOUSE_LEFT               0x0020FF
          MOUSE_RIGHT              0x0012FF
          MOUSE_DOWN               0x0002FF
          MOUSE_LEFT_DOWN          0x0022FF
          MOUSE_RIGHT_DOWN         0x0012FF
          VOL_UP                   0x000210
          VOL_DOWN                 0x000211
          MUTE                     0x00020D
          CH_UP                    0x000220
          CH_DOWN                  0x000221
          1                        0x000201
          2                        0x000202
          3                        0x000203
          4                        0x000204
          5                        0x000205
          6                        0x000206
          7                        0x000207
          8                        0x000208
          9                        0x000209
          MENU                     0x000254
          0                        0x000200
          CHECK                    0x000282
          CLOCK                    0x000296
          ARROW_UP                 0x000258

          INFO                     0x0002F9
          ARROW_LEFT               0x00025A
          OK                       0x00025C
          ARROW_RIGHT              0x00025B
          ARROW_DOWN               0x000259
          C                        0x00027A
          D                        0x00027B
          E                        0x00027C
          F                        0x00027D
          REW                      0x000229
          REC                      0x000237
          PLAY                     0x00022C
          PAUSE                    0x000230
          FF                       0x000228
          STOP                     0x000231
      end codes

end remote

Next you will need to create a lircmd.conf file to specify which buttons opperate the lirc mouse. Mine is as follows:
# To find out how to get a proper configuration file please read:
#   /usr/share/doc/lirc/README.Debian

PROTOCOL IntelliMouse


Notice that the names for the buttons match what is in the lircd.conf file so, if you didn't have to use irrecord check what the button names are in your existing lircd.conf. I also have an activate button set up which could be a TOGGLE_ACTIVATE button instead in lircmd.conf.

That should be it. I believe you can just restart X to get it to run but, you may want to reboot to make sure.

You may want to add some other buttons like tab and enter to run Miro or other apps more efficiently in /home/mythtv/.lircrc file. I also never set up a wheel button. Most of this info came from here which should answer a lot that I have left out. Let me know if this works alright.


Author:  smartel [ Mon Apr 05, 2010 3:32 pm ]
Post subject: 

Anyone had this running with R6?

I got as far as modifying xorg.conf,
copying the lircmd.conf from /usr/share/lirc/remotes/hauppauge/lircmd.conf.hauppauge to /etc/lircmd.conf

I didn't find /etc/lirc/hardware.conf to start the daemon, but am able to start it manually with:
/etc/rc.d/lircmd start

seems to start, but messages.log complains that:

pr  5 15:48:58 Linhes mythfrontend: (EE) xf86OpenSerial: Cannot open device /dev/lircm
Apr  5 15:48:58 Linhes mythfrontend:    No such file or directory.
Apr  5 15:48:58 Linhes mythfrontend: (EE) LIRC-Mouse: cannot open input device
Apr  5 15:48:58 Linhes mythfrontend: (EE) PreInit failed for input device "LIRC-Mouse"
Apr  5 15:48:58 Linhes mythfrontend: (EE) config/hal: NewInputDeviceRequest failed
Apr  5 15:48:58 Linhes mythfrontend: (EE) config/hal: NewInputDeviceRequest failed
Apr  5 15:48:58 Linhes mythfrontend: (EE) config/hal: NewInputDeviceRequest failed

how do I add this device? I have done a ls /dev/lirc* and it shows,
and that's where I'm stuck, any help is welcome!


Author:  footeo [ Thu Apr 08, 2010 1:17 am ]
Post subject: 

I haven't been able to get it to work in R6 and haven't really spent too much time since I first installed R6 trying to figure out how to get it to work. I wasn't having a lot of luck getting the daemon to load on boot. There may be some info out there specific to Arch that would work. I have been using vnc and my laptop if I have needed to use my mouse lately.

Page 1 of 1 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group