LinHES Forums

XBMC mythbox front end (Apple TV Gen 1) [SOLVED]
Page 1 of 1

Author:  gatorback [ Sun Apr 03, 2011 12:34 am ]
Post subject:  XBMC mythbox front end (Apple TV Gen 1) [SOLVED]

I installed mythbox on XBMC \ Apple TV Gen 1. I am having difficulty configuring it:

When I click the 'Test settings' button, it returns and Error: connetion to MythTV host failed: (22, 'Inv...

When starting the XBMC mythbox it returns a similar error: "connection to mythTV host Invalid Argument."

Setting I have changed:
Database Password

No changes to:
Port = 3306
Database name =mythconverg
User = mythtv

Has anyone had success configuring XBMC mythbox frontend with LinHES 6.0X? If so please weigh in with lessons learned. Thank you.

Author:  RobTheGob [ Thu Apr 14, 2011 9:13 pm ]
Post subject: 

I installed Mythbox on my AppleTV/XBMC today. I'm running LinHES 6.04? (MythTV 0.24). I had no issues - but it was a PITA to add all my 7 storage groups using the Apple TV remote!

I'm not sure where your problem is - but I'd look closely at the hostname/address, since the "localhost" part of your error message looks odd...

I'll have to try Mythbox a bit - I hadn't heard about before this (thanks!). I had stopped using the myth:// protocol a while ago and just use a smb:// mount pointed at the "pretty" directory. I really only use the Apple TV to watch news a night - so pretty works well for me... I do like the big icons on the recording page in Mythbox.

Author:  gatorback [ Mon Jun 06, 2011 7:43 pm ]
Post subject:  hostnames: mythtv. vs mythtv

I noticed that the mythbox setting for:

MythTV => Master Backend Hostname = mythtv /

When I am in my AppleTV, mythtv does not resolve to an IP address whereas mythtv. does resolve:

-bash-2.05b$ ping -c 3 mythtv
ping: cannot resolve mythtv: Unknown host
-bash-2.05b$ ping -c 3 mythtv.
PING mythtv ( 56 data bytes
64 bytes from icmp_seq=0 ttl=64 time=0.329 ms
64 bytes from icmp_seq=1 ttl=64 time=1.106 ms
64 bytes from icmp_seq=2 ttl=64 time=0.233 ms

--- mythtv ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.233/0.556/1.106/0.391 ms

Because the "test settings" menu item returns: "Error: Connection to MythTV host failed (22, 'Inv..." my initial reaction is to try to change the hostname to from mythtv to mythtv.: not really sure if should be of the format: 192.168.X.Y. Why would you use localhost? This parameter is greyed out and it does not like this option can be edited.

Here is a list of my configuration parameters:

MySQL DB => Hostname = mythv.
MySQL DB => Port= 3306
MySQL DB => Database Name = mythconverg
MySQL DB => User = mythv
MySQL DB => Password = mythv

MythTV => Master Backend Hostname = /
MythTV => Master Backend Port = 6543
MythTV => Enable Streaming = White dot (not selected?)
MythTV => Local Recording directory(s) = /change/me
MythTV => Confirm on Delete = white dot (not selected?)
MythTV => Enable aggressive checking = grey dot (selected?)

Fan Art => All are white Dot

Test Settings => Error, Connection to MythTV host failed: 22, "INv...

Advanced => Enable debug logging = white dot
Adavanced => Twitter Feeds = mythboxfeed

About: Mythbox for XBMC 1.0.3

@robthegob: does these parameters match with your configuration?

I decided to add the following line to etc\hosts on the Apple TV:

Code:  mythtv

After this change, the ATV can resolve the hostanme mythtv (sans period):

-bash-2.05b$ ping -c 3 mythtv
PING mythtv ( 56 data bytes
64 bytes from icmp_seq=0 ttl=64 time=0.877 ms
64 bytes from icmp_seq=1 ttl=64 time=0.498 ms
64 bytes from icmp_seq=2 ttl=64 time=0.348 ms
--- mythtv ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.348/0.574/0.877/0.223 ms

Rebooted ATV.

The mythbox paramater MYSQL_DB => Hostname now accepts mythtv (sans period).

I observed that that these two parameters would 'grey out and have no values' when I removed the '.' after the hostname (mythtv) in the paramater MYSQL_DB => Hostname = mythtv (sans period):

    MythTV => Master Backend Hostname =
    MythTV => Master Backend Port =

I have to decide whether to include the '.' after the hostname for the paramater: MYSQL_DB => Hostname. For now I choose to include the '.' in the hostname because it corresponds to ensuring that the MBE Hostname and ports have values.

Both sceneraios result in the same error when "test settings" is invoked. Interestingly enough, after "test setting" is invoked, the parameters for MBE hostname and port are disappeared and the same error is invoked.

Here is the pastebin from my initial post: Mythbox Log Pastebin

After verifying that the database name, user & pw are valid:

[root@mythtv ~]#  mysql --user=mythtv --password=mythtv mythconverg
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 2797
Server version: 5.0.75 Source distribution

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.


I think that I have exhausted tinkering with the configuration paramaters (I am hoping that I am wrong and that someone will point out something else that can be tried. In particular, I do not know of a good test to verify that the MBE port is 6543 (seems moot, considering that this is not something that can be configured) and I think that 3306 is working because I was able to extract a database ERD out of this port using Embarcadero.

Can anyone comment as to why localhost ( was automatically configured, when the hostname is user supplied?

Author:  RobTheGob [ Mon Jun 06, 2011 9:21 pm ]
Post subject: 

My settings:

Hostname mythv (no period)
Port 3306
Database Name mythconverg
User mythtv
Password mythv

I used Mythbox for a few days - but found it was "rebuffering" often and that killed it for me. The extra overhead of running this way compared to my Samba share method was just a little too much for the WiFi connection.

Also - on the MythTV page - my Mythtv Backend hostname shows the address being resolved properly.

Author:  gatorback [ Tue Jun 07, 2011 12:59 am ]
Post subject:  Mythbox is now working: Change to MythTV was required.

After reading this article:

and making the following modifications in LinHES 6.02:

ALT-S => General Settings
Local Backend = 192.168.8.X
Master Backend = 192.168.8.X

Mythbox seems to work nicely. The commercial skipping is heavenly and I can now watch TV over the network. Super handy for 'pumping' live TV to an extended LAN. Thank goodness this place has wired ethernet in every room (CAT5E was originally wired in each room for telephones), so there is no lag.

Author:  RobTheGob [ Tue Jun 07, 2011 9:54 am ]
Post subject: 


I was quite happy with it as well. We only use the Apple TV for about 15-20 minutes a day to watch the news at night, so I doubt I'll try to get wires to it...

Page 1 of 1 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group