LinHES Forums

Problems installing R8.0 (Solved)
Page 1 of 1

Author:  goofee [ Tue Mar 18, 2014 11:51 am ]
Post subject:  Problems installing R8.0 (Solved)

So I have a backend and 2 frontends all running the same hardware except the frontends have the sparkle 8400 NVidia card. A few months ago I had a hard drive failure on the backend and at that time upgraded the backend to 8.0. I left the frontends on 7.4 cause I didn't have time to do a complete reinstall required with the new partitioning format. No problems.

I found some time and some different drives and thought I would tackle the frontends. First off it would not boot from the cd or usb stick. It would get to "loading udev modules" then the computer would restart itself. I suspected user error and tried several times crossing my fingers in various fashions to no avail. Finally while wondering what was different from the backend install, I pulled the NVidia card and connected a monitor to the onboard intel adapter. Installed and ran perfectly. Great! Thought I would reinstall the video card and load some different drivers. With the video card installed and booting from the hard drive, the computer reboots at the same point it did while booting from the install media.

Now I'm really lost. Any ideas?

Author:  RacerX [ Tue Mar 18, 2014 11:15 pm ]
Post subject:  Re: Problems installing R8.0

Are the old drives IDE and the new ones Sata? It could have messed with your boot order in bios. Another thought go into bios and check the time. If it says year 2000 the battery is probably dead. I never had much luck switching video cards on the fly like that. I would say check out your bios and then try reloading the FE from scratch.

Author:  goofee [ Thu Mar 20, 2014 9:18 am ]
Post subject:  Re: Problems installing R8.0

The drive swap was so if it didn't work out, it was easy to revert with little down time. Appears to have been a good idea at this point. :) Also moving to a larger drive as I was getting disk full warnings at times. They are all IDE drives in this experiment. BIOS battery seems to be ok as the time is accurate and held through several power disconnects. I downloaded 8.1 and it wouldn't boot from that disk either. Got to the same spot and reset itself. Wonder if its time to look for newer hardware.

Author:  RacerX [ Thu Mar 20, 2014 10:19 am ]
Post subject:  Re: Problems installing R8.0

Ok so bios looks good, could you boot with the minimum of hardware? For the test get rid of everything usb but keyboard or mouse. Test with the R8.1 cd, there are big changes in the kernel since R8. What kind of MB do you have?

Author:  goofee [ Fri Mar 21, 2014 1:26 pm ]
Post subject:  Re: Problems installing R8.0

Its something to do with the video card cause it works with it removed for R8.0 and R8.1 but not with it installed. Its a Sparkle SFPC84GS512U2LP GeForce 8400 GS Video Card. The computer is a Dell OptiPlex GX520. Service tag 4RW42B1 if you want to check all the specs. Could it be related to LinHES switch to 64 bit? This combo has been working fine for years.

Author:  mattbatt [ Fri Mar 21, 2014 3:41 pm ]
Post subject:  Re: Problems installing R8.0

Have you checked that the bios is set to use the video card and not auto or the internal I know my bios has an option.

Author:  goofee [ Sun Sep 28, 2014 5:01 pm ]
Post subject:  Re: Problems installing R8.0

So I couldn't figure this out, ran out of time and gave up for a while. Recently had some more time to play and discovered that adding
to the boot parameters has cured the problem perfectly. So it seems it was a video problem. If I understand what I was reading, the recent kernels start adjusting video settings before X starts and loads the nvidia drivers so it just crashed cause this card isn't supported/tested. Works fine after X starts.

I ended up editing the grub file directly, even though it says not to. What is the prefered method of modifying that?

Author:  RacerX [ Sat Oct 04, 2014 5:55 pm ]
Post subject:  Re: Problems installing R8.0 (Solved)

I guess this is way for grub2

nano /etc/default/grub

Second find the line

Next, change it to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Third find the line

Next, change it to
assuming that you want 1024x768 resolution
grub-mkconfig -o /boot/grub/grub.cfg
to make the changes stick

Page 1 of 1 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group