LinHES Forums

Air2pc; how do I install it?
Page 1 of 1

Author:  ajaxdude [ Wed Feb 23, 2005 1:59 pm ]
Post subject:  Air2pc; how do I install it?

Has anybody figured how to make it work yet?

If so, could you write a step by step guide?


Author:  aovermy [ Wed Feb 23, 2005 11:11 pm ]
Post subject: 

That would depend on your setup.

Are you amenable to updating your kernel? If so, one of the 2.6.11 release candidates might be best as it already includes your driver. If you object to release candidates then you might want to try 2.6.10 with the dvb-kernel links.

Do you want to run it with QAM (for unencrypted dig. cable) or OTA? If QAM, I'm not sure this is in the release candidates for 2.6.11 yet, so you would still need the dvb-kernel cvs links.

I'm not sure you can make it work with non-2.6.x kernels.

There are good directions here: ... howto.html


Author:  ajaxdude [ Thu Feb 24, 2005 8:17 am ]
Post subject:  I was not clear

Sorry for not being clear.

I have a fresh system. Nothing is on the HD. I tried installing gentoo. I had found the guide you posted, and tried three time with fedora core 3.

In either situation, I find that the kernel making has generated errors.

I am interested in OTA; just to get that to work would be great. QAM is just a dream at this point.

I need a guide that would start from the very begining with this card in mind.

My prefered environment would be Gentoo; but I will accept anything that will allow me to play with the card and mythTV.

I have installed gentoo before; but I don't know what to do when it come to the kernel and making it work with the air2pc card. Messing with linux-dvb is very confusing, because I don't know what I am doing. Thus it is hard to migrate the steps from the link you provided to the gentoo environment.

I wish I could emerge a kernel that just worked!


Author:  aovermy [ Thu Feb 24, 2005 5:53 pm ]
Post subject: 

Well I'm pretty rusty on gentoo, but when you install it, you pick a kernel version right? I'm pretty sure one of them will be a smp dev version you can pick. That one will be the 2.6.x version. If you're lucky, it's a 2.6.10 or 2.6.11 rc kernel. Then you should just install gentoo as normal, compiling up your preferred window manager, xorg, etc.

If the kernel they provide is a 2.6.11rc build, then when you do make menuconfig see if there's a nxt2002 frontend buried in the media, dvb submenus area. If so, select it as module, select airstar2 as module and all your other devices and compile.

If the kernel they provide is not a 2.6.11rc or doesn't have nxt2002 as an option, make sure it is 2.6.10. If it is lower than 2.6.10, emerge the vanilla 2.6.10.

Now with that 2.6.10 kernel, get the dvb-kernel directory and run the makelinks shells script.

.e.g. makelinks /usr/src/linux-2.6.10

then make menuconfig in the kernel and enable skystar2 and nxt2002 (a bunch of other frontends will be enabled too by default--don't worry they don't eat much.

Then do a normal make etc.

If your kernel building fails with this procedure, maybe it's something else that's failing during the build.


Author:  ajaxdude [ Fri Feb 25, 2005 7:59 am ]
Post subject:  kernel error

I got development-sources which is 2.6.11rc5; I emerged it.

DVB device (I forget the exact name) <*>
I made Skystar2 PCI <M>
nxt2002 <M>

when it compiles I get an error:

drivers/built-in.o(.text+0x9470a): In function `nxt2002_init':
: undefined reference to `release_firmware'
make: *** [.tmp_vmlinux1] Error 1

If I do <*> <*> for the card and nxt2002 I TWO errors:

drivers/built-in.o(.text+0x7a63f): In function `nxt2002_init':
: undefined reference to `release_firmware'
drivers/built-in.o(.text+0x7d3ed): In function `nxt2002_request_firmware':
: undefined reference to `request_firmware'
make: *** [.tmp_vmlinux1] Error 1

Any insights? I am stuck. Thanks for helping

Author:  cesman [ Fri Feb 25, 2005 1:32 pm ]
Post subject: 

Since you're using Gentoo, perhaps a query (or search) on the Gentoo forum?

Author:  ajaxdude [ Sat Feb 26, 2005 9:29 am ]
Post subject: 

I tried that; no one seems to have a air2pc... or if they do no one is talking ;)

Author:  ajaxdude [ Mon Feb 28, 2005 8:54 am ]
Post subject:  ok it works

I got it to compile in the kernel. I got a new version of the kernel that was realeased on friday. and now it works.

<*><*><*><M><M> is what I used and now there is no errrors.

it must have been a mistake in the previous rc version.

I hope this helps anybody in the same situation.

Page 1 of 1 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group