View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 3 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Thu Aug 01, 2019 3:35 pm 
Offline
Joined: Mon Apr 23, 2007 1:45 pm
Posts: 402
Location: Fargo, ND, USA
Version Installed LinHES R8.6.1
This was a clean install of LinHES R8.6.1 on a SSD + data drive.

This statement show up in every mythfilldatabase command that I run.
Code:
This application expects to be running a locale that specifies a UTF-8 codeset, and many features may behave improperly with your current language settings. Please set the LC_ALL or LC_CTYPE, and LANG variable(s) in the environment in which this program is executed to include a UTF-8 codeset (such as 'en_US.UTF-8').

I also see that in Myth Web that all of my labels are in Spanish but the data in the pages are in English.
When I look for a fix for this it come back to 'en_US.UTF-8' complainants also.

From what I have found so far the first line is empty. My guess is that it should look like LANG = "en_US.UTF-8"
Code:
> locale
LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=

My language settings
Service Menu > Mythtv Settings > Setup > Appearance > Localization
Language: English (US)
Guide Language #1: English
Guide Language #2: English

Is anyone else having trouble with this or have a idea of where to look?

_________________
TVBox
LinHES R8.6.1


Last edited by TVBox on Sat Aug 03, 2019 12:08 am, edited 1 time in total.


Top
 Profile  
 
PostPosted: Fri Aug 02, 2019 5:12 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1175
Location: SC
That doesn't look right. Try
Code:
sudo systemconfig.py -m locale


Top
 Profile  
 
PostPosted: Sat Aug 03, 2019 12:07 am 
Offline
Joined: Mon Apr 23, 2007 1:45 pm
Posts: 402
Location: Fargo, ND, USA
Don't spend any time on this until I can figure out why my SSH
dos not correlate with the command line sitting in front of the machine

The three commands below all produce the same results
$ sudo systemconfig.py –m locale
# systemconfig.py –m locale
# sudo systemconfig.py –m locale
Code:
$ sudo systemconfig.py –m locale
*TEMPLATES is not defined
*using default value
__Start of locale/langconfig__
    locale: is en_US.UTF-8
    Generating locales
   Updating /etc/locale.conf

Command
$ systemconfig.py –m locale
Code:
$ systemconfig.py –m locale
__Start of locale/langconfig__
    locale is: en_US.UTF-8
    Generating locales
Traceback (most recent call last):
   File “/usr/Mythvantage/bin/systemconfig.py”,
   line 452, in <module> main (sys.argv[1:] )
   File “/usr/Mythvantage/bin/systemconfig.py”,
   line 422, in main mv_locale.setup_locale(systemconfig)
   File “/usr/Mythvantage/bin/systemconfig.py”,
   line 88, in_setuplocale genlocale ([locale])
   File “/usr/Mythvantage/bin/systemconfig.py”,
   line 44, in genlocale f = open (locale file,”w”)
   IOError: [Errno13] Permision denied: ‘/etc/locale.gen’

File “/etc/locale.conf” contains
Code:
LANG="en_US.UTF-8"

Code:
> $ locale
LANG="en_US.UTF-8"
LC_CTYPE=" en_US.UTF-8"
LC_NUMERIC=" en_US.UTF-8"
LC_TIME=" en_US.UTF-8"
LC_COLLATE=" en_US.UTF-8"
LC_MONETARY=" en_US.UTF-8"
LC_MESSAGES=" en_US.UTF-8"
LC_PAPER=" en_US.UTF-8"
LC_NAME=" en_US.UTF-8"
LC_ADDRESS=" en_US.UTF-8"
LC_TELEPHONE=" en_US.UTF-8"
LC_MEASUREMENT=" en_US.UTF-8"
LC_IDENTIFICATION=" en_US.UTF-8"
LC_ALL=

This was a clean install of LinHES R8.6.1 on a SSD + data drive.

_________________
TVBox
LinHES R8.6.1


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: Bing [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu