View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 14 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
 Post subject: Drive going bad
PostPosted: Tue Sep 10, 2019 11:37 am 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 978
Location: Lexington, Ky
Looks like my 6 year old drive is starting to fail. It takes forever to load and I'm getting read errors. So far I've copied all the modified and custom files from /home/mythtv , the MYSQL Database, and the last nightly system backup, and the Kodi database.

Did I miss anything else I might need to copy?

I think /etc is included in the nightly backup is that correct?

Also what will be the easiest way to reinstall? I'm thinking an ISO install then restore the database, /home/mythtv, and /etc thoughts anyone?


Top
 Profile  
 
 Post subject: Re: Drive going bad
PostPosted: Thu Sep 12, 2019 5:43 am 
Offline
Joined: Thu Sep 27, 2007 5:44 pm
Posts: 530
I believe the only time I restored a backup was upgrading from r7 to r8 using the instructions here:
http://linhes.org/projects/linhes/wiki/ ... _R7X_to_R8

I would think the same would apply in your situation. I have always used clonezilla to backup drives, but if you think that yours in corrupted then it may not be the best solution for you.


Top
 Profile  
 
 Post subject: Re: Drive going bad
PostPosted: Thu Sep 12, 2019 10:24 am 
Offline
Joined: Sat Jan 06, 2007 7:08 pm
Posts: 89
the nightly backup script will back up /home, /etc, and the database. the restore script will restore the database. /home and /etc is not restored, but it is rather left to the user to selectively restore from the tar file

here is a different page outlining the backup/restore scripts:

http://linhes.org/projects/linhes/wiki/ ... nd_Restore

it is similar as the link outlining steps to upgrade from 7 to 8, but this page shows how to do it via command line, web, or myth-gui and assumes you are restoring to the same version

_________________
DH87MC i7-4770 16GB ram Xonar Essence ST geforce 710 LinHes 8.6


Top
 Profile  
 
 Post subject: Re: Drive going bad
PostPosted: Fri Sep 13, 2019 6:08 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 978
Location: Lexington, Ky
Thank you knappster & welner for pointing me in the right direction I think I'm ready.
Hopefully I can still make a copy of /myth It'

New drive arrived today looks like it will be my project for the weekend.


Top
 Profile  
 
 Post subject: Re: Drive going bad
PostPosted: Sat Sep 14, 2019 5:57 am 
Offline
Joined: Thu Sep 27, 2007 5:44 pm
Posts: 530
Good luck!


Top
 Profile  
 
 Post subject: Re: Drive going bad
PostPosted: Mon Sep 16, 2019 1:52 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 978
Location: Lexington, Ky
Well I have the drive installed, then installed the same version from the ISO using new install.

Now I have questions about the next steps?

I think I need to do the following.
Skip the setup screen.

Overwrite - (restore) /home/mythtv from my backup.
Overwrite - (restore) /etc from my backup.
Restore files to /myth from my backup.
Finally do a full restore of the MySQL DB

Then Reboot and everything should work? Did I miss anything.

Did I miss or overlook anything?

Thanks


Top
 Profile  
 
 Post subject: Re: Drive going bad
PostPosted: Mon Sep 16, 2019 3:32 pm 
Offline
Joined: Wed Jan 07, 2004 12:14 pm
Posts: 404
Location: Charlotte, NC
I have had to do this a couple of times - what I have found is that all works better if you get a working initial system first (do a complete install and initial setup) then restore your key directories and then a DB restore. I have tried it without the initial setup only to run into issues after the restores (biggest was network and capture card setup if I remember right)... Anyway, you are on the right track...

_________________
Backend server - 4.0 TB 3.0ghz dual core 6 gig RAM, nVidia 9400, Gigabyte GA-870A-UD3 MB, 2 HD-5500, 2 HD Homerun dual tuners, 3 frontend machines - LinHES 8.5


Top
 Profile  
 
 Post subject: Re: Drive going bad
PostPosted: Mon Sep 16, 2019 10:13 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 978
Location: Lexington, Ky
nbdwt73
I tried to create a working system but can't get past a "Unable to Connect to Database" message.
I tried the setup but everything looks right there.
If I restore a database then it connects. I don't understand what's happening that I can't go any further?

Any thoughts?


Top
 Profile  
 
 Post subject: Re: Drive going bad
PostPosted: Tue Sep 17, 2019 4:56 pm 
Offline
Joined: Wed Jan 07, 2004 12:14 pm
Posts: 404
Location: Charlotte, NC
So I am not sure that I understand... Are you saying that you cannot get a virgin system installed from a CD (or image)?

_________________
Backend server - 4.0 TB 3.0ghz dual core 6 gig RAM, nVidia 9400, Gigabyte GA-870A-UD3 MB, 2 HD-5500, 2 HD Homerun dual tuners, 3 frontend machines - LinHES 8.5


Top
 Profile  
 
 Post subject: Re: Drive going bad
PostPosted: Tue Sep 17, 2019 11:21 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 978
Location: Lexington, Ky
Yes, that is correct. I have managed to restore all the data and /home/mythtv from backups applied the latest fixes (which I had done on the old drive) and have restored the database.

It shows all recorders are available
Tuner 7 - HDPVR (HDPVR) on mythtv : Idle
Tuner 12 - HDPrime-0 (HDHOMERUN) on mythtv : Idle
Tuner 13 - HDPrime-1 (HDHOMERUN) on mythtv : Idle
Tuner 14 - HDPrime-2 (HDHOMERUN) on mythtv : Idle

But I can not watch live tv , it just flashes starting playback and that's it. I have scheduled recording it say it recorded them but I can't find them, They show up in the list but are grayed out.

Frontend log says
Code:
 It appears that your backend may be misconfigured.  Check yo
ur backend logs to determine whether your inputs, lineups, channels, or storage
configuration are reporting errors.  This issue is commonly caused by failing to
 complete all setup steps properly.  You may wish to review the documentation for mythtv-setup.


I updated the locations in setup with the new path names.

I am also having a problem with kodi. The database got to big so I had moved it to the media dir and created a link. For some reason it can't read the link. I just doesn't start if I delete the link it starts
and creates .kodi in /home/mythtv

What I don't understand is that the mythweb/status shows this.
Code:
Directories: mythtv:/data/storage/WDCWD10EZEX-60WN4A0_WD-WCC6Y1AADZ2V/media/LiveTV,
mythtv:/data/storage/WDCWD10EZEX-60WN4A0_WD-WCC6Y1AADZ2V/media/tv


Which is correct but all of the file names in Watch Recording are greyed out.

Bed time...


Top
 Profile  
 
 Post subject: Re: Drive going bad
PostPosted: Wed Sep 18, 2019 8:01 am 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 978
Location: Lexington, Ky
Britney,
Should I have done a partial restore instead of a full database restore? Would that have created the new path names in the database?

Thanks


Top
 Profile  
 
 Post subject: Re: Drive going bad
PostPosted: Wed Sep 18, 2019 11:06 am 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 978
Location: Lexington, Ky
After getting a good nights sleep it finally dawned on me that the database had the "OLD Storage Drive ID" in all of the path names.

I went through and updated all of the storage paths. Works like a charm!!


Top
 Profile  
 
 Post subject: Re: Drive going bad
PostPosted: Thu Sep 19, 2019 6:20 am 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1300
Location: Orlando FL
Great to hear!!!
I'm sure there is a great reason for using those drive specific paths, but I've run into problems more than once with those.

_________________
My System


Top
 Profile  
 
 Post subject: Re: Drive going bad
PostPosted: Thu Sep 19, 2019 12:58 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 978
Location: Lexington, Ky
mattbatt

Have any idea's on this? viewtopic.php?f=23&t=25081


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu