View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 19 posts ] 
Go to page 1, 2  Next

Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sun Apr 07, 2013 2:36 pm 
Offline
Joined: Tue Sep 13, 2005 10:48 am
Posts: 852
Location: London, UK
Hi,

After getting my R8 running, I seemed to hit a small snag: Mythwelcome....

In all previous versions I have exited the frontend by pressing escape on the keyboard.... except now nothing. I can press m to get a menu for shutdown etc., which doesn't give me an option to exit the frontend (as in previous versions) I've hunted around for other options (I've seen the page in Configuration that sets the options viewable).

But I'm at a loss... Alt-tab shows me mythwelcome running in the background, but how do i close the frontend and use mythwelcome for schedualed wake up to record?

Slightly confused as why this isn't working ...

_________________
Version:R8
Intel C2D 7400, Nvidia 5600 via HDMI to Samsung B37B650TW (PAL), Asus P5QL-E mobo, 4Gb PC6400 DDR2 ram, Samsung Spinpoint 500 Gb & 1Tb drive, Nova-HD-S2 (x2)


Last edited by tophee on Wed Apr 10, 2013 2:23 am, edited 2 times in total.


Top
 Profile  
 
 Post subject: Re: Mythwelcome question
PostPosted: Sun Apr 07, 2013 5:15 pm 
Offline
Site Admin
Joined: Fri Jun 11, 2004 7:58 am
Posts: 507
i think it's alt-esc or ctl-esc to exit.
That can be configured in the keybindings.


Top
 Profile  
 
 Post subject: Re: Mythwelcome question
PostPosted: Sun Apr 07, 2013 7:26 pm 
Offline
Joined: Mon Apr 23, 2007 1:45 pm
Posts: 402
Location: Fargo, ND, USA
alt-esc will bring up a menu listing. If I choose "Yes, Exit Now" it will lock up the system.
The only way I have been successful getting to the Mythwelcome screen is to "alt-esc" "Yes, Exit Now" right after a reboot and then I have only been successful one out of ten times. I have received a frontend lockup just by pushing alt-esc

The letter "m" use to bring up the mythwelcome menu on the mythwelcome frontend screen is now letter "n"

The letter "i" will bring up the daily shutdown menu

TVBox

Edit
after I ran the /usr/LH/bin/mythwelcome-config.py script most of this post is no longer true.
But this one is still true ---> alt-esc will bring up a menu listing. If I choose "Yes, Exit Now" it will lock up the system.

_________________
TVBox
LinHES R8.6.1


Last edited by TVBox on Mon Apr 22, 2013 5:09 am, edited 1 time in total.


Top
 Profile  
 
 Post subject: Re: Mythwelcome question
PostPosted: Sun Apr 07, 2013 11:52 pm 
Offline
Joined: Tue Sep 13, 2005 10:48 am
Posts: 852
Location: London, UK
Thanks for the alt-escape tip. That is what I was looking for.

_________________
Version:R8
Intel C2D 7400, Nvidia 5600 via HDMI to Samsung B37B650TW (PAL), Asus P5QL-E mobo, 4Gb PC6400 DDR2 ram, Samsung Spinpoint 500 Gb & 1Tb drive, Nova-HD-S2 (x2)


Top
 Profile  
 
 Post subject: Re: Mythwelcome question
PostPosted: Mon Apr 08, 2013 1:08 am 
Offline
Joined: Tue Sep 13, 2005 10:48 am
Posts: 852
Location: London, UK
Well I was able to exit the frontend, but mythwelcome doesn't seem to be doing what it should... The frontend just sits there. Will look into it further when I've time later.

_________________
Version:R8
Intel C2D 7400, Nvidia 5600 via HDMI to Samsung B37B650TW (PAL), Asus P5QL-E mobo, 4Gb PC6400 DDR2 ram, Samsung Spinpoint 500 Gb & 1Tb drive, Nova-HD-S2 (x2)


Top
 Profile  
 
PostPosted: Mon Apr 08, 2013 2:34 pm 
Offline
Joined: Tue Sep 13, 2005 10:48 am
Posts: 852
Location: London, UK
So Alt-Escape was the button was the key combination I was looking for, but exiting myth was not dropping me to the mythwelcome screen as anticipated.

I pressed "I" to get into the setup, and I realised the date/time format was wrong.

Changed it to
Code:
yyyy-MM-ddThh:mm:ss


And it all worked as expected

-Edit- Actually it didn't quite. Changed the format in mythtv-setup to reflect the date format. Shall see.

_________________
Version:R8
Intel C2D 7400, Nvidia 5600 via HDMI to Samsung B37B650TW (PAL), Asus P5QL-E mobo, 4Gb PC6400 DDR2 ram, Samsung Spinpoint 500 Gb & 1Tb drive, Nova-HD-S2 (x2)


Top
 Profile  
 
PostPosted: Wed Apr 10, 2013 2:22 am 
Offline
Joined: Tue Sep 13, 2005 10:48 am
Posts: 852
Location: London, UK
Well, it's un-solved now.

I changed the date format in mythwelcome (pressing 'i' once I'd exited the frontend) and I got the mythwelcome screen I was expecting. It still hadn't shutdown the next morning though. The timer had got to 10 seconds and halted. So, I changed the time format for shutdown in myth-setup on page 5.

Now I can't even get into mythwelcome to undo the changes I made. I exit the frontend and myth hangs. I can get into a terminal and restart the frontend. Mythwelcome seems broken at the moment.

I'll have a look through the log files later to see if I can spot any clues...

_________________
Version:R8
Intel C2D 7400, Nvidia 5600 via HDMI to Samsung B37B650TW (PAL), Asus P5QL-E mobo, 4Gb PC6400 DDR2 ram, Samsung Spinpoint 500 Gb & 1Tb drive, Nova-HD-S2 (x2)


Top
 Profile  
 
PostPosted: Thu Apr 11, 2013 6:54 am 
Offline
Joined: Tue Sep 13, 2005 10:48 am
Posts: 852
Location: London, UK
Still haven't managed to look at my log files... after the weekend. Work is frantic at the moment.

But, while at a friends house I updated their Mythbox. Mythwelcome doesn't work on their machine either.

Is it working for anyone?

_________________
Version:R8
Intel C2D 7400, Nvidia 5600 via HDMI to Samsung B37B650TW (PAL), Asus P5QL-E mobo, 4Gb PC6400 DDR2 ram, Samsung Spinpoint 500 Gb & 1Tb drive, Nova-HD-S2 (x2)


Top
 Profile  
 
PostPosted: Thu Apr 11, 2013 10:03 pm 
Offline
Joined: Tue Sep 12, 2006 12:12 am
Posts: 18
Location: Melbourne, VIC, Australia
It's working for me in R8.

Make sure you have the following Shutdown/Wakeup Options in MythTV-Setup General:

Wakeup time format: yyyy-MM-ddThh:mm:ss
Command to set wakeup: /usr/bin/mythshutdown --setwakeup $time
Server halt command: /user/bin/mythshutdown --shutdown
Pre-shutdown-check command: /usr/bin/mythshutdown --check

I think in my tinkering I may have also run /usr/LH/bin/mythwelcome-config.py.

Finally, I'm pretty sure I did what was mentioned in this article in the MythWelcome settings screen: http://www.mythtv.org/wiki/Mythwelcome. I think I changed the shutdown command to /usr/poweroff as per the screenshot.


Top
 Profile  
 
PostPosted: Fri Apr 12, 2013 1:21 am 
Offline
Joined: Tue Sep 13, 2005 10:48 am
Posts: 852
Location: London, UK
Hi Curto,
I'll look into that.
Hopefully will sort.

Chris

_________________
Version:R8
Intel C2D 7400, Nvidia 5600 via HDMI to Samsung B37B650TW (PAL), Asus P5QL-E mobo, 4Gb PC6400 DDR2 ram, Samsung Spinpoint 500 Gb & 1Tb drive, Nova-HD-S2 (x2)


Top
 Profile  
 
PostPosted: Sat Apr 20, 2013 1:07 am 
Offline
Joined: Tue Sep 13, 2005 10:48 am
Posts: 852
Location: London, UK
Well, I'm still no further with this.

Running mythwelcome -v gives me this output:
Code:
[root@lust ~]# mythshutdown -v
2013-04-20 08:42:04.217508 C  mythshutdown version: fixes/0.25 [v0.25.3-32-g79a24c9] www.mythtv.org
2013-04-20 08:42:04.217523 C  Qt version: compile: 4.8.2, runtime: 4.8.2
2013-04-20 08:42:04.217527 N  Enabled verbose msgs:  general
2013-04-20 08:42:04.217544 N  Setting Log Level to LOG_INFO
2013-04-20 08:42:04.217584 I  Added logging to the console
2013-04-20 08:42:04.217590 I  Added database logging to table logging
2013-04-20 08:42:04.217660 N  Setting up SIGHUP handler
2013-04-20 08:42:04.217706 N  Using runtime prefix = /usr
2013-04-20 08:42:04.217717 N  Using configuration directory = /root/.mythtv
2013-04-20 08:42:04.217824 I  Assumed character encoding: C
2013-04-20 08:42:04.217830 W  This application expects to be running a locale that specifies a UTF-8 codeset, and many features may behave improperly with your current language settings. Please set the LC_ALL or LC_CTYPE, and LANG variable(s) in the environment in which this program is executed to include a UTF-8 codeset (such as 'en_US.UTF-8').
2013-04-20 08:42:04.218086 E  Unable to read configuration file mysql.txt
2013-04-20 08:42:04.218242 N  Empty LocalHostName.
2013-04-20 08:42:04.218282 I  Using localhost value of lust
2013-04-20 08:42:04.218395 I  Testing network connectivity to '192.168.0.20'
2013-04-20 08:42:04.220132 I  Starting process manager
2013-04-20 08:42:04.220294 I  Starting process signal handler
2013-04-20 08:42:04.220314 I  Starting IO manager (read)
2013-04-20 08:42:04.220361 I  Starting IO manager (write)
mythshutdown version: fixes/0.25 [v0.25.3-32-g79a24c9] www.mythtv.org
Misc. Options:
-c OR --check                 Check whether shutdown is possible
--lock                        disable shutdown
-x OR --safeshutdown          Check if shutdown is possible, and shutdown
-t OR --setscheduledwakeup    Set wakeup time to the next scheduled recording
-w OR --setwakeup             Set the wakeup time (yyyy-MM-ddThh:mm:ss)
-h OR --help OR --usage       Display this help printout, or give detailed information of
                              selected option.
--version                     Display version information.
--shutdown                    Apply wakeup time to nvram and shutdown.
-p OR --startup               Check startup status
-s OR --status                check current status
-u OR --unlock                enable shutdown

Logging Options:
--loglevel                    Set the logging level.  All log messages at lower levels will be
                              discarded.
                              In descending order: emerg, alert, crit, err, warning, notice,
                              info, debug
                              defaults to info
--logpath                     Writes logging messages to a file in the directory logpath with
                              filenames in the format: applicationName.date.pid.log.
                              This is typically used in combination with --daemon, and if used
                              in combination with --pidfile, this can be used with log
                              rotators, using the HUP call to inform MythTV to reload the file
--nodblog                     Disable database logging.
-q OR --quiet                 Don't log to the console (-q).  Don't log anywhere (-q -q)
--syslog                      Set the syslog logging facility.
                              Set to "none" to disable, defaults to none.
-v OR --verbose               Specify log filtering. Use '-v help' for level info.

2013-04-20 08:42:04.346782 N  Setting QT default locale to en_GB
2013-04-20 08:42:04.346860 I  Current locale en_GB
2013-04-20 08:42:04.346894 N  Reading locale defaults from /usr/share/mythtv//locales/en_gb.xml


I've tried to poke mythshutdown with various peramiters, adding the -v switch to see what it's doing and the only thing it complains of is not being able to read the mysql.txt file and not shut down.

Any thoughts?

_________________
Version:R8
Intel C2D 7400, Nvidia 5600 via HDMI to Samsung B37B650TW (PAL), Asus P5QL-E mobo, 4Gb PC6400 DDR2 ram, Samsung Spinpoint 500 Gb & 1Tb drive, Nova-HD-S2 (x2)


Top
 Profile  
 
PostPosted: Sat Apr 20, 2013 10:44 am 
Offline
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
Do you have a mysql.txt file in /root/.mythtv ?


Top
 Profile  
 
PostPosted: Mon Apr 22, 2013 4:45 am 
Offline
Joined: Mon Apr 23, 2007 1:45 pm
Posts: 402
Location: Fargo, ND, USA
Some of this is posted for the general reader. R8-02-11-2013 version only

Enable Mythwelcome
Service Menu>>LinHES Configuration>>System Type>>Host Settings (tic Run Mythwelcome Box)

Problem 1. (Setting pages not populated)
The script mythwelcome-config.py script fails to run and populate the "MythShutdown / Mythwelcome Settings Page" and "Shutdown / Wakeup Options" with the correct settings. You must manually run this script.
xterm window # /usr/LH/bin/mythwelcome-config.py
You do not have to update any data on these pages after you run the scrip
I filed a bug report http://linhes.org/issues/914

Problem 2. (No way to get to the Mythwelcome screen)
Mythwelcome runs correctly if you use the "enter standby mode" to shut down the system. If you use alt-esc and bring up the menu and choose "Yes Exit now" in a attempt to get to the Mythwelcome page the the front end locks up and has to be rebooted.
I filed a bug report http://linhes.org/issues/915

Problem 3. (Mythtv Standby says its recording but it is not)
With no recordings currently happening or in the near future and no jobs running. If you use the Menu Button >> "enter standby mode" to shut down the system. The black with red square box "MythTV is in standby" appears to give you status of your shut down. The status displays "Backend is Idle" for the first 15 seconds (like you would expect it to). After 15 seconds the status changes to "Backend is recording " and stays that way for the next 2 minutes or longer, until it shuts down.
http://linhes.org/issues/916

Even-tho the status given is incorrect Mythwelcome shuts down and starts up correctly if you use the "enter standby mode" to shut down the system.

You can get to the Mythwelcome screen by typing "Mythwelcome" into a xterm window.
(Note:If left on this screen it will not shut down.) something is broke it will not start the count down.
Type "m" and choose exit to get back to your xterm window

If you type "i" on the mythwelcome screen it will bring up the daily shutdown menu. In the Date Format Box you should have "ddd dd MMM yyyy"
I have no idea what this means. the link provided to explain it is broke. http://doc.trolltech.com/3.3/qdate.html

TVBox

_________________
TVBox
LinHES R8.6.1


Last edited by TVBox on Mon Apr 22, 2013 6:41 am, edited 2 times in total.


Top
 Profile  
 
PostPosted: Mon Apr 22, 2013 4:57 am 
Offline
Joined: Mon Apr 23, 2007 1:45 pm
Posts: 402
Location: Fargo, ND, USA
Tophee
I run mythshutdown -v on my system where Mythwelcome is working and the output is identical to what you posted, if you disregard the the personal setting.

TVBox

_________________
TVBox
LinHES R8.6.1


Top
 Profile  
 
PostPosted: Tue Apr 23, 2013 1:03 am 
Offline
Joined: Tue Sep 13, 2005 10:48 am
Posts: 852
Location: London, UK
Hey TVBox,

I've been a bit tied up for the last few days, so havent been able to do any detective work but you have been ;-)

I'm glad the error is unimportant. however, I will go and double check everything and see if I've some oddities anywhere and/ or follow your instructions. I'll post back later with my findings.

Thanks!

_________________
Version:R8
Intel C2D 7400, Nvidia 5600 via HDMI to Samsung B37B650TW (PAL), Asus P5QL-E mobo, 4Gb PC6400 DDR2 ram, Samsung Spinpoint 500 Gb & 1Tb drive, Nova-HD-S2 (x2)


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 19 posts ] 
Go to page 1, 2  Next



All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu