View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 10 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sat Mar 13, 2010 10:19 am 
Offline
Joined: Sat Jun 05, 2004 2:00 pm
Posts: 31
Location: St. Paul, MN
How do you create a non-root and non-mythtv user if you installed from the R6.02 CD? I believe the R6.01 CD had an input screen for that functionality; I can't find it now.

Under the Service Menu>LinHES Configuration menu there is an entry for User Accounts, but when selected, it tells me I do not have access to this screen. If I look under the Access Control menu, there is no checkbox to enable access to user accounts.

For now, I've had to assign a password to root and allow root logins over ssh in order to remotely log in to my LinHES box.

Thanks for you help.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Mar 13, 2010 12:29 pm 
Offline
Joined: Sun Jul 24, 2005 4:16 pm
Posts: 502
Location: Ft. Worth TX
As root 'adduser'
Answer the questions.


Top
 Profile  
 
PostPosted: Sat Mar 13, 2010 1:34 pm 
Offline
Site Admin
Joined: Fri Sep 19, 2003 6:37 pm
Posts: 2657
Location: Whittier, Ca
winnpeny wrote:
How do you create a non-root and non-mythtv user if you installed from the R6.02 CD?
Oversight on my part... It is being corrected.


Top
 Profile  
 
 Post subject: ssh
PostPosted: Thu Apr 01, 2010 1:55 am 
Offline
Joined: Mon Dec 19, 2005 12:54 am
Posts: 17
Location: Fargo,ND
Hi,
I just did a fresh install of 6.02. Is there any fix i can do to get into ssh as of late?

How can i set root password?


Top
 Profile  
 
 Post subject:
PostPosted: Thu Apr 01, 2010 6:42 pm 
Offline
Joined: Sat Jun 05, 2004 2:00 pm
Posts: 31
Location: St. Paul, MN
I'm going from memory here, but I think it goes like this:

As root, type
Code:
passwd


and it will prompt you for the root password.

As root, use the adduser command to create a non-root, non-mythtv user. You will be able to use that account to ssh into the system.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Apr 13, 2010 12:07 am 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1295
Location: Orlando FL
If you want to assign a password to Mythtv user, as root type
Code:
passwd mythtv

it will ask you for a new password and to confirm the password.

BTW I thought my install went weird when I missed the password page.

_________________
My System


Top
 Profile  
 
 Post subject:
PostPosted: Fri Apr 23, 2010 1:41 am 
Offline
Joined: Mon Apr 19, 2010 2:23 am
Posts: 47
Location: Australia
Hi,

I have installed r6.02, I have manually added Webmin as per the Wiki
http://www.knoppmythwiki.org/index.php?page=webminhowto

I can open Webmin in a web browser on another computer but if I use the name root and enter a password as per this thread to fails to log in. I also created a new user and tried to log in as the new user and that does not work as well.
Can someone tell me what going wrong?

thanks


Top
 Profile  
 
 Post subject:
PostPosted: Fri Apr 23, 2010 2:03 am 
Offline
Joined: Mon Apr 19, 2010 2:23 am
Posts: 47
Location: Australia
Just figured it out......

did this part in the Wiki

If your root password does not work when logging in to webmin, open a terminal on the mythbox with Alt-x and type:

su
/opt/webmin/changepass.pl /etc/webmin root your_desired_password


Top
 Profile  
 
PostPosted: Tue May 11, 2010 4:01 pm 
Offline
Joined: Mon Dec 18, 2006 1:20 pm
Posts: 98
Location: Krakow, Poland, EU
Hi,

More details about non-root and non-mythtv user creation may be found within the thread adduser -m -G {groups} -s.
For instance regarding group membership:

christ wrote:
I just did a quick check and my regular user is a member of its own group. ie. user=myuser and group=myuser.

It is also members of the following groups:
root video audio optical storage users

Just to make it easier for readers, here is the command that creates a user:
Code:
useradd -m -G root,video,audio,optical,storage,users -s /bin/bash yourusername

We should take note also of that helpful comment (see the thread User creation page not accessible):

tjc wrote:
You need to enable that screen. It's disabled after the install for security reasons. Enabling the modules is under another screen of the service menus so it's not terribly secure. See Flyspray ticket #564.

BTW, Flyspray has been superseded by redmine. Here is ticket #564. See also ticket #643 and ticket #196.

winnpeny wrote:
If I look under the Access Control menu, there is no checkbox to enable access to user accounts.

If I understand Cecil's answer in the right way, the check-box is missing under R6.02.00, and the bug is going to be fixed in one of the coming updates.

Bye.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Aug 15, 2010 10:35 pm 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1295
Location: Orlando FL
thank you

_________________
My System


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: Bing [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu