LinHES Forums

New Frontend
Page 1 of 1

Author:  dickwyn [ Wed Jul 28, 2010 9:32 pm ]
Post subject:  New Frontend

I've been using 6.03 as a standalone now for about 4 weeks and it works fine.
I like to add a Frontend now and wonder whether I have to change the LinHes configuration, System Type from standalone to Backend.
I can't change this at the moment since it is grayed out, any suggestions please so I can change it if needs be, will be highly appreciated.
Thanks in advance

Author:  uteck [ Wed Jul 28, 2010 10:49 pm ]
Post subject: 

If that box will continue to be a FE/BE then I think you can leave it as is, and just configure the new FE to look to that box. That is how I did things when I had Mythbuntu as my FE/BE and added more FE's.
Latter when I moved it to the basement as just a BE, then I reconfigured it as just a BE. The FE's were unaffected since the IP stayed the same.

Author:  goofee [ Wed Jul 28, 2010 11:30 pm ]
Post subject: 

Service Menu -> LinHES Configuration -> Access Control -> Select change host type. Then you should be able to go back and it won't be greyed out.

I think the difference between standalone and masterbackend is standalone restricts mysql (and maybe other stuff) to localhost only so remote frontends can't connect. There is a check box so you can still run the front end if you want on the MBE.

Author:  dickwyn [ Wed Jul 28, 2010 11:34 pm ]
Post subject: 

I prefer to leave it running as a FE/BE if I can, I tried to connect from the new Frontend but get a Cannot Login message.
My settings on the first page of Database Configuration is:

Hostname: localhost
Port: blank
Database Name: mythconverg
User: mythtv
Password: mythtv

Author:  dickwyn [ Wed Jul 28, 2010 11:41 pm ]
Post subject: 

Service Menu -> LinHES Configuration -> Access Control

I don't have Access Control in my Menu.

So, are you saying I can or I can't connect to the FE/BE?
Can you please step me through the process?

Author:  goofee [ Wed Jul 28, 2010 11:59 pm ]
Post subject: 

I don't have Access Control in my Menu.


What I would try is comment out the skip networking line in /etc/my.cnf around line 39.
# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!

then restart mysql
sudo sv restart mysql

Now your remote frontend should be able to connect to the database.

Author:  dickwyn [ Thu Jul 29, 2010 9:20 pm ]
Post subject: 

Thanks goofee, tried that but no result.
Something I forgot to mention, When I restart the new Frontend, I get the Language Screen, select English and than the message No UPnP comes up.
Is this is the reason for my problems?

Author:  dickwyn [ Thu Jul 29, 2010 10:06 pm ]
Post subject: 

Problem solved, I had to change the IP address in the backend setup from to my real IP address. After I did this it all worked.
Thanks all.

Author:  goofee [ Thu Jul 29, 2010 11:14 pm ]
Post subject: 

It appears you posted before I finished my post. Good to hear you got it working.

Try running this from an xterm. It should allow you to adjust the access control even though you don't have it in your menu.
mythinstall -s accesscontrol

Or add this to /usr/share/mythtv/themes/defaultmenu/HOST_SETTINGS.xml to add the button to your menu.
      <text>Access Control</text>
      <action>EXEC  mythinstall -s accesscontrol </action>

Author:  dickwyn [ Thu Jul 29, 2010 11:32 pm ]
Post subject: 

Thanks, I will try that later, most likely tomorrow.

Author:  dickwyn [ Sat Jul 31, 2010 10:07 pm ]
Post subject: 

Thanks very much goofee, that worked fine!!

Page 1 of 1 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group