View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 19 posts ] 
Go to page 1, 2  Next

Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Mon Feb 06, 2012 10:56 pm 
Offline
Joined: Fri May 27, 2005 9:33 pm
Posts: 106
Location: Cairns, Australia.
I had hoped to ignore the 6.04 upgrade but see that it is a prerequisite for the upgrade to 7.1.
I read Cecils notes and changed the pacman.conf to knoppmyth.net/repo/i686/R6/core and extras.

Tried the
Code:
sudo pacman -Sy linhes-scripts

and this failed as it wanted mencoder-33805-4 and linhes-scripts-7-25 which are both in the R7 repo.
Changed the repo in pacman.conf to linhes.org instead of knoppmyth.net…. came up with same error.

Tried the upgrade through the services menu, it recognised that there where updates and can list them if I view the files via the menu but if I select Perform updates it comes up updates cancelled in yellow! This happens for both linhes.org repo or knoppmyth.net repo which as far as I can see are the same for R6

If I
Code:
sudo upgrade_linhes.sh

it jumps start to the yellow splash screen, F2 shows the process stuck at
Parent daemon running………

Any ideas?
Can I just use the upgrade option from the 7.02 disk install?

_________________
R8.1 combined backend/frontend
ASUS P7H55-M Pro
Intel i3-550, 4Gb Ram
Seagate 500GB (Sata)
2x Dvico DVB-T Lite & Sony PlayTV (usb twin tuner)
TP-Link TL-WN881ND PCIe wifi card (not working)
Logitech Harmony One remote, CoolerMaster ATC-S case


Top
 Profile  
 
 Post subject:
PostPosted: Wed Feb 08, 2012 8:52 am 
Offline
Joined: Sun Sep 05, 2004 7:06 pm
Posts: 690
I had problems with the 6.04 to 7.1 online upgrade also. It ran for 3 days until I finally killed it. 6.04 worked fine for me but the backup was kinda of busted. So I ran the backup many many times and finally it worked. Then I downloaded the 7.2 iso. I ran the upgrade from there and it formatted sda1 and installed properly.

So backup your stuff, download the 7.2 iso, and then do the upgrade from the cd..


Top
 Profile  
 
 Post subject:
PostPosted: Sat Feb 11, 2012 8:05 pm 
Offline
Joined: Fri May 27, 2005 9:33 pm
Posts: 106
Location: Cairns, Australia.
Hey thanks for that. I was just in the process of burning the 7.2 iso.
Backups arn't working for me either but I'll try a few times, otherwise no big deal, it's just a few shows and movies.

_________________
R8.1 combined backend/frontend
ASUS P7H55-M Pro
Intel i3-550, 4Gb Ram
Seagate 500GB (Sata)
2x Dvico DVB-T Lite & Sony PlayTV (usb twin tuner)
TP-Link TL-WN881ND PCIe wifi card (not working)
Logitech Harmony One remote, CoolerMaster ATC-S case


Top
 Profile  
 
PostPosted: Tue Feb 14, 2012 12:07 am 
Offline
Joined: Mon Dec 24, 2007 9:47 am
Posts: 535
Location: Ottawa, Canada
bearwood wrote:
I had hoped to ignore the 6.04 upgrade but see that it is a prerequisite for the upgrade to 7.1.

The repos haven't been stable since the server crash. The mencoder issue was usually resolved by removing the one that was already installed. However, it will likely then fail on an incorrect udev dependency.

There shouldn't be a strict dependency on 6.04. Cecil told me he was really just encouraging people to take a step by step approach as 6.04 introduced myth 0.24. In theory to isolate issues that might arise.

bearwood wrote:
Can I just use the upgrade option from the 7.02 disk install?

yes. this should work. I believe the 7.2 disk will prompt you to upgrade. However given your current state, I'm not sure how successful it will be. Be sure to backup your database first.

I will be doing a straight upgrade from 6.03 to 7.2 this weekend as well.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Feb 16, 2012 9:44 pm 
Offline
Joined: Fri May 27, 2005 9:33 pm
Posts: 106
Location: Cairns, Australia.
Thanks,

Backing up is proving problematic in that I can not back manually or by using the on screen backup selection….#$%^

Installed 7.2 to a spare disk and installed fine but at the mo can not display any of the channels. It pickes them up fine but goes back to main menu when watch tv is selected.
No time to play around at the moment so still on 6.03

_________________
R8.1 combined backend/frontend
ASUS P7H55-M Pro
Intel i3-550, 4Gb Ram
Seagate 500GB (Sata)
2x Dvico DVB-T Lite & Sony PlayTV (usb twin tuner)
TP-Link TL-WN881ND PCIe wifi card (not working)
Logitech Harmony One remote, CoolerMaster ATC-S case


Top
 Profile  
 
 Post subject:
PostPosted: Sat Feb 18, 2012 10:39 am 
Offline
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
What kind of problems are you having with backup?


Top
 Profile  
 
PostPosted: Sat Mar 03, 2012 11:50 am 
Offline
Joined: Sun Jul 18, 2004 6:24 pm
Posts: 84
Location: Medford, Massachusetts
I'm experiencing a similar problem.

After the upgrade to 7.2 from 6.03 it says the the schema needs to be upgraded, but that isn't working.

From the command line:
$ sudo mythtv-setup
gives me the option to upgrade
I currently have

Warning: MythTV wants to upgrade your database
for the TV schema, from 1257 to 1264

Database Host: localhost
Database Name: mythconverg

Select Upgrade

If your system becomes unstable, a database backup file called
mythconverg-1257-20120303124207.sql.gz
is located in /myth/tv


Database error was:
Table 'internetcontent' already exists

new version: 1258
2012-03-30 12:48:18.237 Database Schema upgade FAILED, unlocking

_________________
AMD Athlon 64 3000+ on MSI K8T Neo
FX5200
pcHD3000
Firewire to Comcast cable box
PVR-250
R6


Top
 Profile  
 
PostPosted: Sat Mar 03, 2012 4:10 pm 
Offline
Joined: Sun Jul 18, 2004 6:24 pm
Posts: 84
Location: Medford, Massachusetts
Still not working.

I tried redoing the Upgrade using the 7.02 iso. Myth installs fine, but when it launches I get the instruction that I need to run mythtv-setup or mythbackend to upgrade the scheme.

My schema is currently at 1257.

When launched from an xterm, the schema update from mythtv-setup still gives me the following error:

Quote:
Database error was:
Table 'internetcontent' already exists


I think it may be a permissions problem in mysql when I tried to DROP the table in mysql.

What account should I use and how should I launch mysql to remove this table to try again?

Also, is mythconverg_restore.pl included in LinHES R7.02?

Thanks!

_________________
AMD Athlon 64 3000+ on MSI K8T Neo
FX5200
pcHD3000
Firewire to Comcast cable box
PVR-250
R6


Top
 Profile  
 
PostPosted: Sat Mar 03, 2012 7:51 pm 
Offline
Joined: Mon Dec 24, 2007 9:47 am
Posts: 535
Location: Ottawa, Canada
jmhunt wrote:
Database error was:
Table 'internetcontent' already exists

Ah yes. I saw this one too. I think there is something funky with the schema upgrade at change set 1257. There are actually two tables (internetcontent and internetcontentarticles) that will seem to exist and you need to delete them both and then continue with the database upgrade. Don't worry once deleted the schema upgrade will recreate them both but if you only delete one then it will fail again.

Did your mythtvbackend.log show something like:
Code:
2010-12-30 21:55:07.603 Connected to database 'mythconverg' at host: localhost
Current MythTV Schema Version (DBSchemaVer): 1257
Current MythTV Schema Version (DBSchemaVer): 1257
Current MythTV Schema Version (DBSchemaVer): 1257
Current MythTV Schema Version (DBSchemaVer): 1257
Current MythTV Schema Version (DBSchemaVer): 1257
Timed out waiting.


If so then try the following as root (and don't forget to have a backup just in case):
Code:
$ sv stop mythbackend
$ mysql  mythconverg

mysql> DROP TABLE IF EXISTS internetcontent;
mysql> DROP TABLE IF EXISTS internetcontentarticles;
mysql> exit;


after that you should be able to continue the upgrade by starting mythbackend again with
Code:
sv start mythbackend


and monitor mythtvbackend.log to ensure it completes.


Top
 Profile  
 
PostPosted: Mon Mar 05, 2012 7:32 am 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1293
Location: Orlando FL
Thank you I was having the same problem! I am going to bookmark this and come back to it when work isn't sooo busy.

_________________
My System


Top
 Profile  
 
PostPosted: Sat Mar 10, 2012 12:53 pm 
Offline
Joined: Sun Jul 18, 2004 6:24 pm
Posts: 84
Location: Medford, Massachusetts
I got it working, once I figured out how to log into the mysql correctly with the right username and password that could actually drop the tables. Happily running at 7.2 now...just dealing with change from Comcast to Verizon FiOS which isn't straight forward.

_________________
AMD Athlon 64 3000+ on MSI K8T Neo
FX5200
pcHD3000
Firewire to Comcast cable box
PVR-250
R6


Top
 Profile  
 
PostPosted: Wed Mar 14, 2012 10:11 pm 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1293
Location: Orlando FL
well that didn't work I guess it's time for me to try a re-install.

_________________
My System


Top
 Profile  
 
PostPosted: Thu Mar 15, 2012 12:33 pm 
Offline
Joined: Sat Feb 03, 2007 12:52 am
Posts: 187
Location: Manitoba, Canada
mattbatt wrote:
well that didn't work I guess it's time for me to try a re-install.

Before you reinstall, what is your exact error? I see you looked at http://forums.linhes.org/viewtopic.php?f=22&t=22195 that is for mythvideo schema version. Try https://github.com/MythTV/mythtv/blob/fixes/0.24/mythtv/libs/libmythtv/dbcheck.cpp around line 5194 for mythtv schema version 1257.


Top
 Profile  
 
PostPosted: Fri Mar 23, 2012 9:58 pm 
Offline
Joined: Tue Aug 15, 2006 11:14 am
Posts: 1293
Location: Orlando FL
I am no longer getting the schema mismatch error. I'm getting the old nasty default brown sidescroling theme on the front end and I cant change out of it. Before I tried to update the database I had the tuner working and now it is not. I'm swamped at work until Easter week I'm going to dive in then... hopefully.
On a completely side note has anyone else noticed that the most work gets done on MythTV when all the shows are on hiatus (Christmas and Summer) then it seems the newest build hits right when all the shows start back up and you can't afford to be down. It makes sense but it's kind of ironic. I'm not complaining really I appreciate all the work that the developers do.

_________________
My System


Top
 Profile  
 
PostPosted: Sat Mar 24, 2012 8:42 am 
Offline
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
mattbatt wrote:
I'm getting the old nasty default brown sidescroling theme on the front end and I cant change out of it.

Once upon a time, a long long time ago, I wrote script called "pickATheme.sh" for setting the UI theme from the command line. Because once you select a bad theme, it can be impossible to fix using the UI. It still seems to work:
Code:
#!/bin/bash

if [ $(id -u) -ne 0 ] ; then
    echo "You must run this script as root!"
    exit 1
fi

echo "Current GUI theme is:"
mysql mythconverg -e "select * from settings where value = 'Theme'"
echo

echo "Current OSD theme is:"
mysql mythconverg -e "select * from settings where value = 'OSDTheme'"
echo

THEMEDIR=/usr/share/mythtv/themes

THEMES=$(for i in $(ls $THEMEDIR) ; do
             [ -f $THEMEDIR/$i/theme.xml ] && echo "$i"
         done)
echo "Select the number of the GUI theme you would like to use:"
select THEME in $THEMES ; do echo ; break ; done

OSDTHEMES=$(for i in $(ls $THEMEDIR) ; do
                [ -f $THEMEDIR/$i/osd.xml ] && echo "$i"
            done)
echo "Select the number of the OSD theme you would like to use:"
select OSDTHEME in $OSDTHEMES ; do echo ; break ; done

echo
echo "Setting Theme = '$THEME', OSDTheme = '$OSDTHEME'."
echo
mysql mythconverg <<EOF
update settings set data = '$THEME' where value = 'Theme';
update settings set data = '$OSDTHEME' where value = 'OSDTheme';
EOF

pkill xinit


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 19 posts ] 
Go to page 1, 2  Next



All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu