View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 25 posts ] 
Go to page Previous  1, 2

Print view Previous topic   Next topic  
Author Message
Search for:
 Post subject: Re: 7.4 and ir blaster
PostPosted: Sun Jan 06, 2013 8:51 am 
Offline
Site Admin
Joined: Fri Jun 11, 2004 7:58 am
Posts: 507
i believe with irsend and multiple lirc devices attached, you have to give the lirc node in the command line. Without this it defaults to the first which may or maynot be the blaster.


Top
 Profile  
 
 Post subject: Re: 7.4 and ir blaster
PostPosted: Sun Jan 06, 2013 2:00 pm 
Offline
Joined: Wed Aug 03, 2005 8:43 am
Posts: 66
jams wrote:
i believe with irsend and multiple lirc devices attached, you have to give the lirc node in the command line. Without this it defaults to the first which may or maynot be the blaster.

You have lost me a bit. I do recalling the old days having to compel two instances of lirc to have a remote and irblaster. But don't know what the lirc node would be?


Top
 Profile  
 
 Post subject: Re: 7.4 and ir blaster
PostPosted: Sun Jan 06, 2013 2:15 pm 
Offline
Site Admin
Joined: Fri Jun 11, 2004 7:58 am
Posts: 507
The device would be something like /dev/lirc0 or /dev/lirc1 or /dev/lirc2 and so forth

since it defaults to /dev/lirc try something like
irsend -d /dev/lircd1 SEND_ONCE i Motorola_dsr_series 1


Top
 Profile  
 
 Post subject: Re: 7.4 and ir blaster
PostPosted: Sun Jan 06, 2013 7:03 pm 
Offline
Joined: Wed Aug 03, 2005 8:43 am
Posts: 66
jams wrote:
The device would be something like /dev/lirc0 or /dev/lirc1 or /dev/lirc2 and so forth

since it defaults to /dev/lirc try something like
irsend -d /dev/lircd1 SEND_ONCE i Motorola_dsr_series 1


I have a /dev/lirc1 and lirc0.
I get the following for both 1 and 0
Quote:
[root@mythtv-server ~]# irsend -d /dev/lircd1 SEND_ONCE i Motorola_dsr_series 1
irsend: could not connect to socket
irsend: No such file or directory


If it were running it should respond to the lircd command I assume.


Top
 Profile  
 
 Post subject: Re: 7.4 and ir blaster
PostPosted: Sun Jan 06, 2013 9:05 pm 
Offline
Joined: Sat Feb 03, 2007 12:52 am
Posts: 187
Location: Manitoba, Canada
There was some changes to lirc in version 7.? On my system I get
Code:
irsend -d /dev/lirc0 SEND_ONCE Motorola_dsr_series 5
irsend: could not connect to socket
irsend: Connection refused

But this works fine.
Code:
irsend -d /var/run/lirc/lircd SEND_ONCE Motorola_dsr_series 5


I'm seeing an 'i' between SEND_ONCE and Motorola that i don't think should be there but judging from the error you got I don't suspect that it's the problem.


Top
 Profile  
 
 Post subject: Re: 7.4 and ir blaster
PostPosted: Mon Jan 07, 2013 10:18 am 
Offline
Site Admin
Joined: Fri Jun 11, 2004 7:58 am
Posts: 507
So I was thinking of something else when talking about the device node, usind -d /dev/lirc[0-9] will not work
Do you have /var/run/lirc/lirc0 or /var/run/lirc/lirc1 ?
If so try using that path for the device node


Top
 Profile  
 
 Post subject: Re: 7.4 and ir blaster
PostPosted: Mon Jan 07, 2013 4:27 pm 
Offline
Joined: Wed Aug 03, 2005 8:43 am
Posts: 66
I found if I do killall lircd
then
lircd -d /dev/lirc1
then
irsend SEND_ONCE Motorola_dsr_series Power

It will power off. But the remote will only do direction arrows. I am surprised the remote worked at all. When our kids are is asleep I will dig deeper. So it looks like I may have to get lircd running twice mapped to lirc1 and lirc0.


Top
 Profile  
 
 Post subject: Re: 7.4 and ir blaster
PostPosted: Tue Jan 08, 2013 5:35 pm 
Offline
Joined: Wed Aug 03, 2005 8:43 am
Posts: 66
jams wrote:
So I was thinking of something else when talking about the device node, usind -d /dev/lirc[0-9] will not work
Do you have /var/run/lirc/lirc0 or /var/run/lirc/lirc1 ?
If so try using that path for the device node

Just a lircd in that dir.
Looking at an old change channel from a backup of a few key files it looks like it ran as a separate service. I cant find an irsend or an irblaster.cfg on this version.

#!/bin/bash

echo "changing to $1"

REMOTE_NAME=\
$(grep ^[[:space:]]*name[[:space:]] /etc/irblaster/irblasterd.conf |
awk '{ print $2 }')

for digit in $(echo $1 | sed -e 's/./& /g'); do
sleep 0.5
/usr/bin/irsend --device=/dev/irblasterd SEND_ONCE $REMOTE_NAME $digit
sleep 0.5
done
#/usr/bin/irsend --device=/dev/irblasterd SEND_ONCE $REMOTE_NAME ENTER


My Linux know how is mediocre at best and with ArchLinux I am still a bit lost. Can anyone give me a push in the right direction on running two instances of lirc if that is the best way to do it?


Top
 Profile  
 
 Post subject: Re: 7.4 and ir blaster
PostPosted: Thu Jan 17, 2013 8:23 am 
Offline
Joined: Wed Aug 03, 2005 8:43 am
Posts: 66
jams wrote:
So I have done some testing and it is possible to get a mce receiver and serial blaster working together.
Granted my testing was on R8 but the remote system didn't change between r7.4 and R8.

So the main thing here is that the blaster MUST BE /dev/lirc0. If it's not /dev/lirc0 the transmitting will fail.

Try this:
1) boot system
2) sv stop remotes
3) rmmod lirc_serial
4) unplug the mce receiver
5) rm /dev/lirc*
6) sv start remotes (this will load lirc_serial), check that /dev/lirc0 is present. If it's present then proceed otherwise try modprobe lirc_serial and continue
7) make sure blasting works
7) sv stop remotes
8) plug in mce receiver
9) sv start remotes
10) test and hopefully it all works.

At the moment I don't have a way to do this automated fashion, udevs helpfulness is getting in the way.


This did work. It wont survive a reboot but a huge help.


Top
 Profile  
 
 Post subject: Re: 7.4 and ir blaster
PostPosted: Sat Feb 02, 2013 7:39 am 
Offline
Joined: Wed Aug 03, 2005 8:43 am
Posts: 66
Last update. I ordered the ir blaster that has the headphone jack and plugged it into the back of my mce usb remote receiver and it worked without needing any changes.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 25 posts ] 
Go to page Previous  1, 2



All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu