View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 67 posts ] 
Go to page Previous  1, 2, 3, 4, 5  Next

Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Thu Oct 23, 2014 8:55 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1116
Location: SC
neufeld wrote:
I had to walk the last few steps of the script manually because somehow, in my previous attempts, I managed to remove tcp_wrappers and that state got onto the backup. The script failed out because it couldn't remove a non-existent package, so I just invoked the rest of the command sequence from the shell and the update completed.
I backed out that change last night so that the script won't fail if it can't remove tcp_wrappers. Thanks for testing and reporting your results.


Top
 Profile  
 
PostPosted: Thu Oct 23, 2014 9:42 am 
Offline
Joined: Sat May 03, 2014 8:47 pm
Posts: 13
Hi,

I thought I'd add my experience with this upgrade testing attempt.

See my pastebin info here: http://pastebin.com/Ngfi1pbQ

I've not positive that I have pacman.conf pointing to the right location for testing repos.

I thought things were looking promising, but later went sideways.

Happy to test again if someone can point out my errors.

Cheers,
Scott


Top
 Profile  
 
PostPosted: Thu Oct 23, 2014 10:42 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1116
Location: SC
From the log it looks like you have corrupted packages in your pacman cache /data/storage/disk0/pacman/pkg/. Delete tdb at the very least. It could also be there isn't enough disk space or even a network problem.


Top
 Profile  
 
PostPosted: Thu Oct 23, 2014 3:09 pm 
Offline
Joined: Sun Sep 05, 2004 7:06 pm
Posts: 678
Well I had a little time to reflect on the upgrade. I decided to take to plunge into R8.2 testing. Once I changed to core-testing and extra-testing I was able to run the script to upgrade to R8.2. When I ran the script it asked me to choose mesa-libgl or nvidia -libgl. I did not know which one to choose so I guessed... and it didn't like that. So I ran the script again and chose the other and that created a conflict. After that I ran it one more time I was able to move past it and then it downloaded and installed all of the packages. So far I'm impressed with the upgrade. My shows came up right away. XMBC 13.2 upgraded my live channels showed up and and my library. Without having to scan again :lol: Also google-chrome upgraded and kept all of my bookmarks and extensions...


Top
 Profile  
 
PostPosted: Thu Oct 23, 2014 3:29 pm 
Offline
Joined: Sat May 03, 2014 8:47 pm
Posts: 13
I tried delting tdb from

Here are applicable lines from my pacman.conf. Is anything wrong here?

#[core]
#SigLevel = Optional TrustedOnly
#Server = http://bits.linhes.org/repo/$arch/$repo/

#[extra]
#SigLevel = Optional TrustedOnly
#Server = http://bits.linhes.org/repo/$arch/$repo/

[core-testing]
Server = http://bits.linhes.org/repo/$arch/$repo/
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[extra-testing]
Server = http://bits.linhes.org/repo/$arch/$repo/
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

Here is the results from trying to run the upgrade script again after deleting tdb package:

[root@mythbox pkg]# rm tdb-1\:1.2.9-1-x86_64.pkg.tar.xz
[root@mythbox pkg]# curl -o update81-82.sh http://cgit.linhes.org/linhes_pkgbuild/ ... ?h=testing
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 3251 100 3251 0 0 578 0 0:00:05 0:00:05 --:--:-- 15936
[root@mythbox pkg]# sudo sh ./update81-82.sh

About to update the OS to LinHES 8.2
This process will only work if currently running LinHES 8.1 or later
* Please respond with Y to ALL the yes/no questions
* Answer Y to remove sysvinit
* If prompted about libgl, select the gl that is appropiate for your system

Press Y to continue, any other key to stop
Y

Syncing pacman repos...

Downloading filesystem and glibc for later use, please wait...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 8500 100 8500 0 0 1498 0 0:00:05 0:00:05 --:--:-- 41062
filesystem package downloaded
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 8337k 100 8337k 0 0 269k 0 0:00:30 0:00:30 --:--:-- 181k
glibc package downloaded
Installing tdb...
warning: downgrading package tdb (1:1.2.9-1 => 1.3.0-2)
resolving dependencies...
looking for inter-conflicts...

Packages (1):

Name Old Version New Version Net Change Download Size

core-testing/tdb 1:1.2.9-1 1.3.0-2 -0.04 MiB 0.06 MiB

Total Download Size: 0.06 MiB
Total Installed Size: 0.18 MiB
Net Upgrade Size: -0.04 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages ...
tdb-1.3.0-2-x86_64 60.6 KiB 146K/s 00:00 [####################################################################################################] 100%
(1/1) checking keys in keyring [####################################################################################################] 100%
(1/1) checking package integrity [####################################################################################################] 100%
error: tdb: missing required signature
:: File /data/storage/disk0/pacman/pkg/tdb-1.3.0-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.
FAILED: pacman -S tdb

thoughts?


Top
 Profile  
 
PostPosted: Thu Oct 23, 2014 4:22 pm 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1116
Location: SC
Try changing -testing to:
Code:
[core-testing]
SigLevel = Optional TrustedOnly
Server = http://bits.linhes.org/repo/$arch/$repo/

[extra-testing]
SigLevel = Optional TrustedOnly
Server = http://bits.linhes.org/repo/$arch/$repo/


I don't think it should matter but you probably shouldn't run update81-82.sh from the pacman cache dir. The script downloads some packages that you don't want pacman to get confused with and install later.

If you still get corrupt packages you could try changing repos back to core and extra and reinstalling pacman.


Top
 Profile  
 
PostPosted: Thu Oct 23, 2014 4:46 pm 
Offline
Joined: Sat May 03, 2014 8:47 pm
Posts: 13
I'm afraid things are progressing much better. I even tried setting -testing to SigLevel = Never as well. No luck. It's like the testing repos don't contain the files the script is calling to upgrade?

See pastebin log info here: http://pastebin.com/P1yTT4Ys

Scott


Top
 Profile  
 
PostPosted: Thu Oct 23, 2014 4:57 pm 
Offline
Joined: Sat May 03, 2014 8:47 pm
Posts: 13
I tried the tip to re-install pacman as well. No luck...

[root@mythbox mythtv]# pacman -S pacman
warning: pacman-4.1.0-1 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...

Packages (1):

Name Old Version New Version Net Change Download Size

core/pacman 4.1.0-1 4.1.0-1 0.00 MiB 0.57 MiB

Total Download Size: 0.57 MiB
Total Installed Size: 3.89 MiB
Net Upgrade Size: 0.00 MiB

:: Proceed with installation? [Y/n] Y
:: Retrieving packages ...
error: failed retrieving file 'pacman-4.1.0-1-x86_64.pkg.tar.xz' from bits.linhes.org : Failed writing body (237 != 1364) 5.1 KiB 7.91K/s 01:13 [----------------------------------------------------------------------------------------------------] 0%
warning: failed to retrieve some files
error: failed to commit transaction (download library error)
Errors occurred, no packages were upgraded.


Top
 Profile  
 
PostPosted: Thu Oct 23, 2014 5:27 pm 
Offline
Joined: Sun Apr 30, 2006 7:49 pm
Posts: 37
Location: Ottawa
sfsouter wrote:
:: Retrieving packages ...
error: failed retrieving file 'pacman-4.1.0-1-x86_64.pkg.tar.xz' from bits.linhes.org : Failed writing body (237 != 1364) 5.1 KiB 7.91K/s 01:13 [----------------------------------------------------------------------------------------------------] 0%
warning: failed to retrieve some files
error: failed to commit transaction (download library error)
Errors occurred, no packages were upgraded.


Is it possible that your pacman cache partition is full? If this message is to be believed, you are getting a write error.


Top
 Profile  
 
PostPosted: Thu Oct 23, 2014 9:12 pm 
Offline
Joined: Sat May 03, 2014 8:47 pm
Posts: 13
So sorry folks... Indeed my small drive where Linhes is installed was full. I will need to figure out a way to eliminate this main drive from the directories available for recordings to reside. I have four other large drives via Storage Groups.

Once I freed up some space this upgrade seems to have completed without any other hitches.

Success.
Scott


Top
 Profile  
 
PostPosted: Sat Oct 25, 2014 8:37 am 
Offline
Joined: Sun Oct 30, 2005 7:07 pm
Posts: 72
I just installed R8.1.1, and am wanting to upgrade to R8.2. I am just wondering if the upgrade script is the best way to go, or should one use the CD ISO (when it is available) and perform a fresh install of R8.2?

Another question: when do the developers expect 8.2 to be released officially? Will it be before the Schedules Direct cutover on November 1, by chance?

Thanks to all for their work on LinHES!

Thanks,
Trevor


Top
 Profile  
 
PostPosted: Sat Oct 25, 2014 9:13 am 
Offline
Joined: Sun Apr 30, 2006 7:49 pm
Posts: 37
Location: Ottawa
OK, one issue. I don't know if it's my problem, or an issue with the update, but mplayer doesn't run on the updated system, libmpeg2.so.0 is not present on the system. The previous version of mplayer didn't link a library called libmpeg2.so, but the new version does.


Top
 Profile  
 
PostPosted: Sat Oct 25, 2014 9:53 am 
Offline
Joined: Sun Sep 05, 2004 7:06 pm
Posts: 678
One Issue

With Mythwelcome, every time I record a program the PC doesn't automatically shutdown. The counter says 30 seconds, but after 30 seconds, the date clock bar on the Mythwelcome screen flashes. The counter does not change to 0.

Clues
1.) Manually from the shell as mythtv ran this..... works properly
Code:
/usr/bin/mythshutdown --shutdown

2.) Manually from the the menu run shutdown this.... works properly

Other Ideas
3.) Changed the halt command to
Code:
 Mythwelcome --Shutdown
this..... does not correct the problem

4.) Changed the permissions of mysql.txt
Code:
chown mythtv:mythtv mysql.txt
this..... does not correct the problem

Also when my PC shuts down it noticed this after the services shutdown

Code:
Deactivating Swap
Unmounting non-API filesystem
cat: /tmp/plymouthhd: No such file or directory
cat: /tmp/plymouthhd: No such file or directory

tried as root

Code:
Find / -name plymouthhd


nothing googled it https://wiki.archlinux.org/index.php/plymouth

Also the second to last command fails every time I shutdown the PC.

/etc/runit/3.local
:: /etc/runit/3/local
> Iniating shutdown...

:: Umounting network filesystems OK
:: Saving Random Seed OK
:: Shutting down udev OK
:: Sending Sigterm to processes Fail
:: Sending Sigkill to processes OK

Then it turns off


Last edited by RacerX on Sat Oct 25, 2014 12:45 pm, edited 8 times in total.


Top
 Profile  
 
PostPosted: Sat Oct 25, 2014 10:14 am 
Offline
Joined: Sun Sep 05, 2004 7:06 pm
Posts: 678
Also

Code:
Pacman -Syu


ceton_infinitv-2013 package

Code:
rmmod: ERROR: Module ctn91xx is not currently loaded
modprobe: FATAL: Module ctn91xx not found.
error: command failed to execute correctly


I have hdhomerun


Top
 Profile  
 
PostPosted: Sun Oct 26, 2014 9:47 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1116
Location: SC
neufeld wrote:
OK, one issue. I don't know if it's my problem, or an issue with the update, but mplayer doesn't run on the updated system, libmpeg2.so.0 is not present on the system. The previous version of mplayer didn't link a library called libmpeg2.so, but the new version does.
Fixed.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 67 posts ] 
Go to page Previous  1, 2, 3, 4, 5  Next



All times are UTC - 6 hours




Who is online

Users browsing this forum: Bing [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu