LinHES Forums

LinHES 8.4 upgrade fail :::Solved:::
Page 3 of 3

Author:  mattbatt [ Mon May 16, 2016 2:11 pm ]
Post subject:  Re: LinHES 8.4 upgrade fail :::Solved:::

[mythtv@gimli ~]$ lspci | grep -i nvidia
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 430] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GF108 High Definition Audio Controller (rev a1)
[mythtv@gimli ~]$ lspci -n | grep '01:00.0'
01:00.0 0300: 10de:0de1 (rev a1)
[mythtv@gimli ~]$

Author:  winnpeny [ Sun May 22, 2016 7:23 pm ]
Post subject:  Re: LinHES 8.4 upgrade fail :::Solved:::

mattbatt, Brfransen or RacerX,

Could you suggest when during the upgrade process is the best time to issue this command? I use the same graphics card and will have the same problem.

sudo VGACARDTYPE="nvidia-340xx"

Thanks for your help.


Author:  brfransen [ Sun May 22, 2016 7:43 pm ]
Post subject:  Re: LinHES 8.4 upgrade fail :::Solved:::

A fix went into R8.4.1 (update of libglvnd) that has been confirmed to fix the problem on a GT520 as well as on another GT430. That said mattbatt was still having an issue with his even with the fix. So I would try it and if mythtv-setup or mythfrontend won't run then run that command. Also note that not all newer cards will work on the 340 branch of the nvidia drivers, and maybe not all GT430s if there are multiple device variations.

Author:  mattbatt [ Mon May 23, 2016 11:12 pm ]
Post subject:  Re: LinHES 8.4 upgrade fail :::Solved:::

It's kinda like a spare tire.. You'll know when you need it.

Author:  winnpeny [ Wed Jun 22, 2016 1:57 pm ]
Post subject:  Re: LinHES 8.4 upgrade fail :::Solved:::

I learned how to change the tire on a LinHES box today, but I might have put it on the wrong axle.

I did my 8.4.1 upgrade and the mythfrontend screens came up normally. But when I went into playback mode, the screen went blank (actually I could see the bubble background) while the audio played. There was no response to keyboard or remote control keypresses.

I looked in mythtv_mythfrontend.log and could see a segmentation fault, so I used your solution to downgrade the driver. The downgraded driver produced the same results. Next I went into setup and looked at the Video>Playback settings and saw that the Playback Profile was set to OpenGL. I changed it back to VDPAU Normal and now I had video during playback.

Just for fun I then ran again and let it install the current nvidia driver and I still had video during playback.

So, I think my problem was the Playback Profile being set to OpenGL and not the driver. I'm not sure when or how it switched to OpenGL.


Page 3 of 3 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group