LinHES Forums

New 8.6 install, rpcbind error
Page 1 of 2

Author:  fr33f411 [ Tue Apr 09, 2019 8:38 pm ]
Post subject:  New 8.6 install, rpcbind error

I'm a new user coming from mythbuntu and I have not had a smooth experience installing LinHES 8.6. I worked through some issues, like having to install the nvidia 340 driver version, but I'm still having issues getting my remote to work and with the frontend system playing HD content smoothly.

My hardware is: Zotac MAG Intel Atom N330, NVIDIA ION, 2 GB DDR2, 160 GB HD, eSATA, HDMI HD-ND01-U Mini PC.

If I enter ctrl-alt-f1 then I see the following repeated at least every second:
rpcbind: another rpcbind is already runnnig. Aborting
Starting rpcbind

I also see every so often :
rsyslogd: cannot resolve hostname '' connection timed out

I believe I saw the same error when the system was booting before I resolved my nvidia driver issues. I don't see the rpcbind error in any log. Any ideas as to what I need to do to resolve this error?

Also on mythbuntu I could hit ctrl-alt-f7 to go back to the windowed session, but this is not working in LinHES, is there another way to get back to the windowed screen?

Author:  tscholl [ Wed Apr 10, 2019 10:46 am ]
Post subject:  Re: New 8.6 install, rpcbind error

I had a similar problem caused by a wrong version of the nvidia 340 drivers being installed.

Try upgrading the drivers using pacman -Syu pacman -Sy nvidia-340xx

Author:  brfransen [ Wed Apr 10, 2019 10:56 am ]
Post subject:  Re: New 8.6 install, rpcbind error

What driver does sudo pick on your system without forcing the 340 driver?

I have a fix for rpcbind. Functionally it isn't an issue but it will get rid of the message.

Did you see the rsyslog error only on the console screen? Not in any other log?

Author:  fr33f411 [ Wed Apr 10, 2019 9:34 pm ]
Post subject:  Re: New 8.6 install, rpcbind error

If I run sudo
it picks the nvidia-390xx driver.
But with the 390 driver, the graphic console will not come up at all. Then I just get the console window with the rpc.bind error continually scrolling. I'm not super familiar with LinHES logging, but I couldn't find the rpc error in /var/log/* or /var/log/*/* . Only see it on the console if he UI doesn't come up or if I do ctrl-alt-f1 .

If I run the commands per tscholl then the nvidia driver version 340.107-4 is installed and the UI will come up, but I still have the rpc messages on ctrl-alt-f1 console. And I have stuttering running the myth video test for HD content, with vdpau slim even though the cpu usage is not that high. ~25% The playback issue might not be related to the rpc issue, but I didn't have any playback problems with this hardware with mythbuntu (older version).

tscholl , if you do ctrl-alt-f1 is your console output clean?

Author:  tscholl [ Thu Apr 11, 2019 1:12 pm ]
Post subject:  Re: New 8.6 install, rpcbind error

If I ctrl-alt-f1, I can confirm that I am getting a repeating rcp bind error as well, and then re spawn's another process.

I had never looked there before you mentioned it. Britany might have an answer for you on that. But yes it looks like I have the same thing happening here.

Author:  brfransen [ Thu Apr 11, 2019 2:05 pm ]
Post subject:  Re: New 8.6 install, rpcbind error

rcpbind trying to restart is fixed: ... a42c6a2b6c

I think I found the issue with trying to install the 390 driver. If you would test this update and see if it chooses the 340 driver I would appreciate it.
sudo pacman -U


Author:  fr33f411 [ Thu Apr 11, 2019 8:09 pm ]
Post subject:  Re: New 8.6 install, rpcbind error

Installed the package and ran the script. It installed the 340 version.
Detected NVIDIA as the video card type
ION 0x087D  B 1
  Checking for nvidia-340xx in cache or online
  Checking for nvidia-340xx-utils in cache or online
  Checking for opencl-nvidia-340xx in cache or online
  Checking for nvidia-340xx-settings in cache or online
  Checking for libglvnd in cache or online
  Checking for libxnvctrl-340xx in cache or online
Installing nvidia-340xx driver
  Successfully Installed
Setting resolution to Auto
Running plymouth_config

Author:  RacerX [ Thu Apr 11, 2019 9:33 pm ]
Post subject:  Re: New 8.6 install, rpcbind error

I have an Asus P5N7A-VM
NVIDIA GeForce 9300/nForce 730i

Tested out 8.6.iso with etcher and a scandisk 8gb usb stick and a DVD (they both fail at linhes.service)
I booted and then the srceen comes up to install and I choose no splash.

Checking mysql
Checking for remote
Preparing live environment
Job for linhes-install.service fails because the control process exited with error code
See systemctl status linhes-install.service and journalctl -xe

jounalctl -xe
start{1128} setting resolution to auto
system-udevd260 specified user igunair is unknown
system-udevd260 invalid rule /usr/lib/user/rules.d
unit linhes-install.servie has failed

then it says control process exited with error code

see systemctl status install-linhes.service

When I I go there I see that it's installed nvidia-390x driver
it finishes and then kicks me out to

I can't run pacman because I'm not on the network at this part of the install....

Author:  fr33f411 [ Fri Apr 12, 2019 6:13 am ]
Post subject:  Re: New 8.6 install, rpcbind error

I had the same issue. To get it to install, I had to choose the special hardware option and then vesa.

Author:  RacerX [ Fri Apr 12, 2019 10:41 am ]
Post subject:  Re: New 8.6 install, rpcbind error

Thanks for the tip, I booted up with my usb stick and was able to complete the install by selecting VESA.

When the install finished I rebooted and now I see the rcp error.
It runs and runs and then the cpu goes into thermal throttle.
I used
control c
to break out of it and continue to mythtv setup.

I'll try and test more later tonight when my recording are complete, it''s just a test....

Author:  brfransen [ Fri Apr 12, 2019 12:11 pm ]
Post subject:  Re: New 8.6 install, rpcbind error

The rpcbind issue has been around since before R8.5.2 should have very little cpu overhead. Basically rpcbind changed the command line switch -d to allow it to be backgrounded which makes runit loose control of the process. So runit would think rpcbind had quit and would try to restart but rpcbind was already running and would throw the error to the console. Rinse and repeat. Functionally rpcbind was already running so NFS would work just fine, runit just didn't know it and wouldn't have been able to stop rpcbind. Fixed now and in the stable repos.

RacerX, I really don't see how runit trying to restart rpcbind could have caused the cpu to thermal throttle. More likely the frontend trying to restart and not being able to because of the nvidia driver is the cause of the thermal throttle. The fixed (part of LinHES-config) is in the stable repo now and I am building a R8.6.1 ISO with the updated so that the nvidia 340 driver is detected correctly on install.

Also, one more note, if you don't have networking all the graphics drivers are included on the ISO so they can be installed offline. From the console force which driver you want and then the install GUI should start.
sudo VGACARDTYPE="nvidia-340xx"
sudo VGACARDTYPE="vesa"

Thanks to all for the feedback and testing!

Author:  RacerX [ Fri Apr 12, 2019 12:38 pm ]
Post subject:  Re: New 8.6 install, rpcbind error

Thanks for explaining how it works. I suppose the thermal issue could be just thermal paste for the cooler not fitting perfect (intel). In my test i never went farther than the mythtv setup portion. I want toto upgrade to because the last update went south and I had roll back two versions back and this broke mythweb. If the test works good then I will migrate to R8.61......

Author:  RacerX [ Sat Apr 13, 2019 2:14 pm ]
Post subject:  Re: New 8.6 install, rpcbind error

Reloaded my test this morning and tested a bit more

R8.6.1 I try to setup audio based on on previous setup (hdmi thru reciever to tv), but no sound at all no matter what I tried. So I thought why not check the nvidia driver. When I ran nvidia-settings it's not installed.

On the arch forum someone said try
pacman -S nvidia

Didn't seem to do much
then I tried
pacman -S nvidia-settings

installed but some file conflict and it asked do you want to remove nvdia 340xx
I said ok and then I noticed that my sound started to work

Something is going on with the nvidia driver. With my old build nvidia-setttings displays nvidia 340 and audio works fine.

I'll try and test more later tonight

Author:  brfransen [ Sat Apr 13, 2019 4:32 pm ]
Post subject:  Re: New 8.6 install, rpcbind error

LinHES is not Arch. There are many many many things that do not work the same way.

If you forced Vesa from the ISO that may be why it didn't install the nvidia driver.

Use to install the correct driver. That will also get you the correct version of nvidia-settings. Based on what you have done now the next time you restart the frontend or reboot X won't start because the nvidia driver doesn't work with your card. I think your 9300 needs the nvidia-340xx driver but the card id will confirm that. You can get the card id by running

Author:  RacerX [ Sat Apr 13, 2019 4:48 pm ]
Post subject:  Re: New 8.6 install, rpcbind error


I will try again another test tonight from sratch. I never had to use Vesa before not really sure what it does other than it works......

New install Vesa, plain vanilla, upgrade to 8.6.1 thru the gui

Detected Nvidia as the video card type
GeForce 9300 / nForce 730i 0x086C B 1
Checking for nvidia-3400xx in cache or online
Checking for nvidia-340xx in cache or online
Checking for opencl-nvidia340xx in cache or online
Couldn't find opencl-nvidia-340xx for install, aborting

So nothing is installed yet?

I took the plunge
Code: nvidia-3400xx
installed fine
Code: nvidia-3400xx-utils
installed fine

setup sound, works properly,,,,

I'm using mce black remote it works a lot better with r8.61. Only issue I can't back it all the way out to mythwelcome screen for shutdown.

On my tv
 control X
opens a huge window that is a little overscan at the top. Can I make the window smaller to fit my tv better?

I migrated primary system to R8.6.1 just followed the same steps with update to r8.6.1 and run it automatically installed 3400xx and then I installed the utils

Mythweb is now working again, and my remote has better functionality.....

Many Thanks

Page 1 of 2 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group