View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 3 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Fri Jul 23, 2010 12:33 am 
Offline
Joined: Sat Oct 07, 2006 7:18 pm
Posts: 55
My new nvidia gt220 card is working delightfully well so far for 1080p video over HDMI. Sound, not so much. It's like the kernel sees a sound device there but doesn't know what to do with it.

I was looking at the instructions here:

http://wiki.xbmc.org/?title=HOW-TO_set_up_HDMI_audio_on_nVidia_GeForce_G210%2C_GT220%2C_or_GT240

...and it suggested that I might need alsa version 1.0.23 or later. Doing "cat /proc/asound/version" turns up 1.0.18rc3.

How hard is it to upgrade alsa beyond that? Tried the usual pacman upgrade commands but it claims to have the latest already. Could I grab a package file from another distro that uses pacman and just drop it in? Is there a bleeding-edge repository for LinHES that I could switch to with a more recent version of alsa?

Thanks!


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jul 23, 2010 11:16 am 
Offline
Joined: Sat Oct 07, 2006 7:18 pm
Posts: 55
I compiled the latest version of ALSA from source. Now it works, more or less. It's passing sound over HDMI but it quits working after rebooting and it sounds like the right channel is being turned into center somehow. Also some video files won't play any sound at all, and sometimes it quits working even without a reboot.

It doesn't help that I couldn't compile alsactl. Something about not being able to download and verify an XML DTD. XML for man page source? And it causes the compile to fail?? Not sure what these guys were thinking.

But still, partial success is a big step in the right direction.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jul 27, 2010 4:54 pm 
Offline
Joined: Sun Aug 28, 2005 7:07 pm
Posts: 821
Location: Melbourne, Australia
bouncey wrote:
It doesn't help that I couldn't compile alsactl. Something about not being able to download and verify an XML DTD. XML for man page source? And it causes the compile to fail?? Not sure what these guys were thinking.


The file that alsactl writes when it performs a store (which I assume is what you are looking for) is simply ascii text. You could write one yourself for the moment (although it may be wiser to ask one of the folks on the xbmc forum for a copy of theirs). I would try to find the bit it's attempting to retrieve and try to bypass it or hard code something. Have you Googled for the error? The apps that don't work probably have their own config files. For example, it your mythtv using mplayer or xine to play videos? What happens if you use Internal?

Also, after reading your post I looked into how much these cards are. Getting HDMI working properly would be really nifty (I could then not turn the DTS amplifier on sometimes - hooray!). So, I may be able to help you later: I'll be off today or tomorrow to buy a GT220 and will fiddle with it in the coming week. If, like you, I have to compile alsa then I'll do so and post the results.

Thanks again :-)

Mike

_________________
*********************
LinHES 7.4
Australian Dragon
*********************


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu