View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 4 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Fri Sep 07, 2012 9:03 pm 
Offline
Joined: Sun Mar 12, 2006 9:51 pm
Posts: 22
Clean 7.4 build w/ HVR-2250 and HVR-950Q. For the life of me, I can't get the Analog audio record volume to adjust on the 2250. Recorded volume is very loud and audio is distorting and clipping, on both analog tuners. The digital side records fine. I've adjusted the volume in the MPEG2 recording profile to no avail. I've tried v4l2-ctl and the volume shows 0 and says "not using libv4l2".

Any hints? Is it possible the analog tuner has/is going bad? My other option was to get the Analog side of the 950Q working, but that seems to be a dead end with our current kernel.

I had scrapped an (upgraded) 7.2 install with the same hardware in the spring, one of the reasons being the high analog volume. In the interim, I tried WMC 7 but eventually decided to come back to LinHES when I found there wasn't enough control in WMC for my taste! Anyway, I just checked one of the recordings from that WMC experiment and the analog volume appears to be "normal". :-(

TIA

-Joe


Top
 Profile  
 
PostPosted: Fri Sep 07, 2012 9:14 pm 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1175
Location: SC
The 950Q analog side is broken due to myth .25 not the LH kernel. It seems that .25 broke framegrabbers, or at least the ones I have as none of them work and they did in .24.


Top
 Profile  
 
PostPosted: Fri Sep 07, 2012 9:49 pm 
Offline
Joined: Sun Mar 12, 2006 9:51 pm
Posts: 22
Ah, ok, thanks for the clarification. I've had the 950Q for awhile, but I never tried to get the Analog side going on a version less than .25. It's a shame, because I really only need one working Analog tuner. -Joe


Top
 Profile  
 
PostPosted: Sat Sep 15, 2012 7:32 pm 
Offline
Joined: Sun Mar 12, 2006 9:51 pm
Posts: 22
[SOLVED] For reference, v4l2-ctl *is* the correct tool to adjust the recording volume, but the volume range is 0-24. I had to set mine to volume=1 to get it to match the volume level from the digital side.

http://ubuntuforums.org/showpost.php?p= ... tcount=335

example: v4l2-ctl --set-ctrl volume=10 -d /dev/video0

I think there is a possible bug in either Mythtv or LinHES, since the MPEG2 profile recording volume doesn't affect this setting. I will be posting a bug report.

Thx

-Joe


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu