View unanswered posts    View active topics

All times are UTC - 6 hours

Post new topic Reply to topic  [ 2 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Thu Aug 15, 2019 1:00 pm 
Joined: Mon Apr 23, 2007 1:45 pm
Posts: 405
Location: Fargo, ND, USA
Version Installed LinHES R8.6.1
This was a clean install of LinHES R8.6.1 on a SSD + data drive.

Problem: The Volume control / Mute for MythTV analog (Stereo or 5.1) goes up and down on the screen but dos not effect output volume.

What I have found so far is that Nvidia sound (snd_hda_intel) is not being set as the default sound module. One of the two pcHD5500 capture cards (cx88_alsa) in the system is taking the index=0 spot on a random basis. The Nvidia sound (snd_hda_intel) being index=2 has no effect on the sound output of the card in analog or HDMI MythTV settings. As long as LinHES audio is set to Alsa. The default setting seem not to change operations in MythTV.
> cat /proc/asound/modules
 0 cx88_alsa
 1 cx88_alsa
 2 snd_hda_intel

Alsamixer also opens up to one of the pcHD5500 capture cards (cx88_alsa). Using F5 you can change to the Nvidia snd_hda_intel page. The select default card button in F5 dos not work to choose the default card.
# alsamixer

From what I see in file /~/alsa-base.conf pcHD5500 (cx88_alsa) should never be able to take the index=0 spot.
This "options cx88_alsa index=-2" should be all that is necessary to solve the problem but it dos not work.

I tried for force Nvidia sound (snd_hda_intel) to index=0 by adding "options snd_hda_intel index=0" to the file but that only caused the module not to load at all. (so the file is being acted upon by the system)
# Force driver to grab index 0
#options snd_hda_intel index=0

# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2

pcm.dmixer {
  type dmix
  ipc_key 2048
  slave {
    pcm "hw:NVidia,0"
    period_size 512
    buffer_size 4096

pcm.!default {
  type plug
  slave.pcm "dmixer"

Anyone have a solution or a way to force the modules to load in the correct order? There appears to be something blocking it from happening.

LinHES R8.6.1

PostPosted: Sat Oct 26, 2019 3:45 pm 
Joined: Tue Aug 08, 2006 7:08 pm
Posts: 561
Location: UK
I don't know if you have solved this yet.
It might not solve the problem with the volume control, but you can disable cx88_alsa by creating a blacklist file in /etc/modprobe.d such as blacklist_alsa.conf which contains:

blacklist cx88_alsa

I don't know if it will disable both, you may have to add a duplicate line and add values after them.

Bruce S.

Updated 2019/10/26: AthlonII X2 265 Gigabyte GA-970A-DS3P
16Gb PC 1866 DDR3, 500GB+2TB+4TB SATA HDD,
Hauppauage Nova-T 500, Nova-T LinHes R8.6.1


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 6 hours

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu