View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 6 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Tue Jul 16, 2019 10:38 am 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 978
Location: Lexington, Ky
I've been using LinHES for years and my sound has always worked in Myth and Kodi. I also use volume leveling so I also have an .asoundrc file in /home/mythtv

With the increase in streaming I decided I wanted to try to use Chrome and the other Online Apps included in LinHES. However when I launch Chrome, or any of the other online apps I get no sound at all. From what I have read it should just work.

Have looked on here viewtopic.php?f=14&t=23941#p138302
and have tried suggestions in that thread.
Quote:
Service Menu --> LinHES Settings --> Audio

That works. It suggests
Quote:
For quick testing I use aplay /usr/share/sounds/restored.wav

aplay /usr/share/sounds/restored.wav returns the following message:
Code:
[mythtv@mythtv ~]$ aplay /usr/share/sounds/restored.wav
ALSA lib pcm_dmix.c:1099:(snd_pcm_dmix_open) unable to open slave
aplay: main:828: audio open error: No such file or directory

By the way /usr/share/sounds/restored.wav does exist. I can also run
Code:
speaker-test -Dsysdefault:CARD=Generic

and that works as well. Any other thoughts?


Top
 Profile  
 
PostPosted: Wed Jul 17, 2019 9:06 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1175
Location: SC
That post is pretty old and there have been some changes to how LinHES Settings --> Audio sets default devices but most of it still should be true. The specifics of what is in asound.conf has changed and the problem of various cards not working anymore hasn't been an issue since I made that change.
My guess is that your ~/.asoundrc is the issue. LinHES Settings --> Audio writes out /etc/asound.conf but since you have a ~/.asoundrc aplay (or chrome or any other app that uses ALSA default devices) won't use /etc/asound.conf. Try deleting (or rename) .asoundrc so that /etc/asound.conf is used. If that gets aplay working then you would need to combine the ~/.asoundrc and /etc/asound.conf.


Top
 Profile  
 
PostPosted: Thu Jul 18, 2019 11:17 am 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 978
Location: Lexington, Ky
Thanks for your reply.

I renamed my .asoundrc in mythtv home and then rebooted my system. Then tried chrome and youtube but still no sound.
Also tried:
Code:
aplay /usr/share/sounds/restored.wav

and it still returns the same error
Code:
ALSA lib pcm_dmix.c:1099:(snd_pcm_dmix_open) unable to open slave
aplay: main:828: audio open error: No such file or directory

aplay -l returns
Code:
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

/etc/asound.conf file looks like this.
Code:
pcm.dmixer {
  type dmix
  ipc_key 2048
  slave {
    pcm "hw:0,3"
    period_size 512
    buffer_size 4096
  }
}

pcm.!default {
  type plug
  slave.pcm "dmixer"
}

aplay -L returns
Code:
null
    Discard all samples (playback) or generate zero samples (capture)
sysdefault:CARD=Generic
    HD-Audio Generic, ALC887-VD Analog
    Default Audio Device
front:CARD=Generic,DEV=0
    HD-Audio Generic, ALC887-VD Analog
    Front speakers
surround21:CARD=Generic,DEV=0
    HD-Audio Generic, ALC887-VD Analog
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=Generic,DEV=0
    HD-Audio Generic, ALC887-VD Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=Generic,DEV=0
    HD-Audio Generic, ALC887-VD Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Generic,DEV=0
    HD-Audio Generic, ALC887-VD Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Generic,DEV=0
    HD-Audio Generic, ALC887-VD Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Generic,DEV=0
    HD-Audio Generic, ALC887-VD Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Generic,DEV=0
    HD-Audio Generic, ALC887-VD Digital
    IEC958 (S/PDIF) Digital Audio Output
hdmi:CARD=NVidia,DEV=0
    HDA NVidia, HDMI 0
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=1
    HDA NVidia, HDMI 0
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=2
    HDA NVidia, HDMI 0
    HDMI Audio Output
hdmi:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    HDMI Audio Output

I did think of one other thing that could be related to the problem. I am not using hdmi audio. I have never been able to get that to work so have been still using the audio out from the motherboard.

Tim


Top
 Profile  
 
PostPosted: Thu Jul 18, 2019 11:46 am 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1175
Location: SC
What device do you have set in LinHES Settings --> Audio?
Code:
cat /etc/systemconfig | grep SoundDevice


The pcm "hw:0,3" line in /etc/asound.conf is all kinds of wrong. It is formatted oddly too as the pcm line should have the card name not the number and that is part of what is wrong. The aplay error is because there is no 0,3 device on your box. That should be fixed by forcing a change to the default device.


Top
 Profile  
 
PostPosted: Thu Jul 18, 2019 1:10 pm 
Offline
Joined: Mon Apr 10, 2006 3:48 pm
Posts: 978
Location: Lexington, Ky
Thanks for that super quick reply!
Quote:
What device do you have set in LinHES Settings --> Audio?

The device shown there is
Code:
Generic device 0:ALC887-VD Analog [ALC887-VD Analog][pludgw;Generic,0)

cat /etc/systemconfig | grep SoundDevice returns
Code:
SoundDevice=""

So I think there is probably another problem somewhere.

I edited the "/etc/asound.conf an changed the line pcm "hw:0,3"
to pcm "hw:0,0" and now "aplay /usr/share/sounds/restored.wav" works.

That change also fixed the no sound problem in Chrome and YouTube.

I renamed my original .asoundrc rebooted and the sound in Chrome and YouTube still work.

But Looking at my " Mythtv Settings / Audio" it looks like my sound leveling configuration is no longer there. So it's not looking for the .asoundrc file anyway. Something else for me to look into.

What else need to be done to fix the /etc/asound.conf file?

Tim


Top
 Profile  
 
PostPosted: Thu Jul 18, 2019 1:21 pm 
Offline
Joined: Fri Jul 21, 2006 11:12 pm
Posts: 1175
Location: SC
Something got very out of sync. The setting screens need something to change to trigger systemconfig to run. Change the device to anything else press finish and then go right back in and set it back to what you want and press finish. That should fix SoundDevice being missing and write out the correct asound.conf.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu