View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 3 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sat Jul 26, 2008 11:21 am 
Offline
Joined: Wed Dec 10, 2003 8:31 pm
Posts: 1995
Location: /dev/null
Been using R5.5 for a while now and I had to do a mythrestore after f*cking up my nvidia settings (openGL and Qt painter). Anyway, after the successful restore, I was back in my frontend under the Qt painter watching some vids under mplayer when my xscreensaver turned on!

I have my .mplayer/config set with the "stop-xscreensaver=1" line, but it seems to have no effect now. I also verified that xscreensaver starts before mythwelcome in my .fluxbox/apps so it's not that....

Anyway, after googling a bit I found the solution in this thread. You need to add the following line to your ~/.mplayer/config since the old "stop-xscreensaver=1" apparently doesn't work with recent builds of mplayer:

Code:
heartbeat-cmd="xscreensaver-command -deactivate > /dev/null"


For your reference, here is my ~/.mplayer/config in its entirety:

Code:
monitoraspect=1.33333333333333
# stop-xscreensaver = 1
heartbeat-cmd="xscreensaver-command -deactivate > /dev/null"


Now the screensaver stay off when watching vids through mplayer, but does come on in mythfrontend when it's idle for the specified time.

_________________
Retired KM user (R4 - R6.04); friend to LH users.


Last edited by graysky on Sat Jul 26, 2008 1:35 pm, edited 1 time in total.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jul 26, 2008 11:32 am 
Offline
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
I'm afraid this might be my fault. We actually had a problem with this mplayer option at one point in the testing cycle and I added a restore fixup to knock that line out. If you look in that directory you _should_ find a backup file called /home/mythtv/.mplayer/config~ with the original version... :oops:

BTW - For reference, the correct version of the option is:
Code:
heartbeat-cmd="/usr/bin/xscreensaver-command -deactivate > /dev/null"


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jul 26, 2008 1:36 pm 
Offline
Joined: Wed Dec 10, 2003 8:31 pm
Posts: 1995
Location: /dev/null
Thanks for the reply, tjc. I edited the first post of the thread with the complete command you mentioned (although it seems to work just fine without the rest of it).

_________________
Retired KM user (R4 - R6.04); friend to LH users.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu