LinHES Forums

PVR-350 TV-OUT Install Script: R4V5 - R5Beta7 (NTSC only)
Page 1 of 11

Author:  SnapperDragon [ Sun Mar 20, 2005 5:11 pm ]
Post subject:  PVR-350 TV-OUT Install Script: R4V5 - R5Beta7 (NTSC only)

[PVRTEXT]This script is designed to help you setup your PVR card. It will download the latest version of the script and give you instructions on what to do. If you run into problems, the correct place for support is via the forums post at . Please follow the prompts to continue the process...

(Ignore the text above this line...this is stuff for the script to detect where to find it's updates.)

6/19/2006 - I have stopped supporting this script as the newest version of KnoppMyth come with their own version. I'll leave things in place for those of you running back-level versions of KnoppMyth for any reason.

3/26/2006 - R5Beta7 support added. You can either get the "" script which will then detect/ask about your current KnoppMyth version and then download the actual version specific pvr-350 script, or get the Beta7 script directly and run it.



wget ...

Read the procedure further below in this post on what to do next.

3/17/2006 - Apparantly I need to update the script to account for a passworded site. I will try to take care of that soon, and possibly have support for 30.2.

Make sure you have ssh/putty access to your box so that if the script fails to yield output you can go back and restore.

To restore your settings, ssh/putty back into your system and run the command using the "-r" option.

NOTICE: This script assumes a single pvr-350 configuration with a standalone system (running the database on same machine). Other combinations may work, but I don't know as I cannot test them. For best results, a standard install with working tv-out to vga is a good starting point. Sorry, no PAL support. For this, please tweak the resulting XFConfig-4 file yourself after the utility completes.

NOTE: Some KnoppMyth versions are omitted as I have not tested each and every one. One of the other scripts may work as the changes are either no changes necessary in some cases or very minor in others. This is especially true of the last several releases from what I can tell.

Currently, the supported KnoppMyth versions are:

2/1/2006 - R5A30.2 support added. No testing done as I had reports that the R5A30.1 script works with R5A30.2.

1/22/2006 - R5A30.1 support added.

12/18/2006 - R5A26 support added and worked first shot on my rig. Fresh install, verify tv tuning works via vga, then "" to get started.

10/25/2005 - Supports R5A22. I tested it a few times. As always with this script, I assume a fairly fresh install, but a lightly modified system should also work.

If anyone wants to veryif this with PAL support, just send me the XF86Config-4 file (complete) and any other files that had to be modified (PM me).

10/9/2005 - Update script to now support R5A16. No PAL support, unfortunately, at this point.

-Exit out of the MythTV interface, and bring up an xterm window.
-Next, change into the root user like this: su - root
-Next, get a copy of the "" script from my site for versions older than R5A22: wget . Next, make it executable: chmod +x . This script is fairly static and is included in new KnoppMyth builds. It is designed to find and download the other scripts which are maintained separately. This gives me the opportunity to make updates as necessary when new builds are released.
-Next, run the script:
-This will download the latest copy of the file from whereever on the internet it may be hosted. This file will be maintained as needed due to KnoppMyth and IVTV updates. Please note that it will usually lag behind new KnoppMyth releases, but hopefully, not too much.
-Instructions from the command will tell you to run the file using the syntax: perl ./ (so do it like that).
-This will then ask you to confirm the version of KnoppMyth you are running.
-Based on this info, a custom script for the release you are running (if available) will be downloaded from the intenet. You will then be given instructions for how to execute it (using the -i option).
-The script downloaded will behave differently for R4V5, R5A12, and R5A16 (and the ones after this). Follow the instructions carefully, but this should be straight forward. Some versions require a reboot and then re-running the script for correct functionality. You will be given this info.

I did some spot testing of the R5A16 script on a fresh installation and it worked.

For best success, I recommend you do this after you have at least setup proper KnoppMyth operation using your VGA monitor. Make sure it is able to show you live TV first before running the script(s).


If yours gets botched up, restore your IVTV file and XF86Config-4 files (originals backed up to the /root/pvr350util directory) and restart. You can then run the downloaded script in debug mode like this (as root in /root): perl ./ -d >out.txt. You can then cut-n-paste this into a private message for me and I will try to figure out what happened. I basically need to bits of info from your system: the BUSID, and the FB number. Send me what you get for the BUSID using the output of this command: lspci | grep iTV . For the FB number, use: cat /var/log/messages | grep "ivtv-osd: fb". If that does not work for the FB number, try this: /sbin/modprobe ivtv-fb; dmesg | grep "x"ivtv-osd: fb"

Please use either this thread or PM me for issues specifically concerning these scripts.

Author:  flatchmo [ Tue Mar 22, 2005 12:52 am ]
Post subject: 

Thanks for the script.

I am running KnopMyth 5A12.
I followed the script directions and rebooted.
X would not load, nor could I control the kybd or mouse.
SSHed into to find 0 byte XF86Config-4
Restored original .
All ok.
I think I'll try it again from the console instead of a ssh session.

Thanks SnapperDragon

Author:  SnapperDragon [ Tue Mar 22, 2005 4:51 pm ]
Post subject: 

Works better now with R5A12. I broke something that made R4V5 happy previously, so I will fix this in a day or two (it's now 3/30/05).


Please be aware that this script only works with R4V5. It says that in my original post, and I think the script also warns about this.

Getting pvr-350 out on R5A12 was documented by someone else already. I can say that I got it to work. The only annoying thing was that the desktop came up without starting mythtv (which the author pointed out).

I may have another go at this. If someone can let me know how to detect what KnoppMyth version is running on a system, I can probably roll both up into a single script.

I cheat a little for R4V5 by doing a "uname -a" command and get the Kernel version. I'm assuming that R4V5 has a different kernel than the previous releases, so I use this now to detect R4V5.

Author:  cesman [ Tue Mar 22, 2005 5:36 pm ]
Post subject: 

On R5, take a look at /etc/KnoppMyth-version.

Author:  SnapperDragon [ Tue Mar 22, 2005 9:10 pm ]
Post subject: 

Is this something that will be there going forward? If so, that would be very useful.

Author:  cesman [ Tue Mar 22, 2005 9:13 pm ]
Post subject: 


Author:  PaulC [ Mon Mar 28, 2005 8:46 am ]
Post subject:  Excellent script worked for me

Great work SnapperDragon your version 0.2.2 script worked beautifully for me. I had previously tried to follow the directions posted by alarson but I ran into a roadblock at the instruction "grep -i itv /proc/fb" Maybe I missed a prior step, I don't know, but my /proc/fb contained only "0 VESA VGA" there was no iTV line.

Your script fixed whatever was missing so now /proc/fb reads:

1 iTVC15 TV out

And I have video and audio out of my PVR350.

Question: Now when I boot up, my monitor (not TV) shows a blank screen. I can Ctrl-Alt-FKey to different virtual consoles. Can I add back in the generic VESA stuff to XF86Config and be able to run a non-Myth X desktop on my monitor while simultaneously running MythTV to my TV output?

And, even better, can I run MythTV on my monitor and TV either simultaneously or sequentially? I have video cabling runing through a wall, so my MythTV server and monitor are in a separate room from my TV.

Thanks enourmously.

This is what was in my original XF86Config-4 from the intial R5A12 install.

Section "Device"
### Available Driver options are:-
# sw_cursor is needed for some ati and radeon cards
#Option "sw_cursor"
#Option "hw_cursor"
#Option "NoAccel"
#Option "ShowCache"
#Option "ShadowFB"
#Option "UseFBDev"
#Option "Rotate"
Identifier "Card0"
# The following line is auto-generated by KNOPPIX mkxf86config
Driver "vesa"
VendorName "All"
BoardName "All"
# BusID "PCI:1:0:0"

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultColorDepth 16
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"

Author:  SnapperDragon [ Mon Mar 28, 2005 8:45 pm ]
Post subject: 

Glad it worked for you.

I'm not an X expert, so I don't know how to help you with what you are trying to do. I think I may have considered this in the past, but I've never pursued it.

For the moment, all I'm really doing is taking all the posts about how to make this work and just automating it to save others time.

However, as time goes on, if these things are discovered, I'd be more than glad to update the script with additional options.

Author:  greenstalk [ Wed Mar 30, 2005 4:02 am ]
Post subject: freezes my Myth on boot

I've -just- installed Myth for the first time, from KnoppMythV5A12, and for testing purposes am currently using a single Hauppage PVR-350. Since I quickly discovered that video-out wasn't working at all (only to my monitor, not to my TV, and this machine has an ancient video card that can't keep up with realtime video, though it -does- have a 1-year-old mobo), I googled and immediately found this thread.

Unfortunately, when I installed v0.2.3, my TV went from black to a bunch of gray and blackish bars in a stepped-diagonal pattern---looks like wrong sync. So I figured it would be fixed when I actually booted, but when I did, I discovered that my machine just -freezes- during boot, with the TV looking exactly like that. The last few lines in on my monitor say:

Encoder revision: 0x02040011
Decoder revision: 0x02020023
Configuring WinTV PVF 350 card with 9 streams
Create DMA stream 0 using 256 16384 byte buffers 4194304 kbytes total
Registered v412 device, streamtype 0 minor 0
Create DMA stream 1

and now it's frozen. I'm not even sure how to boot the machine into any -un-frozen state, to inspect any logs or do anything else. Since I only just installed from KnoppMytyh, I can easily just use that CD to totally wipe the disk and reinstall, or perhaps boot a normal Knopp distro and poke around (e.g., to put the backup files back, though it's be -almost- as fast just to reinstall at this point anyway), but that won't help in debugging this at all.

Anyone have any idea what could be going wrong? Is there something I should look for before I run the script?

Note: My TV is currently connected to the composite-out (not SVideo out) cable coming out of the 350, but I assume this makes no difference at all (I assume that both are simply driven simultaneously by the card).


Author:  PaulC [ Wed Mar 30, 2005 7:44 am ]
Post subject: 

It's interesting that you see messages. In my case the PVR350 displays nothing until MythTV is actually running. Unlike the video output on my VIA EPIA, the PVR350 does not appear to mirror the VGA output. I'm using the composite output on the PVR350 and the TV screen stays black with a faint crawling pattern until MythTV is actually up and running. All the boot messages show up on the VGA monitor.

As to your problem, have you tried Ctrl-Alt-F1 through F5? On my Myth back end with PVR350 video out enabled what happens is that the VGA monitor shows all the bootup messages but then goes completely blank and unresponsive once X windows starts up on the TV output. However, even though the graphics on the VGA monitor are gone, the text virtual consoles are still available.

As soon as I work up the courage I'm going to try the configuration I suggested above where I add back in the original contents of the XF86Config-4. Hopefully I can display different screens to the VGA monitor and the PVR350 TV output at the same time without frying anything.

Author:  greenstalk [ Wed Mar 30, 2005 10:33 am ]
Post subject: 

Oops---I should have been clearer. All the messages I see on boot are on the console, as usual: I never see anything (except the frozen I'm-not-synced-pattern) on the TV. And when the machine freezes, it's so hung that no keyboard input works (I've tried C-Alt-F1 through F5,and also C-Alt-Del) and even the soft power switch isn't responsive; I have to turn off the power supply to recover.

Interestingly enough, though, I -can- ping it. (And have verified that I'm pinging the host I think I'm pinging---unplugging the 100baseT cable makes the pings fail until it's plugged in again. :) But I can't ssh to it (connection refused), and hadn't tried in the configuration to see if sshd gets enabled after a normal boot. (It could well be that it's just way too early in the boot, given that it's still blatting out messages to the console and presumably isn't at a high enough runlevel yet.)

Btw, the hardware here is an MSI K7N2 Delta-L motherboard with an Athlon XP 2800+ CPU.

Author:  PaulC [ Wed Mar 30, 2005 12:29 pm ]
Post subject: 

Have you tried typing "linux 1" at the LILO prompt in order to enter runlevel 1?

With R5A12 on my machine it displays a screen with a red box at bootup and a menu to select what image to boot (even though there's really only one image available) and instead of selecting an image with the arrow keys it's possible to simply type "linux 1". You should type whatever the image name is if you don't have the default of linux.

When you boot into runlevel one it should not initialize graphics, it should boot to a text login screen and it will not allow any user other than root to login.

Author:  greenstalk [ Wed Mar 30, 2005 2:02 pm ]
Post subject: 

I can't figure out how to -stop- it from botting. From powerup, it -never- gits me a LILO prompt, but just instead instantly starts loading vmlinuz, etc. I tried typing I and S at various points just in case something might notice, but it didn't. It -did- get slightly farther on that particular boot; after the

Create DMA stream 1

message I saw several of the sort

Regsitered v412 device, stream 0 minor 0

etc up to Create stream 6 using 1024 2048 byte buffers 262144 kbytes total

and then total lockup again.

I checked the various scripts created by, and noticed a couple of odd things:

(a) BusID was "". since lspci says 0000:01:07.0 for the Hauppage card, I changed that to say "01:07:0". I don't know if I needed a "PCI:" before that, as I have in my XF86Config-4 on a different distro (Mandrake).

(b) gdm.conf hardwires 1=Standard, whereas the original was 0=Standard. This seems odd, because my X config only defines a screen 0, but maybe I misunderstand what this is supposed to be doing.

(c) The script completely removes the actual VESA VGA based monitor from the XF86Config-4 file. I'm not sure why it does this; clearly that means I won't have a monitor console even if the TVout worked, but I assume I can fix that later.

Author:  SnapperDragon [ Wed Mar 30, 2005 2:28 pm ]
Post subject: 

One of the problems with the original post by ALARSON is that you get TV-OUT to the TV, but if you try to exit out to the X desktop it hangs. I don't know what to do about this at the moment, unfortunately. If this ever gets solved, I'll gladly add the fix to the script so that it sets up the PVR-350 out correctly.

I have several options available in the script. If you want to restore to the previous state, you will need to access the console (direct or via ssh) and then do "perl -r". It saves the files into /root/pvr350util that it modifies, and then replaces these. It only does one backup the first time, so if you repeatedly run the utility, you will still only have the original files backed up.

Also, I have seen what you saw also on my mythtv box. I think my problem is the BusID line got detected wrong. It's easy to spot....after the util is run, look at the /etc/X11/XF86Config-4 file and at the bottom look at the busid line and see what it says. Yours should read "BusID 0:0x07:1" based on the info you provided.

If you can get back to a screen, you can see what the util detects by doing this:

perl -d

This will not modify files and just output some stuff, namely the Busid, the FB device, and the tyner type (and some other stuff). If you can post that, it would help.

(The lspci command does not give you the busid in the format that the XF86Config-4 file expects. This is what threw me for quite a while, as all the examples assume a "0" for the buss, and from the published examples, it's not obvious how to structure the lspci output into the busid format in the X config file. This is one of the things the file will do. The only trick is that it must correctly get this from the output of the lspci file and then extract this data. )

Author:  SnapperDragon [ Wed Mar 30, 2005 2:40 pm ]
Post subject: 

By the way, the script is set to output from the PVR-350 SVIDEO port, not composite. Not sure if this was the problem. I think if you want to change this you have to modify the /etc/mythtv/modules/ivtv file and look at the output_select=1 line (guessing). Try 0, 2, etc and see what happens I guess.

Page 1 of 11 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group