View unanswered posts    View active topics

All times are UTC - 6 hours

Post new topic Reply to topic  [ 3 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Mon Apr 14, 2008 10:18 pm 
Joined: Mon Apr 14, 2008 3:26 pm
Posts: 3
I went through the howto at losdos after trying in vain to use the knoppmyth irblaster inline setup. I think it has to do with me also using the usb streamzap remote to control the box. Streamzap gets an entry in the lircd.conf file, but nothing ever gets in there for the irblaster.

irsend always gave "hardware doesn't support sending"

I decided to give the losdos howto a whack. Here are the things I had to do to get it going.

First, I went ahead and got lirc-0.8.2 instead of the 0.7.2 in the instructions. This was an install with the 5F27 image of knoppmyth.

The script fails when making the directories because lirc has an entry for ttusb and the script doesn't include it (no doubt because I'm not using 0.7.2).
>>I'm referring to these lines
mv ./drivers/lirc_serial ./drivers/ledxmit_serial
mv ./drivers/lirc_sir ./drivers/ledxmit_sir
You'll know what I mean when it fails. All you have to do is go edit the file (I used vi since it is there) and add the line for ttusb in with all the other directory creation lines and re-run the script.
>>like this
mv ./drivers/lirc_ttusb ./drivers/ledxmit_ttusb

Other than that, you can pretty much follow the script step by step. Except....

1. I bought the blaster from I could never see it in my video camera which does see ir from remotes. After hours of being sure my system was messed up, I looked up at the TV only to see a steady line of 2's being entered by the script.

2. The ledxmitd daemon wasn't starting on reboot after adding the lines in the howto to /etc/init.d/ If you did ls /dev/led* all you'd get is ledxmit0. If you followed the step by step instructions, you could change the channel using from the shell, but Myth could never do it. I wound up adding this to my /etc/init.d/ file to get the daemon to actually load, instead of what is in the howto. I think the main diff was the /bin/mknod line. I tried all permutations, and it only worked when I added these lines:
/bin/mknod /dev/ledxmit c 72 0
/bin/setserial /dev/ttyS1 uart none
/sbin/modprobe ledxmit_serial

(I tossed the if/fi check because ledxmit-ledxmitd never complained if I ran it more than once and I was troubleshooting. You might want to keep that in at first)

I was worried I'd never get this thing going, but here I am. I have the latest myth, my streamzap, and my DirecTV HD11 receiver.

Another pitfall: The newer DirecTV remotes are called RC16 (look inside the battery door for this). You can download the codes with wget right into place then rename the file to ledxmitd.conf but first go in and edit the names from one, two, three, to 1, 2, 3. I also changed the REMOTE name to rc16 to save a little typing later. Oh, the .conf file is at

Feel free to email questions to (that's a throw-away email that will work unless a robot gets ahold of it.)

Cheers! Bones

 Post subject:
PostPosted: Tue Apr 15, 2008 5:47 am 
Joined: Mon May 10, 2004 8:08 pm
Posts: 1891
Location: Adelaide, Australia
I'd just like to leave a note so that no one else follows jimbones example and attempts to follow the ledxmit path. All you need to do to setup a serial irblaster is to run the script.

Jimbo: It didn't update /etc/lircd.conf because it isn't supposed to. The config file that it uses is /etc/irblaster/irblasterd.conf. If you put your config file there (or even better yet, submitted it for inclusion in the next release so that you can just select it from the list when you run and used the /etc/irblaster/ script, it would all have just worked.

 Post subject:
PostPosted: Thu Apr 17, 2008 11:37 pm 
Joined: Mon Apr 14, 2008 3:26 pm
Posts: 3
You are correct about /etc/lircd.conf - that was a mixup on my end when typing the post. Sorry about that.

You are correct also, that one should use as it is the intended script and is the one used in the automated setup. I only listed this for people who are tearing their hair out in frustration and want to try something that did work for one guy. The would have worked great if it had worked. I was not clear about that, and I'm sorry.

I used during the automated setup, and then tried it later as well. I added the .conf file as you say. I even added my conf info into the list (well, I added a directory and the .conf file to the set of directories) that uses, selected it from the list in, and had the exact same problem.

I could never get it to work using the I used the script you suggest and did exactly what it said. I did it very carefully several times. Maybe I'm a special case.

Anyhow, what I said did work, and you are right, I'll send that conf file in.


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 6 hours

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu