LinHES Forums

New Nvidia graphic drivers.
Page 3 of 6

Author:  tanzania [ Fri Jul 09, 2004 7:03 am ]
Post subject: 

Did you do your initial install via apt-get? What was your package list?

I used the Nvidia script (with the results previously mentioned), and am wondering if I should rip it out and take the apt-get route...[/quote
My first try to update was the nvidia-installer script, which seemed to break my glx. Now that some time has gone there seem to be the right packages. i didn´t even uninstall the nvidias installation. What do you mean with package list? My sources.list? Or the installed packages?

# Stable
deb stable main contrib non-free
deb stable/non-US main contrib non-free

# Security updates for "stable"
deb stable/updates main contrib non-free
deb testing/updates main contrib non-free

# Testing
deb testing main contrib non-free
deb testing/non-US main contrib non-free
# Unstable
deb unstable main contrib non-free
deb unstable/non-US main contrib non-free

# Sources
deb-src unstable main contrib non-free
deb-src unstable/non-US main contrib non-free

deb unstable main

deb unstable/
deb ./

apt-cache depends nvidia-glx
Hängt ab: <nvidia-kernel-1.0.6106>
Hängt ab: xserver-common
|Hängt ab: xlibmesa-glu
|Hängt ab: <libglu>
Hängt ab: <libglu1>
Hängt ab: libc6
|Hängt ab: libx11-6
Hängt ab: xlibs
|Hängt ab: libxext6
Hängt ab: xlibs
Schlägt vor: nvidia-settings
Empfiehlt: nvidia-kernel-source
Kollidiert: nvidia-glx-src
Ersetzt: nvidia-glx-src

Author:  tjc [ Sat Jul 10, 2004 4:36 pm ]
Post subject: 

Actually I was looking for what what you said after "apt-get install ..." how about the output of:
apt-show-versions | grep -i nvidia | sort

Author:  tanzania [ Sat Jul 10, 2004 6:33 pm ]
Post subject: 

nvidia-glx/unstable uptodate 1.0.6106-3
nvidia-kernel-2.4.26-1-386/unstable uptodate 1.0.6106+1
nvidia-kernel-common/unstable uptodate 1.0.6106-1
nvidia-kernel-src/stable uptodate 1.0.2880-1

Author:  Headbonk [ Sun Jul 11, 2004 12:11 pm ]
Post subject: 

I was just getting around to configure the TV-Out on my R4V4.1 nforce2 based mythbox (so I can actually start using it in my living room instead of it sitting on my workbench).

I'm interested in upgrading to this driver, but I'm a little fuzzy on the install routes here. I'm not very experienced with X, and every time I try to do something that involves building kernels/modules under knoppmyth <exaggeration>I end up breaking things badly and have to go back to clean install</exaggeration>.

I'll try to narrow my confusion down to a couple questions:

There seems to be 2 routes here: apt-get or the nvidia uber-installer script (which seems kinda scarry). The uber-installer leaves problems with glx, but some people on this thread have resolved this (under vanilla debian-sid and 2.6 kernel) by making sure the old drivers were cleaned out before running the uber-script. Tanzania appears to have had success with good-ol apt-get. From the show version output I see that Tanzania's got the binary driver package and the source package - did the pre-built binary driver work, or would I need to build the kernel-source against the knoppmyth kernel? Tanzania - what version of knoppmtyh/kernel are you running?

Has anyone got the definative Tier 1, no-hassle upgrade path for a vanilla KnoppMyth R4V4 system? :lol:

Author:  Xsecrets [ Sun Jul 11, 2004 1:04 pm ]
Post subject: 

well I've used both and still have the glx problems and I have double checked that there are no older drivers, so at this point I'd say it's pretty much a crap shoot. The kernel part of the driver is probably easier to install from the nvidia uber package, but the glx part should install fine from apt-get. confused enough yet? what the person here did was use the nvidia installer, it compiled the kernel module and installed glx, but he had problems with glx, so then he installed the nvidia-glx from apt-get this requires the nvidia-kernel-src package and installs it along with the glx stuff, but does not actually compile or install the nvidia-kernel. there's more work to do that, and in my experience it's a royal pain. I've always just gone back to the nvidia packages. I had no problems using the nvidia installer on my debian sid workstation, including glx, however like I said I have not been able to get glx to work with knoppmyth period, however I am using an older kernel from R4V3.

Author:  ceenvee703 [ Sun Jul 11, 2004 1:29 pm ]
Post subject: 

Xsecrets wrote:
what the person here did was use the nvidia installer, it compiled the kernel module and installed glx, but he had problems with glx, so then he installed the nvidia-glx from apt-get this requires the nvidia-kernel-src package and installs it along with the glx stuff, but does not actually compile or install the nvidia-kernel.

I can confirm that this seems to work. At least it doesn't require glx to be commented out in order to get X up and running.

So, again, the steps for the total newbie like me are:

1. get out of X by doing ctl-alt-F1 and su to root.

2. I also seem to have had to shut down Gnome display manager with
/etc/init.d/gdm stop


and go through all the dialog boxes


apt-get update

apt-get install nvidia-glx

7. reboot (I'm sure there's a way to fire up X again but I didn't know what it was)

Author:  tanzania [ Sun Jul 11, 2004 2:34 pm ]
Post subject: 

exactly. That did the trick for me. i=m sure glx is working:

1. i dont need to uncomment glx anymore
2. opengl visualisat5ions in mythmusic and opengl fades in mythgallery work again

Author:  Xsecrets [ Sun Jul 11, 2004 3:07 pm ]
Post subject: 

ok well then more than likely the R4V4 has newer X than R4V3 or something else, because there is no way that I have found (haven't really killed myself trying) to get glx to work in R4V3.

Author:  ceenvee703 [ Sun Jul 11, 2004 3:30 pm ]
Post subject: 

Good point, should have clarified I'm using R4V4.1.

I did have a visualization freeze up on me in MythMusic, but I was running 1080i at that point. :)

Author:  Headbonk [ Sun Jul 11, 2004 9:24 pm ]
Post subject: 

Ok - you guys rock! 8)

I'm no longer confused about this. I am still a little bit scared of trying this though. :shock: Now that I know what's going on, it sounds pretty twisted.

That's what backups are for though right?

Thanks guys! :D

Author:  wififun [ Mon Jul 12, 2004 12:24 am ]
Post subject: 

well ceenvee703's glx trick worked for me, but here is an odd problem I am hoping someone can help with.

the built in svideo on the nforce2 based k7n2gm-l is ok. However, the svideo out on my ti4200 is a night and day difference in quality. I am talking a BIG improvement. Using the XF86Config-4.nvidia-tvout.sample as my XF86Config-4 has worked perfect using the mobo's built in svideo while using any of the following:
Option  "TVStandard" "NTSC-M"
Option  "TVStandard" "HD480i"
Option  "TVStandard" "HD480p"

With the 4200 there is an overscan problem with the new drivers that causes overscan to be to much. There is no difference at all between:
Option  "TVOverScan" "0.1" and Option  "TVOverScan" "0.9"

With overscan off, it is most defanatly off and is to small. With it on, no matter what it is set at, it is to much by exactly the same amount. Odd.. I have played around with MythTV's over and underscan settings to find a balance, but I am hoping to just get the 4200 and the config file straightened out.

Now the bigger issue is that with the 4200 HD480i or HD480p just create a flashing white screen from the svideo. The same XF86Config-4 file as the 4MX based gpu on the mobo, but nothing but flashing white. I have poured over modelines, but can't see anything that would be doing this. I really liked what the HD480x TVStandards did, but I would love to get these working with the 4200's great picture quality.

NOTES: I have tried with a fresh install with xvmc on and off, same thing. I am outputting to a SD sony tv via svideo.

Author:  tjc [ Sun Aug 01, 2004 9:14 pm ]
Post subject: 

Aha!!! I've found the root of the GLX problem, and how to fix it without installing the new DEBs. A search of the nV News Forums turned up this thread:

Apparently there are two versions of, one of which is bogus or broken. My version of the magic fix (scroll way down to message #7 in the thread) went like this :

root@black:/var/log # cd /usr/lib/tls
root@black:/usr/lib/tls # rm
rm: remove symbolic link `'? y
root@black:/usr/lib/tls # ln -s /usr/lib/
root@black:/usr/lib/tls # ls -al
total 28
drwxr-xr-x    2 root     root         4096 Aug  1 22:57 .
drwxr-xr-x   82 root     root        20480 Jul  1 23:08 ..
lrwxrwxrwx    1 root     root           34 Aug  1 22:57 -> /usr/lib/
-rwxr-xr-x    1 root     root         2004 Jul  1 23:08
root@black:/usr/lib/tls # vi /etc/X11/XF86Config-4  # Uncomment the line that says - Load  "glx"
root@black:/usr/lib/tls # /etc/init.d/gdm restart
Stopping GNOME Display Manager: gdm.
Starting GNOME Display Manager: gdm.

Works for me so far!

(Edited to correct a typo. BTW - it's still working! ;-) )

Author:  khrusher [ Mon Aug 02, 2004 7:05 am ]
Post subject: 

two quick questions:

1) is it worth moving to these drivers if im currently using VGA out and not the TV-out?

2) tjc, do you now believe that the steps outlined by ceenvee703 will wirk on my R4V3 box.

3) should I wait for R5 or the need to TV out for the move?


Author:  Xsecrets [ Mon Aug 02, 2004 7:27 am ]
Post subject: 

If you are not using xvmc and seeing interlace problems I would not worry about switching to these drivers.

Author:  tjc [ Mon Aug 02, 2004 1:17 pm ]
Post subject: 

khrusher wrote:
2) tjc, do you now believe that the steps outlined by ceenvee703 will wirk on my R4V3 box.

I didn't use that method and can't comment on it. Instead, I ran the NVidia install script and then made the manual fix shown.

Page 3 of 6 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group