View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 3 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sun Dec 19, 2004 3:18 pm 
Offline
Joined: Fri Apr 02, 2004 10:08 am
Posts: 1637
Location: Virginia, USA
Short version: how can I get xmodmap to run when X starts up? I put the following line at the end of my ~/.fvwm/.fvwm2rc file

Code:
exec xmodmap /home/mythtv/.xmodmaprc


but it doesn't seem to work. If I do the line by hand via an xterm window, it does work.

Background: I'm doing this to try to map some of the ATI Remote Wonder keys that don't do anything by defualt to send keystrokes to MythTV. I found the keys being sent with xev, made a list and put it in .xmodmaprc (because I thought it would auto-load that way). As I said above, if I run the line manually, it works fine. I'd like to get it to run when I start up my machine.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jan 26, 2005 6:00 pm 
Offline
Joined: Tue Nov 16, 2004 5:05 am
Posts: 39
I'm not at my mythbox, so I hope the syntax is correct. I'm assuming you're using KnoppMyth

In KnoppMyth-run which is in /usr/local/bin (I think)

there is a line that says something like like

exec mythfrontend;

replace it with

exec xmodmap modmapfile | exec mythfrontend;

worked for me.

Simon


Top
 Profile  
 
 Post subject: xmodmaps
PostPosted: Tue Nov 22, 2005 12:17 am 
Offline
Joined: Sat Nov 05, 2005 11:28 am
Posts: 2
I wrote a little script to use different xmodmaps with my ATI remote depending on whether I am watching recordings, watching DVD's or videos, or running xmame or another program. In case it might help you, the thread is here.

To get my MythTV key mappings to load when MythTV first starts from a reboot, I modiified the file /home/mythtv/.fluxbox/apps to look like this:
Code:
[startup] {xset -dpms s off}
[startup] {xmodmap /home/mythtv/.Xmodmap_ati_mythtv}
[startup] {KnoppMyth-run}
[app] (SDL_App)
  [Layer]       {2}
  [Deco]        {NONE}
[end]


I also modified the menu to launch MythTV with different key mappings depending on whether I wanted to use a keyboard or the ATI remote by adding to /home/mythtv/.fluxbox/menu:
Code:
[submenu] (MythTV) {}
      [exec] (MythTV) {/usr/bin/mythfrontend}
      [exec] (MythTV - ATI Remote) {/home/mythtv/bin/myth_ati_remote}
      [exec] (MythTV - No ATI Remote) {/home/mythtv/bin/myth_noati_remote}
   [end]
   [submenu] (XModmaps) {}
      [exec] (MythTV - ATI Remote) {xmodmap /home/mythtv/.Xmodmap_ati_mythtv}
      [exec] (Normal Keybindings) {xmodmap /home/mythtv/.Xmodmap_normal}
   [end]

where /home/mythtv/bin/myth_ati_remote looks like:
Code:
#!/bin/bash
xmodmap /home/mythtv/.Xmodmap_ati_mythtv
/usr/bin/mythfrontend

and /home/mythtv/bin/myth_noati_remote looks like:
Code:
#!/bin/bash
xmodmap /home/mythtv/.Xmodmap_normal
/usr/bin/mythfrontend


The (normal) key mappings were set by restarting the X server without loading any other xmodmap files and capturing the default settings with:
Code:
xmodmap -pke > /home/mythtv/.Xmodmap_normal


The key mappings in /home/mythtv/.Xmodmap_ati_mythtv should be set to things that make sense to you.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu