View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 7 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sat Sep 12, 2009 11:44 am 
Offline
Joined: Mon Nov 28, 2005 9:05 pm
Posts: 200
OK, I know SVN isnt officailly supported but I'm kinda at a loss here. I've been running LinHES with Mythtv-SVN for months with no issues (beyond a hint of SVN bugginess here and there). Last week I was out of town and executed a Pacman -Syu remotely on my MBE/FE. I upgraded some pacakages and it jacked up my network connections until I was able to get back from out of town and fix that (same ole /etc/net/ifaces/eth0/ipv4address issue).

Since then, mythfront end will not come up, I get the output below, mythfrontend runs, but never displays on my screen. I can run mythtv-setup and that displays fine. Mytfrontend will not run on any of my SFE's either, I get essentially the same message as below. I've ripped out all of SVN and reinstalled it, rebooted, no avail. This version of SVN was working fine for a week before I left.

Google has been little help. At this point what changed was my Pacman -Syu. I have posted my Pacman Log at the end of this as well.



[mythtv@mythtv ~]$ mythfrontend
Xlib: extension "Generic Event Extension" missing on display ":0.0".
Xlib: extension "Generic Event Extension" missing on display ":0.0".
Xlib: extension "Generic Event Extension" missing on display ":0.0".
2009-09-12 13:34:08.871 mythfrontend version: trunk [21495] www.mythtv.org
2009-09-12 13:34:08.922 Using runtime prefix = /usr
2009-09-12 13:34:09.662 Empty LocalHostName.
2009-09-12 13:34:09.662 Using localhost value of mythtv
2009-09-12 13:34:09.666 New DB connection, total: 1
2009-09-12 13:34:09.685 Connected to database 'mythconverg' at host: localhost
2009-09-12 13:34:09.685 Closing DB connection named 'DBManager0'
Xlib: extension "Generic Event Extension" missing on display ":0.0".
2009-09-12 13:34:09.726 DPMS is disabled.
Xlib: extension "Generic Event Extension" missing on display ":0.0".
Xlib: extension "Generic Event Extension" missing on display ":0.0".
2009-09-12 13:34:09.728 Primary screen: 0.
2009-09-12 13:34:09.751 Connected to database 'mythconverg' at host: localhost
2009-09-12 13:34:09.755 Using screen 0, 1920x1080 at 0,0
2009-09-12 13:34:09.800 MythUI Image Cache size set to 20971520 bytes
2009-09-12 13:34:09.810 Enabled verbose msgs: important general
2009-09-12 13:34:09.893 The theme (defaultmenu) is missing a themeinfo.xml file




*********** Pacman.log*********

[2009-09-08 16:46] synchronizing package lists
[2009-09-08 16:46] starting full system upgrade
[2009-09-08 16:47] upgraded mythweb-svn (21495-1 -> 21495-1)
[2009-09-08 16:52] synchronizing package lists
[2009-09-08 16:52] starting full system upgrade
[2009-09-08 16:52] synchronizing package lists
[2009-09-08 16:52] starting full system upgrade
[2009-09-08 16:53] upgraded mythinstall (1-9 -> 1-11)
[2009-09-08 16:53] upgraded python-netifaces (0.5-1 -> 0.5-2)
[2009-09-08 16:53] warning: directory permissions differ on usr/bin/
filesystem: 777 package: 755
[2009-09-08 16:53] mysql 4395 4394 0 Aug27 ? 00:31:54 /usr/sbin/mysqld --skip-name-resolve -u mysql
[2009-09-08 16:53] status 0
[2009-09-08 16:53] c load
[2009-09-08 16:53] 0
[2009-09-08 16:53] default_1
[2009-09-08 16:53] default_2
[2009-09-08 16:53] upgraded LinHES-config (2.0-89 -> 2.0-96)
[2009-09-08 16:53] warning: /etc/net/ifaces/eth0/options saved as /etc/net/ifaces/eth0/options.pacsave
[2009-09-08 16:53] upgraded etcnet (0.9.8-7 -> 0.9.8-13)
[2009-09-08 16:53] upgraded udev (135-6 -> 135-7)
[2009-09-08 16:53] warning: extracting /etc/rc.local as /etc/rc.local.pacnew
[2009-09-08 16:53] warning: extracting /etc/rc.conf as /etc/rc.conf.pacnew
[2009-09-08 16:53] upgraded initscripts (2009.01-7 -> 2009.01-9)
[2009-09-08 16:53] warning: directory permissions differ on usr/bin/
filesystem: 777 package: 755
[2009-09-08 16:53]
[2009-09-08 16:53] ==> Review your php.ini
[2009-09-08 16:53]
[2009-09-08 16:53] Your php installation has been updated. You should review your current
[2009-09-08 16:53] php.ini and check any upstream changes according to the default
[2009-09-08 16:53] configuration which can be found at php.ini.pacnew.
[2009-09-08 16:53]
[2009-09-08 16:53] upgraded php (5.2.6-20 -> 5.2.6-22)
[2009-09-08 16:53] upgraded local-website (2-13 -> 2-15)
[2009-09-08 16:53] warning: directory permissions differ on usr/bin/
filesystem: 777 package: 755
[2009-09-08 16:53] installed kakasi (2.3.4-2)
[2009-09-08 16:53] upgraded perl-text-kakasi (2.04-3 -> 2.04-4)
[2009-09-08 16:53] warning: directory permissions differ on usr/bin/
filesystem: 777 package: 755
[2009-09-08 16:53] upgraded xulrunner (1.9.1.1-2 -> 1.9.1.1-5)
[2009-09-11 13:32] synchronizing package lists
[2009-09-11 13:32] starting full system upgrade
[2009-09-11 13:33] warning: directory permissions differ on usr/bin/
filesystem: 777 package: 755
[2009-09-11 13:33] mysql 4339 4337 86 13:30 ? 00:02:37 /usr/sbin/mysqld --skip-name-resolve -u mysql
[2009-09-11 13:33] status 0
[2009-09-11 13:33] c load
[2009-09-11 13:33] 0
[2009-09-11 13:33] default_1
[2009-09-11 13:33] default_2
[2009-09-11 13:33] upgraded LinHES-config (2.0-96 -> 2.0-97)
[2009-09-11 13:33] upgraded runit-scripts (1.8.0-94 -> 1.8.0-95)
[2009-09-11 13:34] warning: directory permissions differ on usr/bin/
filesystem: 777 package: 755
[2009-09-11 13:34] upgraded mythtv-svn (21495-1 -> 21495-1)
[2009-09-11 22:52] synchronizing package lists
[2009-09-11 22:52] starting full system upgrade
[2009-09-11 22:58] upgraded myththemes-svn (21495-1 -> 21495-1)
[2009-09-11 23:39] installed phpmyadmin (2.9.1.1-35)
[2009-09-12 13:12] synchronizing package lists
[2009-09-12 13:12] starting full system upgrade
[2009-09-12 13:14] starting full system upgrade
[2009-09-12 13:14] warning: directory permissions differ on usr/bin/
filesystem: 777 package: 755
[2009-09-12 13:14] mysql 4365 4324 99 Sep11 ? 14:20:24 /usr/sbin/mysqld --skip-name-resolve -u mysql
[2009-09-12 13:14] status 0
[2009-09-12 13:14] c load
[2009-09-12 13:14] 0
[2009-09-12 13:14] default_1
[2009-09-12 13:14] default_2
[2009-09-12 13:14] upgraded LinHES-config (2.0-97 -> 2.0-96)
[2009-09-12 13:15] synchronizing package lists
[2009-09-12 13:15] starting full system upgrade
[2009-09-12 13:15] synchronizing package lists
[2009-09-12 13:15] starting full system upgrade
[2009-09-12 13:15] warning: directory permissions differ on usr/bin/
filesystem: 777 package: 755
[2009-09-12 13:15] mysql 4365 4324 99 Sep11 ? 14:21:25 /usr/sbin/mysqld --skip-name-resolve -u mysql
[2009-09-12 13:15] status 0
[2009-09-12 13:15] c load
[2009-09-12 13:15] 0
[2009-09-12 13:15] default_1
[2009-09-12 13:15] default_2
[2009-09-12 13:15] upgraded LinHES-config (2.0-96 -> 2.0-97)
[2009-09-12 13:28] removed morethemes-svn (21495-1)
[2009-09-12 13:28] removed mytharchive-svn (21495-1)
[2009-09-12 13:28] removed mythbrowser-svn (21495-1)
[2009-09-12 13:28] removed mythflix-svn (21495-1)
[2009-09-12 13:28] removed mythgallery-svn (21495-1)
[2009-09-12 13:28] removed mythgame-svn (21495-1)
[2009-09-12 13:28] removed mythmovies-svn (21495-1)
[2009-09-12 13:28] removed mythmusic-svn (21495-1)
[2009-09-12 13:28] removed mythnews-svn (21495-1)
[2009-09-12 13:28] removed myththemes-svn (21495-1)
[2009-09-12 13:28] removed mythvideo-svn (21495-1)
[2009-09-12 13:28] removed mythweather-svn (21495-1)
[2009-09-12 13:28] removed mythweb-svn (21495-1)
[2009-09-12 13:30] removed mythtv-svn (21495-1)
[2009-09-12 13:30] warning: directory permissions differ on usr/bin/
filesystem: 777 package: 755
[2009-09-12 13:30] installed mythtv-svn (21495-1)
[2009-09-12 13:30] You must create a symlink from /home/httpd/html/mythweb/video_dir
[2009-09-12 13:30] to your MythTV recordings directory. Don't forget to change the
[2009-09-12 13:30] permissions so that the webserver can read those files and create
[2009-09-12 13:30] thumbnails.
[2009-09-12 13:30] installed mythweb-svn (21495-1)
[2009-09-12 13:30] installed mythweather-svn (21495-1)
[2009-09-12 13:30] warning: directory permissions differ on usr/bin/
filesystem: 777 package: 755
[2009-09-12 13:30] installed mythvideo-svn (21495-1)
[2009-09-12 13:30] installed myththemes-svn (21495-1)
[2009-09-12 13:30] installed mythnews-svn (21495-1)
[2009-09-12 13:30] installed mythmusic-svn (21495-1)
[2009-09-12 13:30] warning: directory permissions differ on usr/bin/
filesystem: 777 package: 755
[2009-09-12 13:30] installed mythmovies-svn (21495-1)
[2009-09-12 13:30] installed mythgallery-svn (21495-1)
[2009-09-12 13:30] installed mythflix-svn (21495-1)
[2009-09-12 13:30] installed mythbrowser-svn (21495-1)
[2009-09-12 13:30] warning: directory permissions differ on usr/bin/
filesystem: 777 package: 755
[2009-09-12 13:30] installed mytharchive-svn (21495-1)
[2009-09-12 13:30] installed morethemes-svn (21495-1)
[root@mythtv log]#

_________________
Knoppmyth 7.02 Kernel 2.6.39-LINHES
[MBE] SilverStone LC-10 HTPC Case, Asus M2NPV-VM, AMD X2 4200+, 1G RAM, Nvidia 9500 PCIe, PVR500 and a HD-PVR - Rockin VDPAU


Last edited by ethernut on Mon Sep 14, 2009 7:03 pm, edited 2 times in total.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Sep 13, 2009 5:10 pm 
Offline
Joined: Mon Nov 28, 2005 9:05 pm
Posts: 200
Well, I finally hit on something. I noticed that mysqld was running at 99-100% cpu. I killed the process (ofcourse runsv restarted it) and mythfrontend started right up. I would have noticed it sooner but, there was zero disk activity from anything. Just a pissed off mysqld.

Mythfrontends are all working now. Guess I have to kill mysqld after reboot for now.. ugh..

Ether..

_________________
Knoppmyth 7.02 Kernel 2.6.39-LINHES
[MBE] SilverStone LC-10 HTPC Case, Asus M2NPV-VM, AMD X2 4200+, 1G RAM, Nvidia 9500 PCIe, PVR500 and a HD-PVR - Rockin VDPAU


Top
 Profile  
 
 Post subject:
PostPosted: Sun Sep 13, 2009 5:22 pm 
Offline
Joined: Mon Nov 28, 2005 9:05 pm
Posts: 200
I appears my database is hosed pretty bad..

I've exported my tables to a .sql flat file, and would like to refresh the database to with a clean one.

Any help?

_________________
Knoppmyth 7.02 Kernel 2.6.39-LINHES
[MBE] SilverStone LC-10 HTPC Case, Asus M2NPV-VM, AMD X2 4200+, 1G RAM, Nvidia 9500 PCIe, PVR500 and a HD-PVR - Rockin VDPAU


Top
 Profile  
 
 Post subject:
PostPosted: Mon Sep 14, 2009 12:37 am 
Offline
Joined: Tue Feb 03, 2004 3:23 am
Posts: 159
Location: Friesland, The Netherlands
Here's instructions for preparing MySQL for use with MythTV:

http://www.mythtv.org/docs/mythtv-HOWTO-6.html#ss6.2

the mc.sql file comes with the sources of MythTV. If you don't have those at hand then you can also get it here:

http://svn.mythtv.org/trac/browser/tags ... ase/mc.sql


Top
 Profile  
 
 Post subject:
PostPosted: Mon Sep 14, 2009 7:06 pm 
Offline
Joined: Mon Nov 28, 2005 9:05 pm
Posts: 200
I added the phpMyAdmin packaged and used the database repair function, which seems to have lined my issues out for now, at least, on the surface anyway.

I used the following process..

Go to http://yourmythtv/phpMyAdmin, select mythconverg from the dropdown list in the left hand pane window under databases. Scroll down and use the "select all" to add a check mark in all the database boxes. From the drop down box, then select "repair table", once that has completed go back into the drop down box and select "optimize tables." The repair tables program may take a few moments to complete so give it some time. Once it has completed, you should be able to scroll the database to see the results - it should have an ok after each database (you may have to arrow right to see them.

Ether

_________________
Knoppmyth 7.02 Kernel 2.6.39-LINHES
[MBE] SilverStone LC-10 HTPC Case, Asus M2NPV-VM, AMD X2 4200+, 1G RAM, Nvidia 9500 PCIe, PVR500 and a HD-PVR - Rockin VDPAU


Top
 Profile  
 
 Post subject:
PostPosted: Mon Sep 14, 2009 8:38 pm 
Offline
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
The optimize_db.sh script is also still available out of the box and updated to work with R6.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jan 08, 2010 5:30 pm 
Offline
Joined: Sun Jan 01, 2006 3:26 pm
Posts: 46
Location: Raleigh, NC
I had to use Ethernut's method to fix a db problem I was experiencing. The optimize script couldn't fix it. I'm not a db expert so I have no clue why the script could not fix the issue. After the phpMyAdmin initiated repair, starting the backend worked fine and running the optimize script now completes w/o errors.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu