View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 3 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Tue Jan 05, 2010 10:16 pm 
Offline
Joined: Sun Feb 26, 2006 11:34 pm
Posts: 83
Location: Toronto, ON, Canada
Hi

I have 3 machines and none seem to be working right since running the update on Jan 03, 10. The symptoms are slightly different for each:

All are running LinHES R6. The FE machines were loaded with R6 several months ago, while the MBE was only upgraded from 5.5 in mid December.

The FE1 machine worked fine after the upgrade to .22 that came in mid-Dec. After upgrading on the 3rd, mythfrontend would start, but no text would show on the screen. I could get an XTerm session using ctrl+x, restart X with ctrl+alt+Backspace, but nothing would get the mythfrontend working.

The FE2 machine began having problems immediately upon upgrading to .22. Specifically, it would completely freeze up when trying to exit live or recorded programmes. When I say freeze, I mean the entire machine would become unresponsive, and even SSH sessions would become unresponsive, and only a hard boot would get us back to the main screen.

On the backend I can't seem to get the text to show up since upgrading to .22. The symptoms are very similar to FE1: mythfrontend is running but does not actually do anything.

Given the problems I was having with the FEs after the Jan 03 update I decided to hold off on the MBE

Diskless FE1: VIA EPIA M10000, 512MB RAM
Diskless FE2: Jetway VIA C7 2.0G CX700M HDMI J7F5M2G-VHE 1GB RAM

Backend: 3GHz P4, 512MB, 1.740TB LVM
2 PVR-500, 1 HDHomerun
ASUS P4800-VM Motherboard using Intel on-board video to supply monitor that is rarely used as a FE.

I have rolled back the two FE machines using the following:

Code:
cd /data/var/cache/pacman/pkg/ && pacman -U tablet-encode-2.30-1-i686.pkg.tar.gz && pacman -U mythmovies-0.22-22000-i686.pkg.tar.gz && pacman -U mythweather-0.22-22000-i686.pkg.tar.gz && pacman -U mythvideo-0.22-22000-i686.pkg.tar.gz && pacman -U myththemes-0.22-22000-i686.pkg.tar.gz && pacman -U mythnews-0.22-22000-i686.pkg.tar.gz && pacman -U mythmusic-0.22-22000-i686.pkg.tar.gz && pacman -U mythgallery-0.22-22000-i686.pkg.tar.gz && pacman -U mythgame-0.22-22000-i686.pkg.tar.gz && pacman -U mythbrowser-0.22-22000-i686.pkg.tar.gz && pacman -U mythflix-0.22-22000-i686.pkg.tar.gz && pacman -U mytharchive-0.22-22000-i686.pkg.tar.gz && pacman -U morethemes-0.22-22000-i686.pkg.tar.gz && pacman -U mythtv-0.22-22000-i686.pkg.tar.gz &&


Nothing has changed.

BTW, I have checked Flyspray, and there's nothing newly reported since mid-Dec that approximates these problems.

Anyone have any thoughts?

Thanks
Victor

_________________
Backend: Core 2-Quad CPU, 4GB RAM, 3TB
2 PVR-500, 1 HDHomerun
FE1: Zotac IONITX-B-E, w/2GB HD
FE2: Zotac MAG


Top
 Profile  
 
PostPosted: Wed Jan 06, 2010 3:38 pm 
Offline
Joined: Sun Sep 25, 2005 3:50 pm
Posts: 1013
Location: Los Angeles
vabiro wrote:
The FE1 machine worked fine after the upgrade to .22 that came in mid-Dec. After upgrading on the 3rd, mythfrontend would start, but no text would show on the screen. I could get an XTerm session using ctrl+x, restart X with ctrl+alt+Backspace, but nothing would get the mythfrontend working.


Since you do not explicitly state it, I'm going to ask... After opening an xterm, did you try:

Code:
$ mythfrontend


It should give you a clue on stdout as to what's hanging it up.

vabiro wrote:
On the backend I can't seem to get the text to show up since upgrading to .22. The symptoms are very similar to FE1: mythfrontend is running but does not actually do anything.


What theme are you using?

_________________
Mike
My Hardware Profile


Top
 Profile  
 
PostPosted: Thu Jan 07, 2010 9:47 am 
Offline
Joined: Sun Feb 26, 2006 11:34 pm
Posts: 83
Location: Toronto, ON, Canada
Thanks for your reply.

mihanson wrote:

Since you do not explicitly state it, I'm going to ask... After opening an xterm, did you try:

Code:
$ mythfrontend


It should give you a clue on stdout as to what's hanging it up.


Yup. One of the first things that I did, but before we go too far down that path, I think I may have resolved the problem on FE1 and the MBE:

I deleted the files in ~/.mythtv/themecache in hopes that Mythtv was having problems transitioning between the two versions of .22, and that seems to have done the trick. Maybe changes in MythUI?

The only residual problem is very slow navigation when using the guide.

One thing I haven't tried is reapplying the Jan 03 update and deleting the theme cache. I was going to try that before posting my results here.

BTW, I am using Mythbutu theme on both the FE machines, and Mythcenter on the MBE.


mihanson wrote:
vabiro wrote:
On the backend I can't seem to get the text to show up since upgrading to .22. The symptoms are very similar to FE1: mythfrontend is running but does not actually do anything.


What theme are you using?


The remaining issue is that the FE2 machine's mythfrontend seems to still stop responding when exiting watching TV or recordings. Since downgrading I can now use ctrl+alt+backspace to restart X, where as the machine completely locked up before rolling back the update.

This only seems to occur in the TV and Rec of MPEG2 files. Playing files in the Video section (mostly .avi files) works fine.

I suspect something is happening when the mythtv internal player is exiting and that is causing the crash of mythfrontend.

Thanks again for your reply.

Victor

_________________
Backend: Core 2-Quad CPU, 4GB RAM, 3TB
2 PVR-500, 1 HDHomerun
FE1: Zotac IONITX-B-E, w/2GB HD
FE2: Zotac MAG


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu