View unanswered posts    View active topics

All times are UTC - 6 hours





Post new topic Reply to topic  [ 1 post ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Sun Aug 05, 2018 12:33 pm 
Offline
Joined: Wed Dec 10, 2003 8:31 pm
Posts: 1996
Location: /dev/null
Firstly, I am not running LH, just a plain Arch Linux box. My goal is to use an old PVR-250 card and an old VCR to digitize some very old VHS content as I did when I was running LH. I'd like to do it using my existing Arch install, but if the hardware is supported under LH, I can probably scare up an old HDD and put LH on it.

What I did on Arch: installed v4l-utils and, from the AUR, ivtv-utils (which seems to supply the needed firmware) but the kernel seems unable to initialize the card:

Code:
# dmesg | grep -i 'video\|ivtv'
[    0.234056] ACPI: Added _OSI(Linux-Dell-Video)
[    0.288644] pci 0000:00:02.0: Video device with shadowed ROM at [mem 0x000c0000-0x000dffff]
[    2.430862] Linux video capture interface: v2.00
[    2.465557] ivtv: Start initialization, version 1.4.3
[    2.465588] ivtv0: Initializing card 0
[    2.465590] ivtv0: Autodetected Hauppauge card (cx23416 based)
[    2.465877] ivtv0: Cannot request encoder memory region.
[    2.465914] ivtv0: Error -5 on initialization
[    2.465935] ivtv: probe of 0000:06:00.0 failed with error -5
[    2.465948] ivtv: End initialization
[    2.720489] ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)
[    2.720597] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input5


Unsurprising given the age of the hardware, googling on the errors gave outdated advice. Does anyone have some expertise with this type of hardware?

In the past, when I had this working under LH, I could simply have an old VCR hooked up via coax cable, and could digitize the content like this:
Code:
% v4l2-ctl --set-input=5
% cat /dev/video0 >capture.mpg


Since the hardware is not initialized, it's no surprise that a simple query errors out:
Code:
# v4l2-ctl --all
Failed to open /dev/video0: No such file or directory

_________________
Retired KM user (R4 - R6.04); friend to LH users.


Top
 Profile  
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 


All times are UTC - 6 hours




Who is online

Users browsing this forum: Google [Bot] and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu