View unanswered posts    View active topics

All times are UTC - 6 hours

Post new topic Reply to topic  [ 5 posts ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Mon Oct 23, 2006 12:50 pm 
Joined: Tue Jan 03, 2006 3:15 pm
Posts: 9
I'd just like to thank tjc and zaroff1967 for posting info on getting R5D1 to work with my 350 card. I did what tjc said and went to the knoppmythwikki and followed the instructions on upgrading the ivtv driver to 0.7.1 (note: only did the first paragraph in step 3) and then did what zaroff1967 said about adding the local file and editing the XF86Config-4 file (set mine to fb0 cause i didn't use boot splash). I also took out my nvidia card and am just using the crappy onboard video to do the inital setup. I couldn't do that on some previous versions. Must've missed that somewhere. I can even get a frontend to work right off the cd now! Works beautifully! Thanks to everyone.
Ron :D

tjc wrote:
Don't Panic! :-) The Hitchhiker's Guide to Upgrading to KnoppMyth R5D1

This is a very long post which covers everything from pre through post install issues and fixups. Do not let this frighten you off. It's long because I tried to write it at a "drunken monkey" level of detail, with the intent that you can cut & paste the example commands shown directly from this posting into a shell window on your KnoppMyth box. Please scroll down and look at the bold headings to get a feel for what it covers... If you're looking for something specific (say "XF86Config-4") please use your browsers page search feature.

Also note that this posting is intended to be a supplement to Cecil's freshly updated Pamphlet and change list rather than a replacement. As a result it tends to skip issues they cover, so don't forget to review those before you start upgrading.


OBTW - A note on the color coding used below, red is used for file system objects (files, directories, ...), green is used for sample commands (partial or complete).

Phase 0 - BEFORE you upgrade:

    - Make sure you have a good back up using the standard script - /usr/local/bin/mythbackup

    - Check that the backup worked!!!
      - Upgrading from R5C7

      Use the script which can be found either in this thread or as an attachment on the MythBackupAndRestoreHowTo page on the wiki.

      - Upgrading from pre-R5C7
      cd /myth/backup
      ls -al
      for i in etc.tar.gz home.tar.gz root.tgz ; do tar ztvf $i ; done

      Don't forget to look at the SQL dump file to make sure it's not empty or very small.

      - Manually back up all of /etc /root and /home. (The standard backup in R5C7 does this for you already. You only need to do this when upgrading from R5B7 or before) - As root:
      cd /
      tar jcvf /myth/backup/savedfiles.tar.bz2 ./etc ./root ./home

      If this file exists the new restore script will use it by preference. If it doesn't exist many of the tips provided below won't work. After doing this you can also use the script described above.
    See this posting for more details on backup and restore.

    - Make a list of any add ons you've installed or extra configuration you've done while you've still got the old install to refer to.

    - Make a note of your current hostname.

Phase 1 - When you boot from the CD:

    - Use the testcd option in your boot command. If the validation fails do not continue the upgrade! For example:
    tv testcd

    - If the installer hangs probing for SCSI devices boot using the "expert" or "noscsi" options. Note that expert needs to be the first thing in the boot command list. For example:
    tv noscsi testcd


    expert tv testcd

    - Do not change your hostname during the upgrade! Look at the notes you made before the upgrade and use the same hostname. Changing the hostname will cause a number of annoying problems with various tables in the DB, particularly the settings table, which uses the hostname as one of the keys. Changing the hostname is a project beyond the scope of these hints.

    - Do not create a user named mythtv. This is already done automatically.

Phase 2 - After the install from the CD and reboot

Before entering the root password to start the setup dialogs:

NB - To do any of these tasks you'll need to switch to an alternate virtual console using Ctrl-Alt-F1 and login as root.

    - If you're using LVM with the standard volume group name of "vg" use the script to restore it. Otherwise you'll need to edit the script to use the "right" volume group name for you system.

    - If you have some other nonstandard disk arrangement you may need to correct your /etc/fstab and mount the updated partitions. Especially /myth!

    - If X isn't working out of the box, recover your old working XF86Config-4.
    cd /
    mv /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.orig.R5D1
    tar jxvf /myth/backup/savedfiles.tar.bz2 ./etc/X11/XF86Config-4
    /etc/init.d/gdm restart

    - Do any other fixups that you need to complete before the 2nd phase setup dialogs run.

Setup dialogs:
    - Make sure you get the timezone right. This is easy to screw up and will lead to really annoying problems with your program guide at the very least.

    - If you already have a working lirc configuration in your (new style) backup, you can reply "q" to the first question in the script, which will skip reconfiguration and use your existing lirc files. This preserves any customizations you have done.

    - Make a note of the passwords you use.

Phase 3 - post-install setup:

    - If you have a PVR card you must drop all of your card definitions and recreate them! See the CompileIvtv page on the wiki for the last four steps to be done after upgrading the ivtv driver for details. This is necessary because R5D1 includes a new version (0.7.0) of the ivtv driver which changes the input names and numbering yet again. If you do not do this, you will see all sorts of bizarre and mysterious errors.

    - Redo any add ons or extra configuration that you noted earlier. (Check first to make sure that it hasn't already been added as a new standard feature.) For example:

      1) Restoring your NFS setup

      cd /
      mv /etc/exports /etc/exports.orig.R5D1
      tar jxvf /myth/backup/savedfiles.tar.bz2 ./etc/exports
      /etc/init.d/nfs-common start
      /etc/init.d/nfs-kernel-server start
      update-rc.d nfs-common defaults
      update-rc.d nfs-kernel-server defaults

      2) Restoring your webmin setup
      cd /
      mv /etc/webmin/miniserv.conf /etc/webmin/miniserv.conf.orig.R5D1
      tar jxvf /myth/backup/savedfiles.tar.bz2 ./etc/webmin/miniserv.conf
      /usr/share/webmin/ /etc/webmin root YOURPASSWORDHERE
      /etc/init.d/webmin start
      update-rc.d webmin defaults

    - Be very careful about doing apt-get install to add extra packages. The /etc/apt/sources.list has been updated to point to the stable repository but you still need to use common sense.

      1. Don't ever use the -y option.
      2. Always review the list of packages it wants to add or remove.
      3. If in doubt say "no".

Possible issues:

    - The ivtv 0.7.0 drivers apparently don't like certain PVR-150 and PVR-250 cards with the TCL M2523_*_E tuner chips. This appears to be a deficiency in the v4l tveeprom.c in the 2.6.17 kernel. Some people have reported success using the module options to force the tuner type. To do this put
    options ivtv tuner=50

    in /etc/modprobe.conf for the M2523_5N_E, for the M2523_3DB_E use type 55. As of 2006.09.25 the new 0.7.1 version of the ivtv drivers is available which is supoosd to help with this. There are notes on the CompileIvtv page on the wiki for upgrading to use it.

    - The mpeg2 -> mpeg2 lossless transcoding does not appear to be working. This seems to be because of some patch on the MythTV 0.19.1 branch (R5D1 uses release-0-19-fixes @ change set 10505). This was fixed in a later SVN (10979), and the fix is still good in MythTV 0.20. Cecil has posted .debs which can be used to upgrade R5D1 to 0.20+fixes.

    - Software suspend still has some issues with certain things that don't want to restart. If you use it, keep an eye out for these.

    - Some people have reported issues playing streaming video with mplayer. This appears to be because Cecil has taken a more conservative approach on codecs with this release. Search for the various mplayer "how to" postings for fixes.

    - Sound issues. Lots of reports but I haven't really been able to pin down a main cause. Some of it is apparently just misconfiguration by users or changes to the default alsa config. There may also be a kernel issue, possibly with the DVB HDTV drivers...

    - No TV output after reboot with PVR-350 cards. Success stories are starting to appear. The fix seems to be a combination of upgrading to the 0.7.1 ivtv drivers and diddling the startup order. See the last couple pages in this thread for more details -

zaroff1967 wrote:
Good news, everyone! I've solved my problem and got tv-out on the 350 working in R5D1. Here's how:

root@mythtv:~# nano /etc/init.d/local

This file should look like:
#! /bin/sh

modprobe ivtv-fb


root@mythtv:~# chmod +x /etc/init.d/local
root@mythtv:~# update-rc.d local start 95 2 3 4 5 .

Finally, the crucial part was in XF86Config-4:
Section "Device"
        Identifier      "Hauppauge PVR 350 iTVC15 Framebuffer"
        Driver          "ivtvdev"

        ### change fb0 to whatever number you got in the previous section
        Option          "fbdev" "/dev/fb1"
        Option          "ivtv" "/dev/fb1"
        Option          "VideoOverlay" "on"
        Option          "XVideo" "1"

        ### change the busid to whatever is reported by lspci. Note that
        ### output of lspci is hex, so add a preceding "0x" to the BusID
        BusID "PCI:0:20:0"

        Screen          0

Restart X and all should be well.

The fbdev line turned out to be the important part that was missing. I believe someone else got it working earlier by adding that line but for some reason it didn't work for me at the time. The 'local' startup script is a bit of a cheat to get the ivtv-fb module loaded but I couldn't find another way to get it to load correctly. My system has bootsplash enabled which is why I'm using 'fb1' above. If you don't have bootsplash then you should use 'fb0'.

My system will now bootup and the frontend will come up on the 350's tv-out without any sort of manual intervention just like it did in previous releases. I suspect the above steps may be the solution for others as well. Will some other people try this and post their results?

athalon 1.4ghz processor
biostar m7vig 400 mb
via km266 pro/vt8235 chip
pvr-350 tuner
nvidea video card tv out
256 megs ram

 Post subject:
PostPosted: Mon Oct 23, 2006 7:17 pm 
Joined: Thu Mar 25, 2004 11:00 am
Posts: 9551
Location: Arlington, MA
Could you fill in the template with the rest of your hardware details from the topic sticky posting?


 Post subject:
PostPosted: Mon Oct 23, 2006 9:47 pm 
Joined: Tue Jan 03, 2006 3:15 pm
Posts: 9
Sure, still learning how to use the forum. I did try to just upgrade from R5C7 but it went sour and tried to go back to it but with no success. I ended up using webmin to set up samba so I could log into the backend from my windows machine and copied about 140 gig worth of tv I wanted to same over to my windows box.
Ron Nelson

#Video type: SDTV
#Type of System: combined front and backend
#Noise Level: very quiet
#CASE: Aria cube case
#PSU: Antec Aria 300watt
#MOTHERBOARD: biostar m7vig 400mb
#CPU: athalon 1.4ghz processor
#RAM: 512mg ddr400
#CPU HEATSINK: Thermalflake Volcano 10 cpu cooler
# NORTHBRIDGE HEATSINK: whatever came on the motherboard
# CD/DVD-RW: Sony dvd rw+-
# HDD: western digital 200gig ultra ata
# GRAPHICS CARD: via on board video
# SOUNDCARD: onboard sound
# TUNER CARD: Hauppauge pvr-350
# REMOTE CONTROL: Logitech Harmony H659

 Post subject: R5D1 install gone sour
PostPosted: Mon Jan 01, 2007 11:36 pm 
Joined: Mon Jan 01, 2007 10:43 pm
Posts: 6
My box has both a PVR-350 and a PVR-150, which the R5D1 autoinstall seemed to detect. I'd like to use the tv-out on the 350. For some reason, however, X fails with

(II) IVTVDEV_TST: driver for framebuffer: PVR-350
(II) Primary Device is: PCI 00:01:0
(WW) ivtvdev: No matching Device section for instance (BusID PCI:1:10:0) found
(--) Chipset PVR-350 found
(EE) open /dev/fb0: No such device
(EE) Screen 0 deleted because of no matching confi section.
(EE) Device(s) detected, but non match those in the config file.

The 350 is at BusID PCI:1:9:0 and the 150 is at BusID PCI:1:10:0. The primary device above is the motherboard's i810 graphics.

Here's the XF86Config-4 device section:
Section "Device"
Identifier "Hauppauge PVR 350 iTVC15 Framebuffer"
Driver "ivtvdev"

### change fb1 to whatever number you got in the previous section
Option "fbdev" "/dev/fb0"
#Option "ivtvdev" "/dev/fb0"
Option "ivtv" "/dev/fb0"
Option "VideoOverlap" "on"
Option "XVideo" "1"
BusID "1:9:0"
Screen 0

I've tried option "ivtv" and "ivtvdev", and tried /dev/fb1, but I'm stumbling around in the dark here. Any suggestions?

PVR-350 + PVR-150
KnoppMyth R5F27
1.66 GHz Sempron, 1G RAM

 Post subject:
PostPosted: Thu Jan 11, 2007 7:00 pm 
Joined: Tue Jan 03, 2006 3:15 pm
Posts: 9
You need to upgrade to the latest version of ivtv that will work with your kernel.
Good luck.
Ron Nelson

athalon 1.4ghz processor
biostar m7vig 400 mb
via km266 pro/vt8235 chip
pvr-350 tuner
nvidea video card tv out
256 megs ram


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 6 hours

Who is online

Users browsing this forum: No registered users and 4 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu