LinHES Forums

R5D1 Sempron 3200+, Asus M2NPV-VM, GeForce 6150, PVR-500
Page 1 of 2

Author:  spideyk21 [ Fri Nov 03, 2006 9:17 am ]
Post subject:  R5D1 Sempron 3200+, Asus M2NPV-VM, GeForce 6150, PVR-500

Here is my Tier 2 System. I did have to patch the ivtv for the new PVR-500 tuner card. Other then that only some minor bumps. Set up only took about an hour and a half. Most of that was patching the ivtv settings. I am thinking of updating to .20 of mythtv but not totally decided on that just yet.

1. Video type: SDTV
2. Type of system: combined front- and back-end
3. Noise level: Let you know when everything is boxed up.

Case: Cool Master CM 260
PSU: Apevia ATX-CW500CP4
Motherboard: Asus M2NPV-VM
*Northbridge: NVIDIA GeForce 6150
*Southbridge: NVIDIA nForce 430
CPU: AMD Sempron 64 3200+ 2.0GHz
Ram: CORSAIR ValueSelect 512MB 240-Pin DDR2
CD/DVD: Spare
HDD: Seagate 200 GB IDE
Graphics Card: NVIDIA GeForce 6150 (Onboard)
Sound Card: ADI AD1986A, 6 channel (Onboard)
Tuner Card: Hauppauge 500
Remote Control: Not Set Up Yet

Outstanding Items:
-Had some problems with the IP setup. Determined it was the cable and reset the system to use DHCP and things worked out just fine. Now I just have to switch it over to a Static IP.

-My Channel Info is not showing up yet so I have to correct that problem. Looking into "mythfilldatabase" posts for solutions.

-Still have to solder together the remote IR receiver and mount it in the case. Project for this weekend.

-Set up Samba.

-Set up for remote access via Windows (or MAC) through either ssh or VNC.

-Order PCI riser card so I can put the case back together. Everything is just hanging out outside of the case right now.

-Test TV out to TV via Component out. Still running everything on a monitor until I get remote access set up.

More to come as things progress.

Author:  sherif [ Tue Nov 07, 2006 9:41 pm ]
Post subject: 

did you get the sound working on this board? I can't seem to get a peep out of this motherboard with R5D1.

Author:  turpie [ Wed Nov 08, 2006 12:30 am ]
Post subject: 

I also have this board. To get the sound working I had to upgrade alsa, as detailed here.

Also I have to reload the alsamixer settings on each boot in the fluxbox settings. (Sorry but I haven't got details of this fix handy at the moment.)[/url]

Author:  spideyk21 [ Wed Nov 08, 2006 11:30 am ]
Post subject: 

Also I have to reload the alsamixer settings on each boot in the fluxbox settings. (Sorry but I haven't got details of this fix handy at the moment.)

If you do find the details that would be great. I have upgraded ALSA and still no sound. Any help would be appreciated.

Thanks in advance

Author:  turpie [ Wed Nov 08, 2006 4:48 pm ]
Post subject: 

Have you tried setting the volumes in alsamixer?

Before I upgraded alsa I had tried the tips here, so maybe I needed to do both.
I created a file called /etc/modprobe.d/alsa-fix containing the line:
options snd-hda-intel position_fix=1 model=3stack

I also tried adding “noapic” to my lilo kernel options.

I don't if either of these two changes made a difference as I still didn't have it working properly until I upgraded alsa.

When I did get sound out I still needed to save the volume settings as they would keep getting reset to zero after each reboot. So after I got the volume levels correct in alsamixer I saved the settings with the command "alsactl store -f /home/mythtv/.alsasettings".
Then I added a line to /home/mythtv/.fluxbox/apps.
Below the line that says [startup] {} I added a line:
[startup] {alsactl restore -f /home/mythtv/.alsasettings }

Author:  spideyk21 [ Mon Nov 13, 2006 12:05 pm ]
Post subject: 

If possible could you post an image or the number values for your alsamixer profile?

My system records sound just fine from the cable system. Check it by pulling off a recording from my box and playing it threw mplayer on my macbook. But I am unable to get sound out of my speakers.

I will play with it some more this week.

Author:  turpie [ Thu Nov 16, 2006 9:41 pm ]
Post subject: 

I will try to remember to get the exact settings this weekend, but what I did was start playing a known-good recording then start alsamixer in a terminal, raise and unmute volumes until something started playing. From memory, only the first three seemed related to playback. If unmuting and raising the volume on one column doesn't work don't remute it as some of the channels feed into another channel, and require both channels to be working.

Author:  spideyk21 [ Mon Nov 20, 2006 10:02 am ]
Post subject: 

I was able to get my sound set up over the weekend. Not sure what exactly corrected the problem but here is what I did.

1. Updated ALSA and utilities to 1.0.13 (latest rev).
2. Created the file: /etc/modprobe.d/alsa-fix containing the line:
options snd-hda-intel position_fix=1 model=3stack

3. Played with the alsamixer setting (will post image later). Adjusted until all settings were at around 75-80.
4. Saved settings
alsactl store -f /home/mythtv/.alsasettings

5. Added the following lines below [startup] {} in the file /home/mythtv/.fluxbox/apps.
[startup] {alsactl restore -f /home/mythtv/.alsasettings}

At this point I still did not have any sound so I went into the mythtv settings and changed the volume mixer to /dsp. After that everything worked like a champ. Sound is just the right volume, and is in sync with the video.

Next thing is to set up my recording lights, remote (when it come in) and then port the whole thing to the TV as I have been running everything on the monitor so far.

Author:  ethernut [ Wed Dec 13, 2006 2:43 am ]
Post subject: 

I hate to be johnny-come-lately on this but I just created a WIKI entry for the Asus M2NPV-VM a few days ago. I just have my version of the audio fix on it right now (upgrading alsa), but I'll be adding more. I didn't realize this thread was here, if you have anything to add to the WIKI for this board please do so.

Right now I have working on the M2NPV-VM:

1. Audio with the latest Alsa
2. SPDIF Optical out with AC3 passthru (on HDTV)
3. 720P Component out on the Nvidia 6150+


The Ether..

Author:  steven_ellis [ Thu Dec 14, 2006 11:00 pm ]
Post subject: 

Got all of these things working also as we use this board in V2 of myPVR. If you have the correct alsa settings you can get away with 0.11

Anyone managed to get surround over the 3xstereo jacks on the back rather than SPDIF. Getting requests from customers for this.


Author:  spideyk21 [ Fri Dec 15, 2006 6:50 am ]
Post subject: 

steven_ellis wrote:
If you have the correct alsa settings you can get away with 0.11

Could you explain this a bit more?


Author:  steven_ellis [ Mon Dec 18, 2006 11:20 pm ]
Post subject: 

Ok my file /etc/alsa/modutils/1.0 contains

options snd-hda-intel model=3stack  position_fix=1

This seems to make the alsa audio work without any issues.

Author:  yarrumretep [ Wed Dec 27, 2006 8:26 am ]
Post subject:  DVI?

This board has DVI out - my HDTV has a DVI input - but I can't seem to get any HD resolutions working. It just reverts to 640x480 or so. Has anyone got the DVI output working with an HDTV? My tv is a Sony KV30XBR910.

Author:  ethernut [ Wed Dec 27, 2006 10:20 am ]
Post subject: 

I have the same board, but don't use the DVI, I use the Component Output. If you're interested in trying it, check out this post:

The Component out is extremely clear, which may satisfy you. Component aside, the post above should, at least, put on on the right track for DVI.

Author:  spideyk21 [ Thu Dec 28, 2006 6:58 am ]
Post subject: 

Upgraded to the latest version of KnoppMyth yesterday, R5E50, from R5D1. Everything went smooth but there are a few things that still need to be corrected.

1. Alsa Settings: I was able to get sound after I adjusted the alsa setting using alsamixer, but the settings are not reloaded after a restart. Also now alsamixer is throwing an error when I try to access it.

2. Recstat: Had this working on the previous version, LED Status Lights. It works now but I have to start the system by hand (/etc/init.d/recstat start). Will have to reset the link using:
update-rc.d -f recstat remove
update-rc.d recstat defaults 90

3. Apache & Apache2: My httpd.conf file is empty and the security for mythweb is set but I would like to change the user name and password to access it. Also MythWeb is constantly loosing connection when I switch from one page to the next. Originally used Securing MythWeb HowTo, but my httpd.conf is empty in the apache2 folder and nonexistent in the apache folder.

4. RRDTool: The link on the Knoppmyth Web page is valid up the graphs are not updating any info. Have to fix the cron job as stated in the R5E50 Upgrade hints and hazards post.

Check out the R5E50 Upgrade hints and hazards post. It has most of the fixes to my problems.

Hope to get all these problems resolved by the New Year.

Page 1 of 2 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group