LinHES Forums

ASUS P5B, Core 2 Duo E6700, and PATA HD and DVD
Page 1 of 1

Author:  wsweier [ Fri Jan 26, 2007 9:44 pm ]
Post subject:  ASUS P5B, Core 2 Duo E6700, and PATA HD and DVD

Long time reader, first time posting. Hopefully I can give enough details that this will make sense to other. First, here's the set-up as requested by the Sticky Post:

# Video type: HDTV OTA to SDTV
# Type of system: combined front- and back-end
# Noise level: I can tell it's on until I play some media. From the couch, at ~15ft, it is barely audible in a quiet room.

# CASE: Antec Overture II
# PSU: 450W (comes with case)
# CPU: Core 2 Dou E6700
# RAM: 1 GB of DDR2 5400 (667MHz GEIL)
# CPU HEATSINK: Nexus PHT-7750
# NORTHBRIDGE HEATSINK: Passive Heatsink comes with MB
# CD/DVD-RW: Pioneer 106D (DV+-R)
# HDD: Maxtor 300GB PATA
# GRAPHICS CARD: Nvidia 6600GT (noise fan replaced, see below)
# SOUNDCARD: None, using builtin on MB
# TUNER CARD: FusionHDTV Lite 5
# REMOTE CONTROL: None (was Hauppauge, see below

This system took several installs over several night to get right. The mother board is not fully functional yet, but let me get in to what I did to get the basic install to work.

Since this is an Intel 965 board, I had to use the 'intelfix' with the R5E50 version of knoppmyth. But this alone would not automatically install and gave various errors about not being able to find the hda3 or other hda devices. This lead me to this post which mostly works but would result in a corrupt system very quickly. ... controller

So here's what I did (with thanks to unkle and bruce_s01 for there post).

1) insert CD and used 'tv' and 'intelfix' at prompt
2) Select Manual install
3) Follow pamplet on seting up and initializing partitions. Yeah, the pamplet mentions a 4th cache partition but that is no longer needed. Take note of the names of the partions. Mine were hde1, hde5, hde6. Why it picked those, I dont' know enough to tell you.
4) Select Load Config. NOTE: This will fail with and error like this.
Error: Check failed fo HD_CHOICE (/dev/hda1), the configuration module will now be started. But by loading the configuration, some things like the time zone and box name are set for you. Then you have to choose where to install. Use the space bar to select the boot volume (hde1 in my case).
5) Select the Configure Installation Menu. The partition to install is already selected because of step 4. And when you get to the "preferred hostname", it is already set.
6) Select Start Installation. This also give an error for me but still works. The error was.
1.8a - http://acshi?? ????? mount: /dev/hda3 is not a valid block. (the question marks are for parts I couldn't read because the screen was over writen). Eventually, it says it installed to hd and all you can do is hit <enter> to accept the OK. For me it breaks to a prompt. If this doesn't happen for you, you may need to hit <Ctrl><Alt><F1> to do the next stuff.

Here's where the post above comes in handy. I'll repeat it here because I had to add a step or I ended up with a corrupt system. At the prompt do this.
mount /dev/hde1 /mnt/hde1
cd /mnt/hde1/etc
nano lilo.conf
nano fstab

While editing lilo and fstab, change any references to hda to hde. Also remember what your partition names are. Put the right names in were ever there is a reference to hda.
cd ..
chroot /mnt/hde1
lilo -v -b /dev/hde
shutdown -r now

Two notes here. One, I used -b option like bruce_s01 suggested but I always received an error. Didn't seem to hurt it though. Two, it took me a couple of night to figure out that the fstab needed to be edited. Remarkably, without it, it would let me reboot and go through the remainder of the setup and seem to work for a while. But as soon as I recorded something or deleted something, the whole sytem would get corrupted. Very frustrating. I happend to find that fstab had an hda reference by grepping for it in the /hde1/etc directory.

Here's the first Problem:
The on board network device will not work. It can not find a module for it. I've been trying to build this module but with no success. I'm going to try to fix it again but will document what I try so that I can post a question (or a howto fix) later. At any rate, I've tempararily install on old PCI NIC. Due to limited space, I removed my PVR150 (and remote) so that I can connect to my LAN. The HDTV tuner is still in.
<EDIT> I have posted the Ethernet module solution here:

Any ways, sytem is up and seems stable. I get HDTV OTA and use XvMC to scale it to my SD tv. I think I could tweak it some, but the Core 2 Duo is not revving up the fan so I'm not too worried about it. I have not tried anything with the DVD yet. I have a 6 Disk DVD player so I may not try to read or burn anything for a while. I have enable Samba and transfered a video from my Mac to the Myth box. Myth found it and played it fine. I have also used VNC and done editing from my Win PC box. Both are very nice options that are easy to setup or use.

The fan that came with my 6600GT sounded like a tornado. I could stand over 35ft away and easily hear it. I replaced the fan with an NV Silencer by Artic Cooling. This new fan is extremely quiet but covers the adjacent slot. On the P5B this means it covered 1 of my 3 PCI slots. I had not though through the whole noise issue when I bought the card. If I had to do it again, I'd go fanless.

If I missed some information let me know. And if the format looks bad, sorry, first time posting on forums. Really. I'm more of a reader than a poster.

Thanks to all for the hard work on Knoppmyth. It rocks!

<edited: tried to fix my signature. Still had R5B7 instead of R5E50>
<edited2: Added how to get 5.1 suround in a post below>

Author:  tuatara [ Tue Mar 20, 2007 4:00 pm ]
Post subject:  SPDIF

Did you get SPDIF working?
I'm interested in setting up a core duo mythbox
for a friend (can be made nice and quiet).

But we need SPDIF.


Author:  wsweier [ Tue Mar 20, 2007 8:09 pm ]
Post subject: 

Yes, but I'm not sure its 100% correct.

I have a coxial cable connecting my SPDIF to my Yamaha AV receiver. I get sound out for all my videos and OTA TV. I still have not tested the mythbox's DVD player.

Now here's the part I haven't figured out yet. If I enable the "AC3 to SPDIF passthrough" or "DTS to SPDIF passthrough" in the Utilities->Setup->General menu, I get the high frequency clicking of a digital signal out my speakers. So something is passing through, but I don't know why my receiver doesn't autodetect (it's set up to) and use the digital signal. I also tried forcing my reciever to use DTS decoding and I still get the clicking noise out of my speakers.

When I don't enable those buttons, my reciever's LCD display says it's getting a PCM signal and the sound is fine. But, the reciever also shows which speakers the sound it going to and it show it only going to L R (left/right) speakers. So, I'm only getting stereo. I thought show like 24 or Lost would be 5.1 surround. Since I had already spent too many days figuring out the "fstab/hda" thing above, I decided to use features on my receiver to extend the 2ch stereo to all my 7.1 speakers, so it sounds ok.
Therefore its not 100% correct.

Author:  tuatara [ Wed Mar 21, 2007 1:06 am ]
Post subject: 

Thanks for getting back to me.

I'm a little nervous to here there may be SPDIF issues with this
mobo - although it sounds like it *could* be that HD programs are
2 channel rather than 5.1.

Have you done the other ALSA -> SPDIF hacks? (search
on this website for SPDIF, I've done some work on it
for my own EPIA box with SPDIF output).
You also need to correct for 41K -> 48 conversions for music, and
set xine to use iec958.


Author:  wsweier [ Wed Mar 21, 2007 8:00 pm ]
Post subject: 

I'm a little nervous to here there may be SPDIF issues with this
mobo - although it sounds like it *could* be that HD programs are
2 channel rather than 5.1.

I wouldn't be too nervous about the SPDIF, it sortof just worked (from a simple 2ch hookup perspective). I believe the programs are 5.1, I just haven't taken the time to try all the ALSA->SPDIF hacks. My previous MB was an ASUS P5ND2-SLI (nVidia NForce4 chipset) and I never got the SPDIF to work, even when I tried all the hacks. Thanks for reminder of the hacks, one day I'll get back too it, just too busy right now.

I would be more nervous about the ethernet port working. That took some time to figure out. Until then, I used a PCI NIC, which meant I didn't have my hauppague remote because of the number of PCI slot on the P5B. See my link in the first post for how I got it to work.

Anyways, after spending way too many nights on the install and module build (plus some HD antenna issue), I burnt out on the tweaking thing. The SPDIF port is working and that is what I get my sound out of. It's enough for starting functionality and bring up. Please post back if you get it working with 5.1 sound.

Author:  tuatara [ Thu Mar 22, 2007 1:57 am ]
Post subject: 

Thanks for your feedback.

I've decided to take a different approach, since I'm building
this for someone else and I dont want to take a risk with
their money. I can get an old AMD-XP1800 based box
for NZ220 (about 150 USD) with disk, mem etc.

I'll buy that and get it going (low risk/$$ loss if I dont).
I'll spend the savings on silencing it.


Author:  wsweier [ Mon Jun 25, 2007 11:17 pm ]
Post subject:  SPDIF working with 5.1 surround

Well, I finally got some time this past weekend to figure out why I was only getting 2 ch out my spdif instead of 5.1. Below are the relatively easy steps to get it working (extremely easy as compared to bringing this box up).

First I started by opening a shell and typing:
 cat /proc/asound/pcm

All this really shows is that the on board audio chip is already setup as card 0 with device 0 being the analog output and device 1 being digital output. This is really good becasue next you need to read and understand the ALSA setup information here:

Since the device numbers for analog and digital match the asound.conf file found at the url above, copy and past it here:


and make it readable by mythtv
chmod a+r asound.conf

Note you need to be root. Don't forget to comment / uncomment out the appropriate line in the asound.conf file (i.e. use dmix-digital as your default).

At this point, I messed with the "alsamixer" but I don't think this is needed. Just so you know, I un-muted all the "Front", "Surround", "Center", "LFE", and "Side" sliders and set their volume to ~85%. Then did a "/usr/sbin/alsactl store" to store it. I've since remuted these and rebooted and I still have 5.1 sound.

What I think really got it to work was finding the magic combination of settings in the "Utilities and Setting -> Setup -> General" menu. Here's how I setup the sound on the 3rd page in this menu:

Audio output device= ALSA:spdif /*Case matters and you have to type it.
Pass Through output device= ALSA: iec958:{AE50 0x02} /*available in the menu, just select it
Check both: "Enable AC3 to SPDIF passthrough" and "Enable DTS to SPDIF passthrough"
Mixer Device = /dev/mixer
Mixer Controls= Master

After this my Yamaha reciever displayed 5.1 channels operating.

Other notes: I tried many settings inside the setup menu and using /dev/dsp, /dev/adsp, and ALSA:Default did not work. Next, I tried backing things out (i.e. the asound.conf and the alsamixer) settings and it became muted at some point. The only way it came back was keeping the asound.conf and mucking around in the setup menu. Even after replacing the asound.conf file, it stayed muted. I had to temporarily go back to a /dev/dsp (default) setting and turn off all the passthrough setting. This gave me 2 ch back. Then used the settings above to get back to 5.1 working.

The onboard audio sounds great. Hope this helps someone.

Author:  wsweier [ Sat Oct 06, 2007 1:37 pm ]
Post subject: 

About 2 week back, during the schedule direct/R5F27 update, I upgraded this box to R5F27. I have never upgraded a myth box before, so this process was a little more complicated than I hoped.

First, you can't do the "auto upgrade". You need to carefully read the "Hints and Tips" by tjc and use the "manual upgrade" option. Also, carefully read the "Pamphlet" on manual upgrading. Load the CD and follow the step in the "Hints" and "Pamphlet" for manual upgrading.

After following the Pamphlet, use my first post above and fix the lilo.conf and fstab file before the first reboot.

Finally, back to the "Hints and Tips" for fixing schedule direct. That got me 90% of the way there. Previously, in my first post above, I mentioned the ethernet port not working. The ethernet port worked throughout the whole process.

Two issues:
1) 5.1 Surround Sound: Basically it reverted back to 2 channel only. I Had to use alsaconf and then alsamixer. While in alsamixer I noticed that some of my sound devices had been muted for unknown reasons. Double check your alsamixer for MM vs 00. After I fixed that, I then did: "/usr/sbin/alsactl store" to ensure my changes were stored (as root of course).

2)Video Card: Through a combination of new TV (Yay! HDTV finally), Nvidia driver, and X11, I had to go through several iteration before I got the display working properly. I hit the dreaded "id "c7" respawning too fast" issue several times. There are many good post on how to solve that so I won't repeat it here.

Beside that, the system is up and running. Thanks again to all those that post valuable information in these forums.

Author:  graysky [ Tue Dec 04, 2007 2:33 am ]
Post subject: 

So did your network card work out-of-the-box with R5F27?

Author:  Greg Frost [ Tue Dec 04, 2007 3:32 am ]
Post subject: 

I have just setup a P5B box and my network had issues. I started with a PATA drive and the network sort of worked but when I turned my DVI connected TV off it would hang the network. Wierd. I then changed to a SATA drive and the network problems got worse (NIC shares an IRQ with the SATA controller) the network would be very slow. It was as if it was not getting any interrups from the network card and was relying on the occasional interrupt from the SATA drive. I also had stability problems. The box would hang when unattended.
I upgraded the kernel to 2.6.22 and the network and stability problems all seemed to go away. I'm a happy camper now.

Author:  graysky [ Tue Dec 04, 2007 2:53 pm ]
Post subject: 

Thanks for the post, Greg. Food for the thought.

Author:  Greg Frost [ Tue Dec 04, 2007 7:39 pm ]
Post subject: 

My only other annoyance with the P5B is the proximity of the first PCI slot to the PCIe x16 slot. Chances are the heatsink on your PCIe graphics will prevent you from using the first PCI slot.

Author:  wsweier [ Tue Dec 04, 2007 8:30 pm ]
Post subject: 

For me, the network card just continued to work. I did an upgrade from R5E50 to R5F27. I still have the PATA drive.

I'll also agree with Greg on the 3rd PCI slot being to close to the PCIex16. I mention this in my very first post. If you already have 3 PCI cards and need all three slots, beware. If your getting new hardware, you may want to consider some of the PCIe tuner cards.

Page 1 of 1 All times are UTC - 6 hours
Powered by phpBB® Forum Software © phpBB Group