View unanswered posts    View active topics

All times are UTC - 6 hours

Post new topic Reply to topic  [ 1 post ] 
Print view Previous topic   Next topic  
Author Message
Search for:
PostPosted: Wed Jul 25, 2007 10:37 am 
Joined: Thu Jan 04, 2007 11:51 pm
Posts: 7
This has turned into quite a project
I started out using another pc entirely and eventually got this P4 D865GLC motherboard w/ p4 2.4 cpu for a bargain on ebay.

Eventual hardware:
P4 D865GLC w 2.4Ghz cpu / 768 mb ram.
DViCO DVB-T Lite card & Leadtek winfast dv2000.
nvidia tnt2 agp video card (hey it has tv out and im not playing 3d games)
Seagate 160gig hdd
wd 6gig hdd (i backed up and unplugged it as i copied the configured base install files & database here if things ever fail)
Netgear WG311 54G wireless network card

Step one was getting capture to work correctly.
Default fedora fc6 kernel wouldn't correctly work for me, i eventually got everything working after downloading kernel and compiling it with a few customizations (removed drivers i wont need, i.e. 1gbit eth support / ISDN, etc). Added the nvidia binary driver for my TNT2,

Added dvb_bt8xx to modprobe.conf to allow the HDTV functions to work within the dvico, added options cx88 card=8 tuner=5 for the dv2000 card to function (as it turns out pci audio out is mangled on this card, use audio out to the soundcard)

created a .xmltv entry each for Analog & Digital (i tried using the same one for both, trust me, it doesn't work) and edited the appropriate file to suit (clue for any aussies, go here for a tv_grab_au & then beeline it to to set up an account for the tv guide. Scan and add the channels and tweak them to suit.
Install the dvico USB reciever and specify it in the setup that you're using and use info from here on setting up the keymaps. Worked like a trooper straight away.

Then I got the wireless networking to work correctly, it required me to get the win2k drivers off my cd onto the pc. then i had to issue the following commands to get it working.

        ndiswrapper -i /root/netgear311/WG311v3.INF
        modprobe ndiswrapper
        ndiswrapper -m
        iwconfig wlan0 essid my-ap <- your  WLAN SSID
        iwconfig wlan0 mode managed <- an ap = managed
        iwconfig wlan0 channel 11
        iwconfig wlan0 ap 00:91:44:A2:05:12  <- your AP mac address
        iwconfig wlan0 rate 54M auto
        #iwconfig wlan0 txpower auto
        iwconfig wlan0 key restricted AAAA-BBBB-CCCC-DDDD-EEEE-FFFF-AA  <- your encrypted key

Then i had to go into /etc/sysconfig/network-scripts and create a five ifcfg-wlan0 for the wireless device to be auto created upon bootup.


Now im just doing some final tweaking, mythweb works fine, i can schedule recordings, you may just need some playing with audio properties via gnome-volume-properties to ensure line in for the dv2000 card is only used for recording and not annoyingly played back out the line-out port (thats what i wasted a couple hours figuring out tonight)

From start to finish including the false starts with the early knoppmyth and mythdora installs i dare not figure how much time i wasted, it would be a couple thousand hours over about 6 months trying to get the bugger working. Just using mythdora4 i think i only wasted a couple hundred hours including using incorrect kernel compiles (that was the p.i.t.a)

Next on the list now is getting the TV out to work, but by comparison with the size of these other hurdles i've beaten i think im going to get that sorted quick smart.

Anyway, thats me :)


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 6 hours

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group

Theme Created By ceyhansuyu